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Introduction to Polyspace Products

+ “Overview of Polyspace Verification” on page 1-2
*  “The Value of Polyspace Verification” on page 1-3
+ “How Polyspace Verification Works” on page 1-5
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Introduction to Polyspace Products

Overview of Polyspace Verification

Polyspace products verify C, C++, and Ada code by detecting run-time errors before code
is compiled and executed. Polyspace verification uses formal methods not only to detect
errors, but to prove mathematically that certain classes of run-time errors do not exist.

To verify the source code, you set up verification parameters in a project, run the
verification, and review the results. A graphical user interface helps you to efficiently

review verification results. The software assigns a color to operations in the source code
as follows:

Green — Indicates that an operation is proven to not have certain kinds of error.

Red — Indicates that an operation is proven to have at least one error.

*  Gray — Indicates unreachable code.

Orange — Indicates that the operation can have an error along some execution paths.

The color-coding helps you to quickly identify errors and find the exact location of an
error in the source code. After you fix errors, you can easily run the verification again.



The Value of Polyspace Verification

The Value of Polyspace Verification

In this section...

“Enhance Software Reliability” on page 1-3
“Decrease Development Time” on page 1-3

“Improve the Development Process” on page 1-4

Enhance Software Reliability

Polyspace software enhances the reliability of your Ada applications by proving code
correctness and identifying run-time errors. Using advanced verification techniques,
Polyspace software performs an exhaustive verification of your source code.

Polyspace software can:

* Prove that your code has certain kinds of errors.
*  Prove that your code does not have certain kinds of errors.
+ Identify unreachable code.

+ Identify code that can have an error along some execution paths.

With this information, you know how much of your code does not contain run-time errors,
and you can improve the reliability of your code by fixing the errors.

Decrease Development Time

Polyspace software reduces development time by automating the verification process and
helping you to efficiently review verification results. You can use it at any point in the
development process, but using it during early coding phases allows you to find errors
when it is less costly to fix them.

You use Polyspace software to verify Ada source code before compile time. To verify the
source code, you set up verification parameters in a project, run the verification, and
review the results. This process takes significantly less time than using manual methods
or using tools that require you to modify code or run test cases.

Color-coding helps you to quickly identify errors. You will spend less time debugging
because you can see the exact location of an error in the source code. After you fix errors,
you can easily run the verification again.
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Polyspace verification software helps you to use your time effectively. Because you know
the parts of your code that do not have errors, you can focus on the code with proven (red
code) or potential errors (orange code).

Reviewing the code that might have errors (orange code) can be time-consuming, but
Polyspace software helps you with the review process. You can use filters to focus on
certain types of errors or you can allow the software to identify the code that you should
review.

Improve the Development Process

Polyspace software makes it easy to share verification parameters and results, allowing
the development team to work together to improve product reliability. Once verification
parameters have been set up, developers can reuse them for other files in the same
application.

Polyspace verification software supports code verification throughout the development
process:

* An individual developer can find and fix run-time errors during the initial coding
phase.
* Quality assurance can check overall reliability of an application.

+ Managers can monitor application reliability by generating reports from the
verification results.
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How Polyspace Verification Works

Polyspace software uses static verification to prove the absence of run-time errors. Static
verification derives the dynamic properties of a program without actually executing it.
This technique differs significantly from other techniques, such as run-time debugging,
in that the verification it provides is not based on a given test case or set of test cases.
The dynamic properties obtained in the Polyspace verification are true for all executions
of the software.

What is Static Verification

Static verification is a broad term, and is applicable to any tool which derives dynamic
properties of a program without actually executing it. However, most static verification
tools only verify the complexity of the software, in a search for constructs which may be
potentially erroneous. Polyspace verification provides deep-level verification identifying
most run-time errors and possible access conflicts on global shared data.

Polyspace verification works by approximating the software under verification, using
representative approximations of software operations and data.

For example, consider the following code:

for (i=0 ; i<1000 ; ++i)
{ tab[i] = foo(i);
}

To check that the variable 1 does not overflow the range of tab, a traditional approach
would be to enumerate each possible value of i. One thousand checks would be required.

Using the static verification approach, the variable 1 is modelled by its domain variation.
For instance, the model of i is that it belongs to the [0..999] static interval. (Depending
on the complexity of the data, convex polyhedrons, integer lattices and more elaborate
models are also used for this purpose).

An approximation usually leads to information loss. For instance, the information that

i is incremented by one every cycle in the loop is lost. However, the important fact is
that this information is not required to ensure that a range error will not occur; it is only
necessary to prove that the domain variation of 1 is smaller than the range of tab. Only
one check is required to establish that — and hence the gain in efficiency compared to
traditional approaches.
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Static code verification has an exact solution. However, this exact solution is not
practical, as it would require the enumeration of all possible test cases. As a result,
approximation is required for a usable tool.

Exhaustiveness

Nothing is lost in terms of exhaustiveness. The reason is that Polyspace verification
works by performing upper approximations. In other words, the computed variation
domain of a program variable is a superset of its actual variation domain. The direct
consequence is that a runtime error (RTE) item to be checked cannot be missed by
Polyspace verification.
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* “Polyspace Verification and the Software Development Cycle” on page 2-2
+ “Implementing a Process for Polyspace Verification” on page 2-4

+ “Sample Workflows for Polyspace Verification” on page 2-9
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Polyspace Verification and the Software Development Cycle

2-2

In this section...

“Software Quality and Productivity” on page 2-2

“Best Practices for Verification Workflow” on page 2-3

Software Quality and Productivity

The goal of most software development teams is to maximize both quality and
productivity. However, when developing software, you must consider the following
factors:

+ Cost

*  Quality

* Time

Cost Time
Quality

Changing the requirements for one of these factors can impact the other two.

Generally, the criticality of your application determines the balance between these three
variables — your quality model. With classical testing processes, development teams
generally try to achieve their quality model by testing the modules in an application
until each module meets the required quality level. Unfortunately, this process often
ends before quality requirements are met, because the available time or budget has been
exhausted.

Polyspace verification allows a different process. Polyspace verification can support both
productivity improvement and quality improvement at the same time, although you have
to reach a balance between these goals.

To achieve maximum quality and productivity, however, you cannot simply perform code
verification at the end of the development process. You must integrate verification into
your development process, in a way that respects time and cost restrictions.




Polyspace Verification and the Software Development Cycle

This chapter describes how to integrate Polyspace verification into your software
development cycle. It explains both how to use Polyspace verification in your current
development process, and how to change your process to get more out of verification.

Best Practices for Verification Workflow

Polyspace verification can be used throughout the software development cycle. However,
to maximize both quality and productivity, the most efficient time to use it is early in the
development cycle.

Requirements Validation Testing

Functional Design Integration Testing

Module Testing

2
PolySpace®

Code Code
Analysis  Verification

Polyspace Verification in the Development Cycle

Typically, verification is conducted in two stages. First, you verify code as it is written, to
check coding rules and quickly identify obvious defects. Once the code is stable, you verify
it again before module/unit testing, with more stringent verification and review criteria.

Using verification at this stage of the development cycle improves both quality and
productivity, because it allows you to find and manage defects soon after the code is
written. This saves time because each developer is familiar with their own code, and can
quickly determine why the code contains defects. In addition, defects are cheaper to fix at
this stage as they can be addressed before the code is integrated into a larger system.
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Implementing a Process for Polyspace Verification

2-4

In this section...

“Overview of the Polyspace Process” on page 2-4
“Defining Quality Goals” on page 2-4
“Defining a Verification Process to Meet Your Goals” on page 2-7

“Applying Your Verification Process to Assess Code Quality” on page 2-7

“Improving Your Verification Process” on page 2-7

Overview of the Polyspace Process

Polyspace verification cannot automatically produce quality code at the end of the
development process. However, if you integrate Polyspace verification into your
development process, Polyspace verification helps you to measure the quality of your
code, identify issues, and ultimately achieve your own quality goals.

To implement Polyspace verification within your development process, you must perform
each of the following steps:

1 Define your quality goals.

2 Define a process to match your quality goals.

3  Apply the process to assess the quality of your code.
4 Improve the process.

Defining Quality Goals

Before you can verify whether your code meets your quality goals, you must define those
goals. This process involves:

+ “Choosing Robustness or Contextual Verification” on page 2-4

+ “Defining Software Quality Levels” on page 2-6
Choosing Robustness or Contextual Verification

Before using Polyspace products to verify your code, you must decide what type of
software verification you want to perform. There are two approaches to code verification
that result in slightly different workflows:
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* Robustness Verification — Prove software does not generate run-time errors for all
verification conditions.

+ Contextual Verification — Prove software does not generate run-time errors under
normal working conditions.

Note: Some verification processes may incorporate both robustness and contextual
verification. For example, developers may perform robustness verification on individual
files early in the development cycle, while writing the code. Later, the team may perform
contextual verification on larger software components.

Robustness Verification

Robustness verification proves that the software does not generate run-time errors under
all verification conditions, including “abnormal” conditions for which it was not designed.
This can be thought of as “worst case” verification.

By default, Polyspace software assumes you want to perform robustness verification. In a
robustness verification, Polyspace software:

+ Assumes function inputs are full range

+ Initializes global variables to full range

+ Automatically stubs missing functions

While this approach ensures that the software works under all verified conditions, it can
lead to orange checks (unproven code) in your results. You must then manually inspect
these orange checks in accordance with your software quality goals.

Contextual Verification

Contextual verification proves that the software works under predefined working
conditions. This limits the scope of the verification to specific variable ranges, and
verifies the code within these ranges.

When performing contextual verification, you use Polyspace options to reduce the
number of orange checks. For example, you can:

+ Use Data Range Specifications (DRS) to specify the ranges for your variables,
thereby limiting the verification to these cases. For more information, see “Inputs &
Stubbing”.
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+ Create a detailed main program to model the call sequence, instead of using the
default main generator. For more information, see “Manually Generating a Main” on
page 4-8.

*  Provide manual stubs that emulate the behavior of missing functions, instead of
using the default automatic stubs. For more information, see “Manual vs. Automatic
Stubbing” on page 5-3.

Defining Software Quality Levels

The software quality level you define determines which Polyspace options you use, and
which results you must review.

You define the quality levels for your application, from level SQL-1 (lowest) to level
SQL-4 (highest). Each quality level consists of a set of software quality criteria that
represent a certain quality threshold. For example:

Software Quality Levels

Criteria Software Quality Levels
SQL1 SQL2 SQL3 SQL4

Document static information X X X X
Review all red checks X X X X
Review all gray checks X X X X
Review first criteria level for orange checks X X X
Review second criteria level for orange checks X X
Perform dataflow analysis X X
Review third criteria level for orange checks X

In the example above, the quality criteria include:

+ Static Information — Includes information about the application architecture, the
structure of each module and file. Full verification of your application requires the
documentation of static information.

* Red checks — Represent errors that occur every time the code is executed.
* Gray checks — Represent unreachable code.
* Orange checks — Indicate unproven code, meaning a run-time error may occur. .

+ Dataflow analysis — Identifies errors such as non-initialized variables and variables
that are written but not subsequently read. This can include inspection of:
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+ Application call tree
+ Read/write accesses to global variables

* Shared variables and their associated concurrent access protection

Defining a Verification Process to Meet Your Goals

Once you have defined your quality goals, you must define a process that allows you to
meet those goals. Defining the process involves actions both within and outside Polyspace
software.

These actions include:

+ Setting standards for code development, such as coding rules.

+ Setting Polyspace Analysis options to match your quality goals. See “Specify Analysis
Options” on page 3-3.

+ Setting review criteria in the Polyspace user interface so that results are reviewed
consistently. See “Review Results”.

Applying Your Verification Process to Assess Code Quality

Once you have defined a process that meets your quality goals, it is up to your
development team to apply it consistently to all software components.

This process includes:

1 Running a Polyspace verification for each software component as it is written.
2 Reviewing verification results consistently. See “Results Management”.

3 Saving review comments for each component, so they are available for future review.
See “Add Review Comments to Results” on page 8-32.

4 Performing additional verifications on each component, as defined by your quality
goals.

Improving Your Verification Process
Once you review initial verification results, you can assess both the overall quality

of your code, and how well the process meets your requirements for software quality,
development time, and cost restrictions.
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Based on these factors, you may want to take actions to modify your process. These
actions may include:

Reassessing your quality goals.

Changing your development process to produce code that is easier to verify.

Changing Polyspace analysis options to improve the precision of the verification.

Changing Polyspace options to change how verification results are reported.

For more information, see “Reduce Orange Checks” on page 9-13.
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Sample Workflows for Polyspace Verification

In this section...

“Overview of Verification Workflows” on page 2-9

“Software Developers — Standard Development Process” on page 2-9
“Software Developers — Rigorous Development Process” on page 2-11
“Quality Engineers — Code Acceptance Criteria” on page 2-14

“Project Managers — Integrating Polyspace Verification with Configuration
Management Tools” on page 2-16

Overview of Verification Workflows
Polyspace verification supports two goals at the same time:

*  Reducing the cost of testing and validation

* Improving software quality

You can use Polyspace verification in different ways depending on your development
context and quality model. The primary difference being how you exploit verification
results.

This section provides sample workflows that show how to use Polyspace verification in a

variety of development contexts.

Software Developers - Standard Development Process

User Description

This workflow applies to software developers using a standard development process.
Before implementing Polyspace verification, these users fit the following criteria:

* In Ada, unit test tools or coverage tools are not used — functional tests are performed
just after coding.
+ In C, either coding rules are not used, or rules are not followed consistently.

Quality

The main goal of Polyspace verification is to improve productivity while maintaining or
improving software quality. Verification helps developers find and fix bugs more quickly
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than other processes. It also improves software quality by identifying bugs that otherwise
might remain in the software.

In this process, the goal is not to completely prove the absence of errors. The goal is to
deliver code of equal or better quality than other processes, while optimizing productivity
to provide a predictable time frame with minimal delays and costs.

Verification Workflow

This process involves file-by-file verification immediately after coding, and again just
before functional testing.

Requirements Validation Testing

Functional Design Integration Testing

Coding Module Testing

PonSpéfcle®

Code Verification

The verification workflow consists of the following steps:

1 The project leader configures a Polyspace project to perform robustness verification,
using default Polyspace options.

Note: This means that verification uses the automatically generated “main” function.
This main will call unused procedures and functions with full range parameters.

2 Each developer performs file-by-file verification as they write code, and reviews
verification results.

The developer fixes red errors and examines gray code identified by the verification.
Until coding is complete, the developer repeats steps 2 and 3 as required.
Once a developer considers a file complete, they perform a final verification.

o 0 bW

The developer fixes red errors, examines gray code, and performs a selective orange
review.
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Note: The goal of the selective orange review is to find as many bugs as possible
within a limited period of time.

Using this approach, it is possible that some bugs may remain in unchecked oranges.
However, the verification process represents a significant improvement from the previous
process.

Costs and Benefits
When using verification to detect bugs:

* Red and gray checks — The number of bugs found in red and gray checks varies,
but approximately 40% of verifications reveal one or more red errors or bugs in gray
code.

* Orange checks — The time required to find one bug varies from 5 minutes to 1
hour, and is typically around 30 minutes. This represents an average of two minutes
per orange check review, and a total of 20 orange checks per package in Ada and 60
orange checks per file in C.

Disadvantages to this approach:

* Setup time — the time required to set up your verification will be higher if you do
not use coding rules. You may have to make modifications to the code before starting
the verification.

Software Developers — Rigorous Development Process
User Description

This workflow applies to software developers and test engineers working within
development groups. These users are often developing software for embedded systems,
and typically use coding rules.

These users typically want to find bugs early in the development cycle using a tool that is
fast and iterative.

Quality

The goal of Polyspace verification is to improve software quality with equal or increased
productivity.
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Verification can prove the absence of run-time errors, while helping developers find and
fix bugs more quickly than other processes.

Verification Workflow

This process involves both code analysis and code verification during the coding phase,
and thorough review of verification results before module testing. It may also involve
integration analysis before integration testing.

Integration Testing

Module Testin

Code Analysis  Code Verification

f Y

Textual _| Application | Module '\‘Hand—written/’ | Object
Requirements "1 Design "1 Design Code Code

Writing

Compilation
Code

and Linking

[ ] Development Artifact
@ Software Development Activity

Verification of
C and C++ Code

Workflow for Code Verification

Note: Solid arrows in the figure indicate the progression of software development
activities.

The verification workflow consists of the following steps:

1 The project leader configures a Polyspace project to perform contextual verification.
This involves:

+  Creates a “main” program to model call sequence, instead of using the
automatically generated main.

2-12



Sample Workflows for Polyspace Verification

+  Sets options to check the properties of some output variables. For example, if a
variable y is returned by a function in the file and should always be returned
with a value in the range 1 to 100, then Polyspace can flag instances where that
range of values might be breached.

The project leader configures the project to check the required coding rules.

Each developer performs file-by-file verification as they write code, and reviews both
coding rule violations and verification results.

The developer fixes coding rule violations, fixes red errors, examines gray code, and
performs a selective orange review.

Until coding is complete, the developer repeats steps 2 and 3 as required.
Once a developer considers a file complete, they perform a final verification.

The developer performs an exhaustive orange review on the remaining orange
checks.

Note: The goal of the exhaustive orange review is to examine all orange checks that
were not reviewed as part of previous reviews. This is possible when using coding
rules because the total number of orange checks is reduced, and the remaining
orange checks are likely to reveal problems with the code.

Optionally, an additional verification can be performed during the integration phase. The
purpose of this additional verification is to track integration bugs, and review:

Red and gray integration checks;

The remaining orange checks with a selective review: Integration bug tracking.

Costs and Benefits

With this approach, Polyspace verification typically provides the following benefits:

3-5 orange and 3 gray checks per file, yielding an average of 1 bug. Often, 2 of the
orange checks represent the same bug, and another represent an anomaly.

Typically, each file requires two verifications before it can be checked-in to the
configuration management system.

The average verification time is about 15 minutes.
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Note: If the development process includes data rules that determine the data flow
design, the benefits might be greater. Using data rules reduces the potential of
verification finding integration bugs.

If performing the optional verification to find integration bugs, you may see the following
results. On a typical 50,000 line project:

* A selective orange review may reveal one integration bug per hour of code review.

+ Selective orange review takes about 6 hours to complete. This is long enough to
review orange checks throughout the whole application and represents a step towards
an exhaustive orange check review. Spending more time is unlikely to be efficient.

* An exhaustive orange review takes between 4 and 6 days, assuming that 50,000 lines
of code contains approximately 400—800 orange checks.

Quality Engineers — Code Acceptance Criteria
User Description

This workflow applies to quality engineers who work outside of software development
groups, and are responsible for independent verification of software quality and
adherence to standards.

These users generally receive code late in the development cycle, and may even be
verifying code that is written by outside suppliers or other external companies. They are
concerned with not just detecting bugs, but measuring quality over time, and developing
processes to measure, control, and improve product quality going forward.

Quality

The main goal of Polyspace verification is to control and evaluate the safety of an
application.

The criteria used to evaluate code can vary widely depending on the criticality of the
application, from absence of red errors only to exhaustive oranges review. Typically,
these criteria become increasingly stringent as a project advances from early, to
intermediate, and eventually to final delivery.

For more information on defining these criteria, see “Defining Software Quality Levels”
on page 2-6.
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Verification Workflow

This process usually involves both code analysis and code verification before validation
phase, and thorough review of verification results based on defined quality goals.

Requirements Validation Testing
Original A ®
Equipment PolySpace
Manufacturer i
Code Verification
Functional Design Integration Testing
Sub-contractor]|
Coding Module Testing

Note: Verification is often performed multiple times, as multiple versions of the software
are delivered.

The verification workflow consists of the following steps:

1

Quality engineering group defines clear quality goals for the code to be written,
including specific quality levels for each version of the code to be delivered (first,
intermediate, or final delivery) For more information, see “Defining Quality Goals”
on page 2-4.

Development group writes code according to established standards.
Development group delivers software to the quality engineering group.

The project leader configures the Polyspace project to meet the defined quality goals,
as described in “Defining a Verification Process to Meet Your Goals” on page 2-7.

Quality engineers perform verification on the code.

Quality engineers review red errors, gray code, and the number of orange checks
defined in the process.

Note: The number of orange checks reviewed often depends on the version of
software being tested (first, intermediate, or final delivery). This can be defined by
quality level (see “Defining Software Quality Levels” on page 2-6).
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7 Quality engineers create reports documenting the results of the verification, and
communicate those results to the supplier.

8 Quality engineers repeat steps 5—7 for each version of the code delivered.
Costs and Benefits

The benefits of code verification at this stage are the same as with other verification
processes, but the cost of fixing faults is higher, because verification takes place late in
the development cycle.

It is possible to perform an exhaustive orange review at this stage, but the cost of doing
so can be high. If you want to review all orange checks at this phase, it is important to
use development and verification processes that minimize the number of orange checks.
This includes:

+  Developing code using strict coding and data rules.

*  Providing accurate manual stubs for unresolved function calls.

+ Using DRS to provide accurate data ranges for input variables.

Taking these steps will minimize the number of orange checks reported by the

verification, and make it likely that remaining orange checks represent true issues with
the software.

Project Managers — Integrating Polyspace Verification with Configuration
Management Tools

User Description

This workflow applies to project managers responsible for establishing check-in criteria
for code at different development stages.

Quality

The goal of Polyspace verification is to test that code meets established quality criteria
before being checked in at each development stage.

Verification Workflow

The verification workflow consists of the following steps:
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Project manager defines quality goals, including individual quality levels for each
stage of the development cycle.

Project leader configures a Polyspace project to meet quality goals.

Developers run verification at the following stages:

+ Daily check-in — On the files currently under development. Compilation must
complete without the permissive option.
Pre-unit test check-in — On the files currently under development.

* Pre-integration test check-in — On the whole project, ensuring that
compilation can complete without the permissive option. This stage differs from
daily check-in because link errors are highlighted.

+  Pre-build for integration test check-in — On the whole project, with
multitasking aspects accounted for as required.

Pre-peer review check-in — On the whole project, with multitasking aspects
accounted for as required.

Developers review verification results for each check-in activity to confirm that the
code meets the required quality level. For example, the transition criterion could be:
“No bug found within 20 minutes of selective orange review”
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* “Create Project Manually” on page 3-2

+  “Create Project Using Template” on page 3-6
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* “Choosing Strict or Permissive Verification Options” on page 3-21
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Create Project Manually

3-2

To create a project manually, you must know:

* Location of your source files

* Location of your include files

Tip In the Polyspace user interface, you can quickly change to an arrangement of panes
dedicated to project setup. Select Window > Reset Layout > Project Setup.

Create Project

This example shows how to create a new project.

1 Select File > New Project.

2 In the Project — Properties dialog box, enter the following information:

* Project name

Location: Folder where you will store the project file with extension .psprj.
You can use this file to open an existing project.

The software assigns a default location to your project. You can change this
default on the Project and Results Folder tab in the Polyspace Preferences
dialog box.

3 Add source files to your project.
Navigate to the location where you stored your source files. Select each source
file. Click Add Source Files.

* To add all files in a folder and its subfolders, select the option Add recursively.
Select the folder. Click Add Source Files.

Often, compilers add symbolic links in your source folders during compilation. If
your folder contains symbolic links to other folders but you do not want to add

source files from the other folders, select Exclude symbolic links (Linux® only).

4  Add include folders to your project. The software adds standard include files to your

project. However, you must explicitly add folders containing your custom include
files.
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+ Navigate to the folder containing your include files. Select the folder and click
Add Include Folders.

+ If you do not want to add subfolders of the folder, clear Add recursively. Select
the folder and click Add Include Folders.

5 Click Finish.
The new project opens in the Project Browser pane. Your source files are
automatically copied to the first module in the project.

6 Save the project. Select File > Save or enter Ctrl+S.

To close the project at any time, in the Project Browser, right-click the project node
and select Close.

Specify Analysis Options

You can either retain the default analysis options used by the software or change them to
your requirements.

Each project consists of one or more modules. Before running verification on a module,
you can change the analysis options. Each module has a Configuration that consists of
the default analysis options. To change the analysis options:

1 On the Project Browser, below the Configuration node of the module, select the
configuration.

2 Change the options on the Configuration pane.
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Demo_Ada X

-~ Machine Configuration

: Target & Compiler
Target & Compiler

Macros

“ Envirenment Settings
E—J---‘v‘_eriﬁcation Made Target Environment
- Inputs & Stubbing

Target operating system | no-predefined-05 -

Verification Assumptions

‘. Precision Target processor type | sparc -

----- Reporting Files extensions *ad[sa]
----- Advanced Settings

|:| Remove ambiguities in comparison operators

Value of the constant Storage_Unit

For instance:

To specify the target processor, select Target & Compiler in the Configuration
tree view. Select your processor from the Target processor type drop-down list.

To specify verification precision, select Verification Mode > Precision. Select a
number from the Precision level drop-down list.

You can also create another configuration in your module. For more information, see
“Create Configurations in Module” on page 3-12.

For more information on the options, see “Analysis Options”.

Specify Results Folder

This example shows how to specify a results folder. In the Project Browser pane, the
folder appears as a node under the Result node of your project. By default, the software
creates a new results folder for each analysis. Before starting an analysis, you can choose
to overwrite an existing results folder. For example, if you stopped an analysis before
completion and want to restart it, you can overwrite a results folder.

To create a new folder, on the Project Browser pane, select Create new result
folder.
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+ By default, the new folder is created in Project_folder /Module name.
Project_folder is the project location you specified when creating a new project.

* You can also create a parent folder for storing your results. Select Tools >
Preferences and enter the parent folder location on the Project and Results
Folder tab. If you enter a parent folder location, any new result folder will be
created under this parent folder.

To overwrite an existing folder that is open in the Project Browser pane, clear

Create new result folder. Before running verification, select the result that you

want to overwrite.

To store results in a folder that is not open in the Project Browser, right-click the

Result node. Select Choose a Result folder. Select the folder where you want your

results stored.

When you start the verification, the software saves the results in the specified folder.
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Create Project Using Template

A Project Template is a predefined set of analysis options for a specific compilation
environment. When creating a new project, you can do one of the following:

+ Use an existing template to automatically set analysis options for your compiler.

Polyspace provides predefined templates for common compilers such as Aonix,
Rational, and GreenhilIs. For additional templates, see Polyspace Compiler
Templates .

* Set analysis options manually. You can then save your options as a template and
reuse them later.

Use Predefined Template

1 Select File > New Project.

2 On the Project — Properties dialog box, after specifying the project name and
location, under Project configuration, select Use template.

3  On the next screen, select the template that corresponds to your compiler. For
further details on a template, select the template and view the Description column
on the right.

If your compiler does not appear in the list of predefined templates, select Baseline.

4  On the next screen, add your source files and include folders. For more information,
see “Create Project Manually” on page 3-2.

Create Your Own Template

This example shows how to save a configuration from an existing project and create a
new project using the saved configuration.

* To create a template from a project that is open on the Project Browser pane:

1 Right-click the project configuration that you want to use, and then select Save
As Template.
2 Enter a description for the template, then click Proceed. Save your template file.

* When you create a new project, to use a saved template:
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Create Project Using Template

Select ’ '{IF' Add custom template. ..

Navigate to the template that you saved earlier, and then click Open. The new
template appears in the Custom templates folder on the Templates browser.

Select the template for use.
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l
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Update Project

3-8

You can manually add source files and include folders to an existing project, or change
the analysis options.

Tip In the Polyspace user interface, you can quickly change to an arrangement of panes
dedicated to project setup. Select Window > Reset Layout > Project Setup.

Add Sources and Includes

1

In the Project Browser, right-click your project or the Source or Include folder in
your project.

Select Add Source.

Add source files to your project.

Navigate to the location where you stored your source files. Select each source
file. Click Add Source Files.

To add all files in a folder and its subfolders, select the option Add recursively.
Select the folder. Click Add Source Files.

Often, compilers add symbolic links in your source folders during compilation. If
your folder contains symbolic links to other folders but you do not want to add
source files from the other folders, select Exclude symbolic links (Linux only).

Add include folders to your project. The software adds standard include files to your
project. However, you must explicitly add folders containing your custom include
files.

+ Navigate to the folder containing your include files. Select the folder and click
Add Include Folders.

+ If you do not want to add subfolders of the folder, clear Add recursively. Select
the folder and click Add Include Folders.

Click Finish.

Before running a verification, you must copy the source files to a module.

a Select the source files that you want to copy. To select multiple files together,
press the Ctrl key while selecting the files.

b Right-click your selection.
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¢ Select Copy to > Module_n. n is the module number.

Manage Include File Sequence

You can change the order of include folders to manage the sequence in which include files
are compiled.

When multiple include files by the same name exist in different folders, you might want
to change the order of include folders instead of reorganizing the contents of your folders.
For a particular include file name, the software includes the file in the first include folder
under Project_Name > Include.

In the following figure, Folder_1 and Folder_2 contain the same include file
include.h. If your source code includes this header file, during compilation, Folder_2/
include.h is included in preference to Folder_1/include.h.

—E Include

To change the order of include folders:

1 In the Project Browser, expand the Include folder.

2 Select the include folder that you want to move.

=

v

To move the folder, click either 2 or ¥ on the Project Browser toolbar.

Change Analysis Options

For later verifications, you might have to change your analysis options. For instance:

* To avoid compilation errors in Polyspace for constructs that are allowed by your
compiler, specify your target and compiler options.
For more information, see “Target & Compiler”.

+ If you provide partially developed code, you can specify external constraints to stand
in for the remaining code. Towards the end of your development cycle, as you provide
more complete code for verification, you can remove some of these constraints.
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For more information, see “Inputs & Stubbing”.

+ If your code is intended for multitasking, you can specify your entry points and
protection mechanisms.

For more information, see “Verification Mode”.

+ To allow Polyspace to prove more operations and therefore produce fewer non-critical
orange checks, you can specify appropriate options.

For more information, see “Reduce Orange Checks” on page 9-13.

For more information, see “Specify Analysis Options” on page 3-3.
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Modularize Project

You can create multiple modules in a Polyspace Code Prover™ project. In each module,
you can copy all or some of your source files.

On the Project Browser pane, each module contains the following nodes.

Node Content

Source All or some of the source files in the project.
When you run verification on the module,
the software verifies these source files.

Configuration One or more configurations. Each
configuration consists of a set of analysis
options.

Result One or more results.

In your file system, each module corresponds to a subfolder of your project folder.

Note: If you add your source files when creating a new project, they are automatically

copied to the first module, Module_1. If you add them later, you must copy them
manually to a module.

In this section...

“Create New Module” on page 3-11

“Create Configurations in Module” on page 3-12

Create New Module

Suppose you have one module, Module_1, in your project.

1 Do one of the following on the Project Browser pane:

Select your project. Click the e button on the Project Browser toolbar.

Right-click your project or the existing module. Select Create New Module.
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You see a new module, Module_2, in your project.

In your project, below the Source node, right-click the files that you want to add to
the module. From the context menu, select Copy to > Module_2.

The software displays these files below the Source node of Module_2.

Create Configurations in Module

By default, when you create a new module, it contains a configuration with the default
analysis options. To run verification on the module with different options, do one of the
following:

Change the analysis options in this configuration.

Create a new configuration and change the options in the new configuration. You can
retain the default analysis options in the original configuration.

Tip To copy a configuration to another module, right-click the configuration. Select

Copy Configuration to > Module_name.

To create a new configuration in your module:

1

Right-click the Configuration folder in the module. From the context menu, select
Create New Configuration.

*  On the Project Browser pane, the software displays a new configuration
project _name_1. To rename the configuration, double-click it.

On the Configuration pane, the new configuration appears as an additional tab.
On the Configuration pane, specify the analysis options for the new configuration.

To use this new configuration, double-click it.

When you run a new verification on the module, it uses the analysis options in this
configuration.

To see the configuration you used for a certain result, right-click the result on the
Project Browser. Select Open Configuration.

You can see a read-only form of the configuration.
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Note: If you are viewing the results and do not have the corresponding project open
on your Project Browser, to see the configuration you used, select the link View
configuration for results on the Dashboard pane.
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Organize Layout of Polyspace User Interface

3-14

The Polyspace user interface has two default layouts of panes.

The default layout for project setup has the following arrangement of panes:

Project Browser Configuration

Output Summary

The default layout for results review has the following arrangement of panes:

Results Summary Result Details

Dashboard

You can create and save your own layout of panes. If the current layout of the user
interface does not meet your requirements, you can use a saved layout.

You can also change to one of the default layouts of the Polyspace user interface. Select
Window > Reset Layout > Project Setup or Window > Reset Layout > Results
Review.

Create Your Own Layout

To create your own layout, you can close some of the panes, open some panes that are not
visible by default, and move existing panes to new locations.

To open a closed pane, select Window > Show/Hide View > pane_name.
To move a pane to another location:
1  Float the pane in one of three ways:
Click and drag the blue bar on the top of the pane to float all tabs in that pane.

For instance, if Project Browser and Results Summary are tabbed on the
same pane, this action floats the pane together with its tabs.

+ Click and drag the tab at the bottom of the pane to float only that tab.
For instance, if Project Browser and Results Summary are tabbed on the

same pane, dragging out Project Browser creates a pane with only Project
Browser on it and floats this new pane.



Organize Layout of Polyspace User Interface

*  Click =l on the top right of the pane to float all tabs in that pane.

2 Drag the pane to another location until it snaps into a new position.

If you want to place the pane in its original location, click [l in the upper-right
corner of the floating pane.

For instance, you can create your own layout for reviewing results.

Save and Reset Layout

After you have created your own layout, you can save it. You can change from another
layout to this saved layout.

+ To save your layout, select Window > Save Current Layout As. Enter a name for
this layout.
* To use a saved layout, select Window > Reset Layout > layout_name.

* To remove a saved layout from the Reset Layout list, select Window > Remove
Custom Layout > layout_name.

3-15



3 Setting Up a Verification Project

Customize Results Location and Folder Name
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By default, the software saves verification results in Module_(#) subfolders within the
project folder. However, through the Polyspace Preferences dialog box, you can define a
parent folder for your results.

B WO —

Select Tools > Preferences.
On the Project and Results Folder tab, select Create new result folder.
In the Parent results folder location field, specify the location that you want.

If you require a subfolder, select the Add a subfolder using the project name
check box. This subfolder takes the name of the project.

If required, specify additional formatting options for the folder name . The options
allow you to incorporate the following information into the name of the results folder:
* Result folder prefix — A string that you define. Default is Result.

Project variable — Project, module, and configuration.
+ Date format — Date of verification
* Time format — Time of verification

Counter — Count value that automatically increments by one with each
verification

For each verification, the software now creates a new results folder
ResultFolderPrefix_ProjectVariable DateFormat_TimeFormat_Counter.

Note: If you do not specify a parent results folder, the software uses the active module
folder as the parent folder.
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Specify External Text Editor

This example shows how to change the default text editor for opening source files from
the Polyspace interface. By default, if you open your source file from the user interface, it
opens on a Code Editor tab. If you prefer editing your source files in an external editor,
you can change this default behavior.

A WN -

Select Tools > Preferences.
On the Polyspace Preferences dialog box, select the Editors tab.
From the Text editor drop-down list, select External.

In the Text editor field, specify the path to your text editor. For example:

C:\Program Files\Windows NT\Accessories\wordpad.exe

To make sure that your source code opens at the correct line and column in your
text editor, specify command-line arguments for the editor using Polyspace macros,
$FILE, $LINE and $COLUMN. Once you specify the arguments, when you right-click
a check on the Results Summary pane and select Open Editor, your source code
opens at the location of the check.

Polyspace has already specified the command-line arguments for the following
editors:

* Emacs
Notepad++ — Windows" only
+ UltraEdit
+ VisualStudio
+ WordPad — Windows only
+ gVim
If you are using one of these editors, select it from the Arguments drop-down list.

If you are using another text editor, select Custom from the drop-down list, and
enter the command-line options in the field provided.

For console-based text editors, you must create a terminal. For example, to specify
Vi:

a In the Text Editor field, enter Zusr/bin/xterm.
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b From the Arguments drop-down list, select Custom.
¢ Inthe field to the right, enter -e Zusr/bin/vi $FILE.

6 To revert back to the built-in editor, on the Editors tab, from the Text editor drop-
down list, select Built In.
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Change Default Font Size

This example shows how to change the default font size in the Polyspace user interface.

1 Select Tools > Preferences.
2 On the Miscellaneous tab:

+ To increase the font size of labels on the user interface, select a value for GUI
font size.

For example, to increase the default size by 1 point, select +1.

To increase the font size of the code on the Source pane and the Code Editor
pane, select a value for Source code font size.

3 Click OK.

When you restart Polyspace, you see the increased font size.

3-19



3 Setting Up a Verification Project

Choosing Contextual Verification Options
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While creating your project, you must configure analysis options to match your quality
goals. Polyspace software performs robustness verification by default. If you want to
perform contextual verification, there are several options you can use to provide context
for data ranges, function call sequence, and stubbing.

For more information on robustness and contextual verification, see “Defining Quality
Goals” on page 2-4.

Note: If you are aware of run-time errors in your code but still want to run a verification,
you can annotate your code so that these known errors are highlighted in the Polyspace

user interface. For more information, see “Add Review Comments to Code” on page
8-36.

1 On the Configuration pane, select Verification Mode. Select Verify module.

2 On the Configuration pane, select Inputs & Stubbing. In the Variable/function
range setup field, specify a data range specification (DRS) file.

3 Control stubbing behavior with the following options:
No automatic stubbing — If you select this option, the software does not

automatically stub functions. The software lists the functions to be stubbed and
stops the verification.

+ Initialization of uninitialized global variables — Specify how uninitialized
global variables are initialized.

For more information on these options, see “Analysis Options”.
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Choosing Strict or Permissive Verification Options

Polyspace software provides options that allow you to customize the strictness of the
verification. You should set these options to match the quality goals for your application.

Note: If you are aware of run-time errors in your code but still want to run a verification,
you can annotate your code so that these known errors are highlighted in the Polyspace
user interface. For more information, see “Add Review Comments to Code” on page

8-36.

For strict verification, on the Configuration pane, select Inputs & Stubbing. Select
the No automatic stubbing check box.

For permissive verification:

1 On the Configuration pane, select Inputs & Stubbing. Clear the No automatic
stubbing check box.

2 Select Verification Assumptions. Select the Continue with non-initialized in/
out parameters check box.

For more information on these options, see “Analysis Options”.
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Setting Up Project to Generate Metrics
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In this section...

“About Polyspace Metrics” on page 3-22
“Enabling Polyspace Metrics” on page 3-22
“Specifying Automatic Verification” on page 3-22

About Polyspace Metrics

Polyspace Metrics is a Web-based tool for software development managers, quality
assurance engineers, and software developers. In software projects, this tool enables you
to do the following :

+ Evaluate software quality metrics

*  Monitor the variation of code metrics and run-time checks over the lifecycle of a
project

* View defect numbers, run-time reliability of the software, review progress, and the
status of the code with respect to software quality objectives

For information on using Polyspace Metrics, see “Reports and Metrics”.

Enabling Polyspace Metrics

1 On the Configuration pane, select Machine Configuration.
2 Select the Send to Polyspace Server check box.
3 Select the Add to results repository check box.

The software generates Polyspace Metrics for the next verification.

Specifying Automatic Verification

You can configure verifications to start automatically and periodically, for example, at
a specific time every night. At the end of each verification, the software stores results in
the repository and updates the project metrics. You can also configure the software to
send you an email at the end of the verification.

For more information, see “Specifying Automatic Verification” on page 10-3.
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+ “Target & Compiler Overview” on page 4-2

+ “Specifying Target & Compiler Parameters” on page 4-3
+  “Predefined Target Processor Specifications” on page 4-4
+ “Main Generator Overview” on page 4-6

+  “Automatically Generating a Main” on page 4-7

+ “Manually Generating a Main” on page 4-8
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Target & Compiler Overview

Many applications run on specific target CPUs and operating systems. The type of CPU
determines many data characteristics, such as data sizes and addressing. These factors
can influence whether errors (such as overflows) occur.

Some run-time errors are dependent on the target CPU and operating system. Therefore,
before running a verification, you must specify the type of CPU and operating system for
the target environment.



Specifying Target & Compiler Parameters

Specifying Target & Compiler Parameters

To specify the target environment and compiler behavior for your application, in the
Polyspace user interface, on the Configuration pane, select Target & Compiler.

For example, to specify the target environment for your application:

1 For Target operating system, select the operating system on which your
application is designed to run.

2 For Target processor type, select the processor on which your application is
designed to run.

For detailed specifications of each predefined target processor, see “Predefined
Target Processor Specifications” on page 4-4.
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Predefined Target Processor Specifications

Polyspace software supports many processors. To specify a predefined processor:

On the Configuration pane, select Target & Compiler.
2 For Target processor type, select your processor.

3 If your processor is not specified in the drop-down list, use the following table to
select a processor that shares the same characteristics as your processor.

Target sparc m68kColdFi 1750a powerpc32bi| powerpcé4bit|i386
Character 8 8 16 8 8 8
short_integer 16 16 16 16 16 16
Integer 32 32 16 32 32 32
long_integer 32 32 32 32 64 32
long_long_integer 64 64 64 64 64 64
short_float 32 32 32 32 32 32
Float 32 32 32 32 32 32
long_float 64 64 48 64 64 64
long_long_float 64 64 48 64 64 64

In the following list, the largest default alignment of basic types within record/array
for various targets is given:

* powerpc32bits — 64.
* powerpc64bits — 64.
+ 1386 —32.

4 To identify target processor characteristics, compile and run the following program.
If none of the characteristics described in the preceding table match, contact
MathWorks® technical support for advice.
with TEXT_10;
procedure TEMP is
type T_

Ptr is access integer;
Ptr :T_Ptr;

begin
TEXT_10.PUT_LINE ( Integer®lImage (Character-Size) );
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TEXT_I0.PUT_LINE ( Integer®lImage (Short_Integer-Size) );
TEXT_I0.PUT_LINE ( Integer®lImage (Integer”Size));
TEXT_I0.PUT_LINE ( Integer®lImage (Long_Integer-Size) );

-— TEXT _10.PUT_LINE ( Integer~Image( Long_Long_Integer"Size) );
TEXT_I0.PUT_LINE ( Integer®lImage (Float"Size) );

-- TEXT _10.PUT_LINE ( Integer~Image(D_Float"Size) );
TEXT_I0.PUT_LINE ( Integer®lImage (Long_Float"Size));
TEXT_I0.PUT_LINE ( Integer®lImage (Long_Long_Float"Size) );
TEXT_I0.PUT_LINE( Integer®lImage (T_Ptr"Size) );

end TEMP;
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Main Generator Overview

When your application is a function library (API) or a single module, you must provide a
main that calls each uncalled procedure within the code because of the execution model
used by Polyspace. You can either manually provide a main, or use Polyspace to generate
a main automatically.

When you run a verification on Polyspace Client™ for Ada software, the main is
generated. When you run a verification on Polyspace Server™ for Ada software, you can
choose to generate a main automatically.



Automatically Generating a Main

Automatically Generating a Main

You can choose to automatically generate a main by selecting the Verify module (-
main-generator) option. The -main-generator option automatically creates a
procedure that calls every uncalled procedure within the code.

With Polyspace Client for Ada software, the software, by default, automatically generates
a main. You can choose to manually generate a main using the -main option:

1 On the Configuration pane, select Verification Mode.
2 Select Verify whole application.

3 Inthe Main entry point field, the package that defines the main, for example,
INIT.MAIN.

With Polyspace Server for Ada, the software sets the -main option by default. You can
choose to automatically generate a main using the -main-generator option.

1 On the Configuration pane, select Verification Mode.

2 Select Verify module.

For more information on the main generator, see “Verify module”.
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Manually Generating a Main

You might prefer to manually generate a main because it allows you to provide a more
accurate model of the calling sequence to be generated.

To manually define the main:

1
2

Identify the API functions and extract their declaration.

Create a main containing declarations of a volatile variable for each type that is
listed in the function prototypes.

Create a loop with a volatile end condition.
Inside this loop, create a switch block with a volatile condition.

For each API function, create a case branch that calls the function using the volatile
variable parameters that you created.

The following code shows the five steps:

-- Step 1: APl function declarations
function funcl(x in integer) return integer;
procedure func2(x in out float, y in integer);

-- Step 2: Create main with declarations of volatile variables
procedure main is

a,b,c,d: integer;
e,f: float;

pragma volatile (a);
pragma volatile (e);
begin

--Step 3: Create loop
loop

f:=e;

c:=a;

d:=a;

-- Steps 4 and 5

if (a = 1) then b:= funcl(c); end if;
if (a = 1) then func2(e,d); end if;

end loop

end main;
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How Polyspace Verifies Generic Packages

Consider the following code, which instantiates a generic package.
with Ada.Numerics.Generic_Elementary_Functions;

Package Body Test is
Pi : Constant := 3.141592;

Buf_Length : constant := 500;
type Buffer_type is array(l .. Buf_Length) of Float;
Tab : Buffer_type;

-- Create instance of generic package
package Trig is new Ada.Numerics.Generic_Elementary_Functions(float);

Procedure Main is
begin
for i in Tab"First .. Tab"Last loop
Tab(i) := float(1.0 - Trig.cos(2.0 * Pi * float(i - 1) / 1000.0));
end loop;
end Main;

end Test;

Polyspace can only analyze packages that are explicitly instantiated. In

the code, Trig represents a new instantiation of the generic package
Ada.Numerics.Generic_Elementary Functions(float). If you specify the Verify
module (-main-generator) option, Polyspace verifies the functions called by your code.
In this case, Polyspace verifies only the function cos from the new package.
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Specifying Constraints Using Text Files
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By default, Polyspace software performs robustness verification, proving that the
software does not generate run-time errors for all verification conditions. Robustness
verification assumes that the data inputs are set to their full range. Therefore, most
operations on these inputs could produce an overflow.

The Polyspace Data Range Specifications (DRS) feature allows you to perform contextual
verification, proving that the software works under normal working conditions. Using
DRS, you set constraints on data ranges, and verify the code within these ranges. This
process can substantially reduce the number of orange checks in the verification results.

To use the DRS feature, you must specify a file that constrains the range of values
for global variables, values returned by stubbed functions, out or in/out parameters
of stubbed procedures, or input parameters of user subprograms called by the main
generator during verification. See “DRS Text File Format” on page 4-10.

To configure a verification that applies the data range specifications in this text file:

1 In the Polyspace user interface, on the Configuration pane, select Inputs &
Stubbing.

To the right of the Variable/function range setup row, click . The Load a DRS
file dialog box opens.

Use this dialog box to navigate to the folder that contains your DRS text file.
In the File name field, specify your DRS file.
Click Open. You see the file path in the Variable/function range setup field.

o O bW

Select File > Save to save your project settings, including the DRS text file location.

DRS Text File Format

The DRS file contains a list of variables, functions, and parameter names together with
associated data ranges. During verification, the point at which the range is applied, for
example, to a variable, is controlled by the mode keyword: reinit, init, or permanent.

Each line of the DRS file must have the following format:

var_func_param min_val max_val <reinit]init]|permanent>



Specifying Constraints Using Text Files

* var_func_param — A variable name, the name of a function that returns a value, or
a subprogram parameter name.

* min_val, max_val — Constants that specify minimum and maximum range values.
Data type of these values can be character, enumerator, integer, or float. The integer
or float values may be binary, octal, decimal, or hexadecimal.

* reinit — Sets global variables to the specified range at the entry point for each
subprogram called by the main generator, or the entry point for the user-defined main
subprogram.

* Init — Initializes subprogram input parameters to a specified range when the
subprogram is called by the main generator.

*  permanent — Sets the return, out, or in/out parameters to the specified range of a
stubbed subprogram each time the subprogram is called.

Tips for Creating DRS Text Files

* You can replace min_val and max_val by the words “min” or “max”. In this case,
the software uses the corresponding minimum and maximum value for the declared
data subtype (true even for an enumeration type that has enumerated values min and

max). For example, with a SPARC® processor, the minimum value for the integer data
type is -2231 and the maximum value is 2/31-1.

* You can use tab, comma, space, or semicolon as column separators.

* You can apply data range specification to variables and subprograms declared within
a package specification or body, or subprograms outside a package. For subprograms
outside a package, use the subprogram name as package name.

* You cannot apply data range specification to:

* Local subprograms or task entries

+ Constant qualified variables, record discriminants, variables of access type, or
variables defined in a protected type or task type

Example DRS Text File

The following lines:

P_x 2#0001#E2 100 reinit # x is (re)initialized between [4;100]

P_.y min max reinit # y is initialized with the full range.

P.sl.c "a" max reinit # sl.x is initialized between ["a";Character”Last]
P_bar -1.0 1.0 permanent # stubbed function bar returns [-1.0;1.0]
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P.barl.outp -1.0 1.0 permanent # stubbed procedure barl®s parameter
# outp returns [-1.0;1.0]
P.proc.i -1.0 1.0 init # main generator calls the user

# procedure proc with the parameter
# 1 initialized to [-1.0;1.0]
dummy_Ff_.dummy_f -10 10 permanent # stubbed free function dummy_*f
# returns [-10;10]-

are data range specifications for a scenario where:

+ X andy are two global variables declared in the package P

* slis a variable of record type that has a character type component c
* bar is the name of a stubbed function

* barl is a stubbed procedure with outp as out parameter

* proc is a procedure defined with a parameter named i

* dummy_Fis a function declared without a parent package

DRS Warning Messages

Polyspace produces a DRS warning message in the verification log file in the following
situations.

* When a data range constraint is applied:

Warning: <symbol> has a range specified by DRS
in [<min> .. <max>] (<mode>).
+ If the DRS file contains a syntax error, Polyspace produces one of the following types
of messages:
« <DRS file>, line <line#>: Warning: data range specification with
incorrect min that is greater than max

o <DRS file>, line <line#>: Warning: data range specification with
incorrect min or max type. <[Integer|Float]Enum]> value is expected

« <DRS file>, line <line#>: Warning: data range specification with
incorrect mode

o <DRS file>, line <line#>: Warning: data range specification with
incorrect [max|min] value

« <DRS file>, line <line#>: Warning: data range specification
with [min]min] out of range of ada type

+ If the DRS file contains an unsupported data range specification, Polyspace produces
one of the following types of messages:

e <DRS file>, line <line#>: Warning: data range specification with
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unsupported object type | DRS cannot be applied to constant variable,
record discriminant or variant, access type, protected type, task
entry and local subprogram

<DRS file>, line <line#>: Warning: data range specification with
unsupported variable scope | Variable must be defined within a
package specification or body
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Performing Efficient Module Testing with DRS

DRS allows you to perform efficient static testing of modules. To do so, you add design
level information, which is missing in the source code.

A module can be seen as a black box that has the following characteristics:

Input preconditions of call are designed for subprograms to be tested

Input global data is consumed when testing subprograms

Output data is produced by missing (stubbed) subprograms

Using the DRS feature, you can define:

The nominal range for input arguments as preconditions of subprogram calls

The generic range for input global variables at the start point of each subprogram test

The generic range for return parameters of stubbed functions, and out or in/out
parameters of procedures

These definitions then allow Polyspace software to perform a single static verification
task, answering questions about robustness and reliability.

In this context, you assign DRS keywords according to the type of data (input argument
of call, input global data, stubbed subprogram output).

Type of Data  |DRS Mode Effect on Results Why? Oranges | Selectivity
Input init Reduces the number |Input arguments l 1
argument of of orange checks that were full range
call (compared to a are set to a smaller

standard Polyspace and realistic range.

verification)
Input global |reinit Reduces the number |Input data that was |1 1
data of orange checks full range is set to a

(compared to a smaller and realistic

standard Polyspace range.

verification)
Stubbed permanent Reduces the number |Output data, 1 i}
subprogram of orange checks produced by a
output (compared to a missing subprogram,
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Type of Data  |DRS Mode Effect on Results Why? Oranges | Selectivity
standard Polyspace that was full range
verification) is set to a smaller
and realistic range.
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Reducing Orange Checks with DRS
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When performing robustness (worst case) verification, data inputs are set to their full
range. Therefore, every operation on these inputs, even a simple “one_input + 10” can
produce an overflow, as the range of one_input varies between the minimum value and
the maximum value of the type.

If you use DRS to restrict the range of “one-input” to the real functional constraints
found in a specification, design document, or models, you can reduce the number of
orange checks reported on the variable. For example, if you specify that “one-input” can
vary between 0 and 10, Polyspace software recognizes that:

+ one_input + 100 does not overflow

* the results of this operation are between 100 and 110

This process eliminates the local overflow orange and results in more accuracy in the
data. This accuracy is then propagated throughout the rest of the code.

The red circle indicates the orange checks that are removed by using DRS.

% of orange
checks

Orange checks due to
complexity

Orange checks due to
# full range variables

Size (lines of code)




Reducing Orange Checks with DRS

Removing orange checks caused by full-range (worst-case) data can significantly reduce
the total number of orange checks, especially in the verification of small files or modules.
However, the orange checks caused by code complexity does not change on applying DRS.
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Using Pragma Assert to Set Data Ranges

4-18

You can use the construct "pragma assert” within your code to inform Polyspace of
constraints imposed by the environment in which the software will run. A “pragma
assert” function is:

pragma assert(<integer expression>);

If <integer expression> evaluates to zero, then the program is assumed to be
terminated, therefore there is a “real” run-time error. This condition is why Polyspace
produces checks for the assertions. The behavior matches the one exhibited during
execution, because execution paths for unsatisfied conditions are truncated (red
and then gray). Thus it can be assumed that a verification performed downstream of the
assert uses value ranges which satisfy the assert conditions.

You can use the construct "pragma assert” in a procedure to inform Polyspace of
constraints in the environment in which the software will be embedded. You can use user
assertions to describe the physical properties of the environment, such as:

* The maximum and minimum speed limit (a car does not go faster than 200 miles per
hour or slower than 0 miles per hour),

* The maximum duration of software exploitation (five years for a satellite and one
hour for its launcher)

Example

procedure main is
counter: integer;
-- counter is not initialized
random: integer;
pragma volatile (random);

begin
counter:= random;
-- counter~ [-2731, 2731-1]
pragma assert (counter < 1000);
pragma assert (counter > 100);
end;
end main;

Both assertions are orange because the conditions may or may not be fulfilled. From
then on, counter ~ [101, 999] because execution paths that do not meet the conditions are
halted.
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Supported Ada Pragmas

Polyspace software provides verification support for many standard Ada or GNAT

compiler pragmas.

Pragma

How Polyspace Software Processes Pragma

Import, Import_Function, and
Import_Procedure

Stubs function or procedure

Interface and Interface_ Name

Stubs function or procedure

Inspection_Point

Provides information about possible values for
the variable. May display a range.

Volatile

Variable becomes full-range

Volatile_Components

If you specify Polyspace for Ada95, you get
the same results as with the pragma Volatile.
However, in this case, the pragma applies to
arrays.

Assert Produces a user assertion check, ASRT. See
“User Assertion: ASRT”.
Restrictions Ignored for standard Ada or GNAT compiler

restrictions. Other restriction pragmas produce
a warning.

Ada_83 and Ada_95

Polyspace option —lang overwrites this pragma
(option set by default to Ada95 when you use
polyspace-ada).

Pure

Applies requirement that package has cross-
dependencies only with other Pure packages. If
requirement is not met, generates compilation
errors.

You can remove requirement by inserting
pragma Not Elaborated within package body.
For example:

package System is

pragma Pure;
pragma Not_Elaborated;
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Pragma How Polyspace Software Processes Pragma
end System;
Prelaborate, Elaborate Provides order of elaboration and verification of
Elaborate All, and packages by Polyspace
Elaborate_Body
Storage_Unit Polyspace option —storage_unit overwrites
this pragma

Note: If your code contains an unsupported pragma, Polyspace ignores the pragma and
continues the verification. At the end of the compilation phase, Polyspace displays a
message:

The following pragmas have been ignored...
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How Polyspace Evaluates Function and Procedure Parameters

Polyspace applies by-copy semantics and a left-to-right evaluation order for parameter
passing. You can use Polyspace to verify your Ada code provided your compiler
implements:

* Left-to-right evaluation for subprogram parameters. Consider the following code.

1 with ada.integer_text_io;

2 use ada.integer_text_io;

3 procedure testl is

4 X,Y,z,r : integer;

5

6 function ¥ (x : integer) return integer
7 is

8 begin

9 z = 0;

10 return x + 1;

11 end f;

12 begin

13 X = 10;

14 y = 20;

15 z = 10;

16 R:=y /Z+ FX);

17 pragma assert(R = 13); -- green ASRT
18 put(R);

19 end;

In this example, Polyspace verification implements left-to-right evaluation and
generates a green ASRT check.

+  By-copy semantics for subprogram parameters. Consider the following code.

1 procedure Test2

2 is

3

4 type Rec is

5 record

6 F,G: Integer;

7 end record;

8

9 R: Rec;

10 Result : Integer;
11

12 procedure Multiply (X, Y : in Rec; Z : out Rec)
13

14 is

15 begin

16 z = (0,0);

17 Z.F = X.F * Y_F;
18 Z.G := X.G * Y.G;
19 end Multiply;

20

21 begin
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22 R := (10,10);

23 Result := 100;

24 Multiply (R,R,R);

25 Result := Result/R.F;

26 pragma assert (Result = 1); -- green ASRT

27 end Test2;
In this example, Polyspace verification implements by-copy semantics and generates a
green ASRT check.

The green checks generated indicate that the code conforms to the Ada standard,
which states that The execution of a program is erroneous if its effect depends on which
mechanism is selected by the implementation. See Formal Parameter Modes.
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Stubbing Overview

A function stub is a small piece of code that emulates the behavior of a missing function.
Stubbing is useful because it allows you to verify code before all functions have been fully
developed.
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Manual vs. Automatic Stubbing

The approach you take to stubbing can have a significant influence on the speed and
precision of your verification.

There are two types of stubs in Polyspace verification:

+ Automatic stubs — When you attempt to verify code that calls an unknown function,
the software automatically creates a stub function based on the function’s prototype
(the function declaration). Automatic stubs generally do not provide insight into the
behavior of the function.

*+ Manual stubs — You create these stub functions to emulate the behavior of the
missing functions, and manually include them in the verification with the rest of the
source code.

Only advanced users should consider manual stubbing. Polyspace can automatically stub
every missing function or procedure, leading to an efficient verification with a low loss in
precision. However, in some cases you may want to manually stub functions instead. For
example, when:

+ Automatic stubbing does not provide an adequate representation of the code it
represents— both in regards to missing functions and assembly instructions.

* The entire code is to be provided, which may be the case when verifying a large piece
of code. When the verification stops, it means the code is not complete.

*  You want to improve the selectivity and speed of the verification.
* You want to gain precision by restricting return values generated by automatic stubs.

* You need to deal with a function that writes to global variables.

Deciding which Stub Functions to Provide

Stubs do not need to model the details of the functions or procedures involved. They only
need to represent how the function interacts with the remainder of the code.

Consider procedure_to_stub. If it represents:

* a timing constraint, such as a timer set/reset, a task activation, a delay or a counter
of ticks between two precise locations in the code, you can stub it to an empty
action begin null; end;. Polyspace does not need a concept of timing because
the software takes into account possible scheduling and interleaving of concurrent
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execution. You do not have to stub functions that set or reset a timer. Simply declare
the variable representing time as volatile.

an I/0O access, such as to a hardware port, a sensor, read/write of a file, read of an
EEPROM, write to a volatile variable:

* You do not have to stub a write access. If you want to do so, you can stub it
through an empty action begin null; end;.

* You can stub read accesses using procedures that read volatile variables.

a write to a global variable, consider which procedures or function write to it and why:
do not stub the concerned procedure_to_stub if:

this variable is volatile;

+ this variable is a task list. Such lists are accounted for by default because tasks
declared with the —-task option are automatically started.

write a procedure_to_stub by hand if this variable is a regular variable read by other
procedures or functions.

a read from a global variable: if you want Polyspace to detect that it is a shared
variable, you need to stub a read access as well. This is easy to achieve by copying the
value into a local variable.

Generally speaking, follow the data flow and remember that:

Polyspace only uses the Ada code which is provided.

For multitasking code, Polyspace does not need to be informed of timing constraints
through explicit time specification inside the code.

Example

This example shows a header for a missing function (which might occur if, for example,
the code is an incomplete subset or a project). The missing function copies the value of
the src parameter to dest, so there would be a division by zero (RTE) at run time.

procedure a_missing_function

(dest: in out integer,
src : in integer);

procedure test is

a: integer;
b: integer;

begin

a: = 1;
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end;

Due to the reliance on the software's default stub, the division is shown with an orange
warning because a is assumed to be anywhere in the full permissible integer range
(including 0).

If the function was commented out, then the division would be green.

A red division could only be achieved with a manual stub.

This example shows what might happen if the effects of assembly code are ignored.

procedure test is

begin
a:= 1;
b:= 0;
-- b:=a
pragma asm (“'move: a,b')
b:= 1 /a;
end;

Due to the reliance on the software's default stub, the assembly code is ignored and the
division " /" is green. The red division "/" could only be achieved with a manual stub.

Summary

Stub manually: to gain precision by restricting return values generated by automatic
stubs; to deal with a function which writes to global variables.

Stub automatically if you are sure that a run-time error will not be introduced by
automatic stubbing; to minimize preparation time.
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Automatic Stubbing

Some functions might not be included in the set of Ada source files because the functions
are:

+ External.
+  Written in another programming language, for example, C.

* Part of the system libraries.

By default, Polyspace automatically stubs these functions. For information about how
Polyspace automatically stubs functions, see “No automatic stubbing”.
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Polyspace Software Assumptions

These are the rules followed by Polyspace. It is strongly recommended that the preceding
sections should be read and understood before applying the rules described below. Some
rules are mandatory; others facilitate improved selectivity.

The following describes the default behavior of Polyspace. If the code to be verified does
not conform to these assumptions, then some minor modifications to the code or to the
Polyspace run-time parameters will be required.

+  The main procedure must terminate in order for entry-points (or tasks) to start.

+ All tasks or entry-points start after the execution of the main has completed. They
start simultaneously, without predefined assumptions regarding the sequence,
priority and preemption.

If an entry-point is seen as dead code, it can be assumed that the main contains (a) red
error(s) and therefore does not terminate. Polyspace does not assume any:

+  “Atomicity” on page 5-18

*  Timing constraints.
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Scheduling Model

In the Polyspace model, the main procedure is executed first before other tasks are
started. After it has finished, the task entry points are assumed to start concurrently
in an interleaved manner. This is an accurate upper approximation model for most
concurrent RTOS.

Tasks and main loops need to simply declare as entry points. It only concerns task not
defined using keyword of the Ada language.

Example
procedure body back_ground_task is
begin
loop —- infinite loop
-- background task body
-- operations

-- function call

my_original_package.my_procedure;
end loop

end back_ground_task

Launching Command

polyspace-ada -entry-points
package.other_task,package.back ground_task

If the tasks are already infinite loops, simply declare them as mentioned above.

Limitation

* A main procedure using the -main option is required.

* The tasks declared in -entry-points may not take parameters and may not
have return values:procedure MyTask is end MyTask;

If it is not the case, it is mandatory to encapsulate with a new procedure. In this case,
the real task will be called inside.

*  The main procedure cannot be called in a defined or declared task.
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Modelling Synchronous Tasks

Problem

My application has the following behavior:

* Once every 10 ms: void tsk_10ms(void);
*  Once every 30 ms: ...

*  Once every 50 ms

My tasks do not interrupt each other. My tasks do not contain infinite loops.
procedure tsk_10ms;
begin do_things_and_exit();
-— it"s important it returns control
end;

Explanation
If each task was declared to Polyspace by using the option

polyspace-ada -entry-points pack_name.tsk _10ms, pack_name.tsk 30ms,
pack name.tsk 50ms

then the results would be valid. However, because more scenarios than those
encountered at execution time are modelled, there may be unnecessarily more warnings
— the results are less precise.

In order to address this, Polyspace Server for Ada needs to be informed that the tasks are
purely sequential. This can be achieved by writing a function to call each of the tasks in
the right sequence, and then declaring this new function as a single task entry point.

Solution 1

Write a function that calls the cyclic tasks in the right order: this is an exact
sequencer. This sequencer is then identified to the software as a single task.

This sequencer will be a single Polyspace task entry point. This solution:

* 1s more precise,
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* but you need to know the exact sequence of events.

procedure body one_sequential_Ada_function is
begin
loop
tsk_10ms;
tsk_10ms;
tsk_10ms;
tsk_30ms;
tsk_10ms;
tsk_10ms;
tsk_50ms;
end_loop
end one_sequential_Ada_function;

polyspace-ada -entry-points pack_name.one_sequential_Ada_function

Solution 2

Make an upper approximation sequencer, which takes into account every possible
scheduling. This solution:

* 1s less precise,

* but is quick to code, especially for complicated scheduling.

procedure body upper_approx_Ada_function is
random : integer;
pragma volatile (random);
begin
loop
if (random
if (random
if (random
end_loop
end upper_approx_Ada_function;

1) than tsk_10ms; end if;
1) than tsk_30ms; end if;
1) than tsk 50ms; end if;

polyspace-ada -entry-points pack_name.upper_approx_Ada_function

Note: If this is the only task, then it can be added at the end of the main.
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Interruptions and Asynchronous Events/Tasks

Problem

Interrupt service routines appear gray (dead code) in the Polyspace user interface.

Explanation

The gray code indicates that this code is not executed and is not taken into account, so
the interruptions are ignored by Polyspace Server for Ada.

The execution model is such that the main is executed initially. Only if the main
terminates and returns control (i.e. if it is not an infinite loop) will the task entry points
be started.

My interrupts it1 and it2 cannot preempt each other

You can group interruptions in a single function and declare that function as a task entry
point if the following conditions are fulfilled:

* The functions itl and 1t2 cannot interrupt each other.
* Each interrupt can be raised several times in a row.

* The functions do not contain infinite loops.

procedure it_1;
procedure it _2;

task body all_interruptions_and_events is
random: boolean;
pragma volatile (random);
begin
loop
if (random) then it_1; end if;
if (random) then it_2; end if;
end_loop
end all_interruptions_and_events;

polyspace-ada -entry-points package.all_interruptions_and_events
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My interruptions can preempt each other

If two interruption can be interrupted, then:

. encapsulate each of them in a loop;
. declare each loop as a task entry point.
package body original_file is

procedure it_1 is begin ... end;

procedure it_2 is begin ... end;

procedure one_task is begin ... end;

end;

package body new_poly is

procedure polys_it_1 is begin loop it_1; end loop; end;
procedure polys_it_2 is begin loop it_2; end loop; end;
procedure polys_one_task is begin loop one_task; end loop; end;

polyspace-ada -entry-points new_poly. polys_it _1,new_poly. polys_it_2,
new_poly.polys_one_task
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Are Interruptions Maskable or Preemptive by Default?

Problem

In my main task I use a critical section but I still have unprotected shared data. My
application contains interrupts. Why is my variable verified as unprotected?

Explanation

Polyspace Server for Ada does not distinguish between interrupt service routines and
tasks. If you specify an interrupt to be an —entry-point, it will have the same priority
level as other procedures that are also declared as tasks via the —entry-point option.
Therefore, as Polyspace Server for Ada makes an upper approximation of scheduling
and interleaving. This upper approximation includes the possibility that the ISR
can be interrupted by other tasks. There are more paths modelled than can happen
during execution.

Solution

Embed your interrupt in a specific procedure that uses the same critical section as the
one you use in your main task. Then, each time this function is called, the task will enter
a critical section which will be equivalent to a nonmaskable interruption.

Original Packages

package my_real_package is
procedure my_main_task;
procedure my_real _it;
shared_X: INTEGER:= O;
end my_real_package;

package body my_ real_package is
procedure my_main_task is
begin
mask_it;
shared_x:= 12;
unmask_1it;
end my_main_task;
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procedure my_real_it is
begin
shared_x:= 100;
end my_real_it;
end my_real_package;

Extra Packages

An extra package that is required to embed the task with body my_real_package;

package extra_additional_pack is
procedure polyspace_real _it;
end extra_additional_package;

package body extra_additional_pack is
procedure polyspace_real_it is
begin
mask_it;
my_real_package.my_real _it;
unmask_1it;
end;
end extra_additional_package;

Command Line to Open Polyspace User Interface

polyspace-ada \

-entry-point my_real_package.my_main_task,extra_additional_pack\
polyspace_real_it

\

-main your_package.your_main
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Mailboxes

Problem

My application has several tasks:

* some that post messages in a mailbox;

* others that read these messages asynchronously.

This communication mechanism is possible because the OS libraries provide send and

receive procedures. I do not have the source files because these procedures are part of
the OS libraries.

Explanation

By default, Polyspace Server for Ada will automatically stub these send/receive
procedures. Such a stub will exhibit the following behavior:

+ for send(char *buffer, int length): the content of the buffer will only be
written when the procedure is called;

+ Ffor receive(char *buffer, int *length): each element of the buffer will
contain the full range of values for the corresponding data type.

Solution

You can provide similar mechanisms with different levels of precision.

Mechanism Description

Let Polyspace Server for Ada stub
automatically

Quick and easy to code

Imprecise because between a mailbox
sender and receiver are not directly
connected. It means that even if the sender

is only submitting data within a small range,
the full data range for the type(s) will be used
for the receiver data.
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Mechanism

Description

Provide a real mailbox mechanism

+ Can be very costly (time consuming) to
implement

Can introduce errors in the stubs

Is too much effort compared with the solution
below

* Precise, but does not provide a much better
precision than the upper approximation

Provide an upper approximation of
the mailbox

in which each new read to the mailbox reads
one of the recently posted messages, but not
necessarily the last one.

*  Quick and easy to code

+ Gives precise results

See detailed implementation below

package mailboxes

type BIG_ARRAY is
array (1..100)of INTEGER;
type MESSAGE is
record
length: INTEGER;
content: BIG_ARRAY;
end MESSAGE;
MAILBOX : MESSAGE;
procedure send
(X: in MAILBOX);
procedure receive
(X: out MAILBOX);
end mailboxes;

package body mailboxes

procedure send (X: in MESSAGE) is
random : boolean;
pragma Volatile_(random);
begin
if (random) then




Mailboxes

MAILBOX:= X;
end if;
-- a potential write
-- to the mailbox
end;

procedure receive

(X: out MESSAGE) is
begin

X:= MAILBOX;
end;

task body task_1

msg :© MESSAGE;
begin
for i in 1 .. 100 loop

msg.content(i):= i;

end loop;
msg. length : = 100;
send(msg) ;
end task_1;
task body task_2 is
msg :© MESSAGE;
begin
receive(msg);

if (msg.length = 100) ...

end;

Provided that each of these tasks is included in a package.

polyspace-ada -main a_package.a procedure
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Atomicity

Definitions

* Atomic — In computer programming, atomic describes a unitary action or object that
is essentially indivisible, unchangeable, whole, and irreducible

*  Atomicity — In a transaction involving two or more discrete pieces of information,
either all the pieces are committed or none are.

Instructional Decomposition

In general terms, Polyspace Server for Ada does not take into account either CPU
instruction decomposition or timing considerations.

It is assumed by Polyspace that instructions are not atomic except in the case of read
and write instructions. Polyspace Server for Ada makes an upper approximation of
scheduling and interleaving. Because of this approximation, the software models
more paths than could happen during execution.

Consider a 16 bit target that can manipulate a 32 bit type (an int, for example). In this
case, the CPU needs at least two cycles to write to an integer.

Suppose that x is an integer in a multitasking system, with an initial value of 0x0000.
Now suppose 0xFF55 is written it. If the operation was not atomic it could be interrupted
by another instruction in the middle of the write operation.

* Task 1: Writes 0xFF55 to x.
* Task 2: Interrupts task 1. Depending on the timing, the value of x could be 0xFF0O,
0x0055 or 0xFF55.

Polyspace Server for Ada considers write/read instructions atomic, so task 2 can only
read 0xFF55, even if X is not protected.

Critical Sections

In terms of critical sections, Polyspace Server for Ada does not model the concept of
atomicity. A critical section implies that once the function associated with ~critical-
section-begin has been called, other functions making use of the same label will be
blocked. Functions not using the label can continue to run.
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Polyspace Server for Ada verification of run-time errors supposes that a conflict does not
occur when writing the shared variables. Hence even if a shared variable is not protected,
the run-time error verification is complete and correct.

More information about protection is available in “Critical section details” or “T'emporally
exclusive tasks”.
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Priorities

5-20

Polyspace does not consider priorities of tasks during verification. In addition, Polyspace
does not assume that priorities can protect shared variables.

Though you cannot implement different task priorities, the verification effectively takes
all priorities into account because it assumes that:

+ All task entry points that you specify on the Configuration pane start at the same
time.

* They can interrupt each other in any order, regardless of the sequence of instructions.

For instance, if you have two tasks t1 and t2, and t1 has higher priority than t2, use
polyspace-ada -entry-points tl,t2. Polyspace assumes that:

* tl can interrupt t2 at arbitrary intervals, thus modelling the behavior at execution
time.

* 12 can also interrupt tl at arbitrary intervals. This behavior does not occur at
execution time unless priority inversion takes place. Polyspace Server for Ada
makes an upper approximation of scheduling and interruptions. Because of this
approximation, the software models more paths than possible during actual
execution.
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6-2

Before running verification on your source files, you must add them to a Polyspace
project. For more information, see “Create Project”.

In this section...

“Start Verification” on page 6-2
“Monitor Progress” on page 6-2
“Stop Verification” on page 6-3
“Open Results” on page 6-3

Start Verification

To start a verification on your local desktop:

1 On the Project Browser pane, select the project module that you want to verify.

On the toolbar, click the [> Run button.

Tip To run verification on all modules in the project, expand the drop-down list beside the

1> Runl Select Run All Modules.

Monitor Progress

To monitor the progress of a local verification, use the following panes. If you have closed
a pane, to open it again, select Window > Show/Hide View.

+  Output Summary — Displays progress of verification, compile phase messages and
errors.

* Run Log — This tab displays messages, errors, and statistics for all phases of the
verification.

Tip To search for a term in the Qutput Summary or Run Log, enter the term on the
Search pane. Select Output Summary or Run Log from the drop-down list beside the
search box.



Run Local Verification

If the Search pane is not open by default, select Windows > Show/Hide View >
Search.

At the end of a local verification, the Dashboard tab displays statistics, for example,
code coverage and check distribution.

Stop Verification

To stop a local verification:
1  On the toolbar, click the Stop button.

A warning dialog box opens asking whether you want to stop the execution.

2 Click Yes. The verification stops, and results are incomplete. If you start another
verification, the verification starts from the beginning.

Open Results

After verification, the results open automatically on the Results Summary pane. If you
are looking at previous results when a verification is over, you can load the new results
or retain the previous results on the Results Summary pane.

To open the new results later:

1 On the Project Browser pane, navigate to the results set that you want to review.
2 Double-click the results set, for example, Result_1.

The software loads the verification results in the Results Summary pane.

To open results of verification when the corresponding project is not open in the Project
Browser pane:

1 Select File > Open.
2 In the Open File dialog box, navigate to the results folder. For example:

My_project\Module_1\Result_1
3 Select the results file, for example, My_project.rte.
4 Click Open.
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Run Remote Verification

Run remote verification when:

* You want to shut down your local machine but not interrupt the verification.
*  You want to free execution time on your local machine.

*  You want to transfer verification to a more powerful computer.

Before you run remote verification, you must do the following:

* Set up a server for this purpose. For more information, see “Polyspace Software
Administration”.

* Add your source files to a Polyspace project. For more information, see “Create
Project”.

In this section...

“Start Verification” on page 6-4
“Monitor Progress” on page 6-5

“Stop Verification” on page 6-5

“Open Results” on page 6-5

Start Verification

To start a remote verification:

On the Project Browser pane, select the module you want to verify.

2 On the Configuration pane, select Machine Configuration. Select Send to
Polyspace Server.

3 Optionally, select Add to results repository.
After verification, your results are uploaded to the Polyspace Metrics web dashboard.
On the toolbar, click the L’) RUN | button.

The verification starts. For information on the verification process, see “Phases of
Verification” on page 6-6.



Run Remote Verification

Note: If you see the message Verification process failed, click OK and go to
“Troubleshooting in Polyspace Products for Ada”.

Monitor Progress

You can manage your verification through the Polyspace Job Monitor.

1 Select Tools > Open Job Monitor.
2 In the Polyspace Job Monitor, right-click your verification.

3 From the context menu, select your management task:

View Log File — Open the verification log.

+ Download Results — Download verification results from remote computer if the
verification is complete.

Stop Verification

1 Select Tools > Open Job Monitor.

2 In the Polyspace Job Monitor, right-click your verification. From the context menu,
select Remove From Queue.

Open Results

Your results are downloaded automatically after verification. To open them:

1 On the Project Browser pane, navigate to the results set.

2 Double-click the results set, for example, Result_1.

The software loads the verification results in the Results Summary pane.

Note: If you select the option Add to results repository, your results are not
downloaded automatically after verification. Use the Polyspace Metrics web dashboard
to view the results and download them to your desktop. For more information, see “Fix
Defects” on page 10-29.
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Phases of Verification

The verification has three main phases:

1 Checking syntax and semantics (the compile phase). Because Polyspace software
is independent of a particular Ada compiler, it ensures that your code is portable,

maintainable, and complies with ANSI® standards.

2 Generating a main if the verification does not find a main and you selected the
Verify module option. For more information, see “Generate a main”.

3  Analyzing the code for run-time errors and generating color-coded diagnostics.

The compile phase of the verification runs on the client. When the compile phase is
complete:

* You see the message queued on server at the bottom of the Polyspace user
interface. This message indicates that the part of the verification that takes place on
the client is complete. The rest of the verification runs on the server.

* A message in the Qutput Summary view gives you the identification number
(Analysis ID) for the verification.
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Run File-by-File Local Verification

This example shows how to run a local verification on each file independently of other
files in the module. You need a Polyspace Server for Ada license to perform a local file-by-
file verification on your desktop.

In this section...

“Run Verification” on page 6-7

“Open Results” on page 6-7

Run Verification

1 Select your project configuration. On the Configuration pane, specify that each file
must be verified independently of other files.
a Select the Verification Mode node.
b Select Verify module and then Verify files independently.

For Common source files, enter files that you want to include in the
verification of each file. Enter the full path to a file. Enter one file path per row.

On the toolbar, click the L/H Run button.

As you can see on the Output Summary pane, you can see that after the Compile
phase, each file is verified independently. After the verification is complete for a file,
you can view the results while other files are still being verified.

Open Results

After verification, your results appear in the Project Browser. The results are grouped
under a root node below the Result node of your module. The results for each source file
has the same name as the source file.

After a source file is verified, to open the results, double-click the corresponding result
file under the Result node. Alternatively, after all source files are verified, you can see a
summary of results for all files and begin reviewing from files with more severe issues.

1  To open the results, click the root node below the Result node in your project
module. For instance, click Result_1 if your project uses the default result naming
scheme.
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On the Dashboard pane, you can see a summary of results for all files. The files in
the summary table are sorted by the severity of check colors. For instance, the files
are sorted by the number of red checks. The files with the same number of red checks
are sorted by the number of gray checks and so on.

2 To load the results for an individual file, double-click the file name on the table.
After you load the results for an individual file, the Dashboard pane shows graphs
for the current file. The summary table for all files appears on a separate Unit by

unit results synthesis tab on this pane. You can use this tab to load results for
other files.

See Also

“Verify files independently”

More About
. “Multiple File Error in File by File Verification” on page 7-18
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Run Remote File-by-File Verification

This example shows how to run a remote verification on each file independently of other
files in the module.

Before you run remote verification, you must do the following:

Set up a server for this purpose. For more information, see “Polyspace Software
Administration”.

Add your source files to a Polyspace project. For more information, see “Create
Project”.

In this section...

“Run Verification” on page 6-9

“Open Results” on page 6-10

Run Verification

On the Project Browser pane, select the module you want to verify.

On the Configuration pane, select Machine Configuration. Select Send to
Polyspace Server.

Optionally, select Add to results repository.

After verification, your results are uploaded to the Polyspace Metrics web dashboard.
On the Configuration pane, specify that each file must be verified independently of
other files.

a Select the Verification Mode node.

b Select Verify module and then Verify files independently.

¢ For Common source files, enter files that you want to include with verification
of each file. Enter the full path to a file. Enter one file path per row.

On the toolbar, click the 2 ®" button.
After the Compile phase, you can view the jobs in the Polyspace Job Monitor.

Select Tools > Open Job Monitor.
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Your files appear as child nodes under the main verification node. After the
verification is complete for a file, you can download and view the results while other
files are still being verified. Right-click the row corresponding to the file and select
Download Results.

Open Results
Your results are automatically downloaded after verification.

To open result for each source file, double-click the corresponding result file under the
Result node. The result file has the same name as the source file.

Note: If you select the option Add to results repository, your results are not
downloaded automatically after verification. Use the Polyspace Metrics web dashboard
to view the results and download them to your desktop. For more information, see
“Generate Code Quality Metrics”.

See Also

“Verify files independently”

More About
. “Multiple File Error in File by File Verification” on page 7-18
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Manage Job Monitor

In this section...

“Purge Server Queue” on page 6-11
“Change Job Monitor Password” on page 6-12
“Share Server Verifications Between Users” on page 6-12

Purge Server Queue

You can purge the server queue of all jobs, or completed and aborted jobs using the using
the Polyspace Job Monitor.

Note: You must have the Job Monitor password to purge the server queue.

To purge the server queue:

1 Select Tools > Open Job Monitor.

The Polyspace Job Monitor opens.
2 Select Operations > Purge queue. The Purge queue dialog box opens.
3  Select one of the following options:
* Purge completed and aborted analysis — Removes completed and aborted
jobs from the server queue.

* Purge the entire queue — Removes all jobs from the server queue.

Note: For unit-by-unit verification jobs, the jobs are not removed until the entire
group has been verified.

4 Enter the Job Monitor Password.
5 Click OK.

The server queue is purged.
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Change Job Monitor Password

The Job Monitor has an administrator password to control access to advanced operations
such as purging the server queue. You can set this password through the Job Monitor.

Note: The default password is admin.

To set the Job Monitor password:

1 Select Tools > Open Job Monitor.

The Polyspace Job Monitor opens.

2 Select Operations > Change Administrator Password.

The Change Administrator Password dialog box opens.

3 Enter your old and new passwords. Then click OK.

The password is changed.

Note: Passwords are limited to 8 characters.

Share Server Verifications Between Users
Security of Jobs in Server Queue

For security reasons, verification jobs in the server queue are owned by the user who sent
the verification from a specific account. Each verification has a unique encryption key,
that is stored in a text file on the client system.

When you manage jobs in the server queue (for example, download, kill, and remove), the
Job Monitor checks the public keys stored in this file to authenticate that the job belongs
to you.

If the key does not exist, an error message appears: “key Ffor verification <ID>
not found”.



Manage Job Monitor

analysis-keys. txt File

The public part of the security key is stored in a file named analysis-keys.txt which
is associated to a user account. This file is located in %APPDATA%\Polyspace:

* UNIX® — “/home/<username>/ .Polyspace”
* Windows — “C:\Users\<username>\AppData\Roaming\Polyspace”

The format of this ASCII file 1s as follows (tab-separated):

<id of launching> <server name of IP address> <public key>
where <public key> is a value in the range [0..F]
The fields in the file are tab-separated.

The file cannot contain blank lines.

Example:

1 m120 27CB36A9D656F0C3F84F959304ACF81BF229827C58BE1A15C8123786
2 m120 2860F820320CDD8317C51E4455E3D1A48DCES76F5C66BEEF391A9962
8 m120 2D51FF34D7B319121D221272585C7E79501FBCC8973CF287F6C12FCA

Sharing Verifications Between Accounts
To share a server verification with another user, you must provide the public key.
To share a verification with another user:

1 Find the line in your analysis-keys. txt file containing the <ID> for the job you
want to share.

2 Add this line to the analysis-keys. txt file of the person who wants to share the
file.

The second user can then download or manage the verification.
Magic Key to Share Verifications

A magic key allows you to share verifications without copying individual keys. This
allows you to use the same key for verifications launched from a single user account.

The format for a magic key is as follows:
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0 <Server 1id> <your hexadecimal value>

When you add this key to your analysis-keys. txt file, verification jobs you submit to
the server queue use this key instead of a random one. Users who have this key in their
analysis-keys. txt file can then download or manage your verification jobs.

Note: This only works for verification jobs launched after you place the magic key in the
file. If the verification was launched before the key was added, the normal key associated
to the ID is used.

If analysis-keys. txt File is Lost or Corrupted

If your analysis-keys. txt file is corrupted or lost (removed by mistake) you cannot
download your verification results. To access your verification results you must use
administrator mode.

Note: You must have the Job Monitor password to use Administrator Mode.

To use administrator mode:
1 Select Tools > Open Job Monitor.

The Polyspace Job Monitor opens.
2 Select Operations > Enter Administrator Mode.
Enter the Job Monitor Password.
4 Click OK.

w

You can now manage verification jobs in the server queue, including downloading
results.
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Run Local Verification at Command Line

At the Windows or Linux or command-line, append sources and analysis options to the
polyspace-ada command.

For instance:

+ To specify the target processor, use the —target option. For instance, to specify the
m68K processor for your source file file.adb, use the command:

polyspace-ada -sources "file.adb" -lang ada95 -target m68k

+ To specify verification precision, use the -0 option. For instance, to set precision level
to 2 for your source file file.adb, use the command:

polyspace-ada -sources "file.adb" -lang ada95 -02
For the full list of analysis options, see “Analysis Options”.

You can also enter the following at the command line:

polyspace-ada -help
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Run Remote Verification at Command Line

In this section...

“Start Verification” on page 6-16
“Manage Verification” on page 6-16

“Download Verification Results from Server” on page 6-18

Start Verification
A set of commands allow you to run remote verifications.
These commands begin with the following prefixes:

* Server verification — Polyspace Install/polyspace/bin/polyspace-
remote-ada

+ Client verification — Polyspace_Install/polyspace/bin/polyspace-
remote-ada -desktop

For example,polyspace-remote-ada -desktop -server [<hostname>:[<port>]
| auto] connects the client to the specified server. This connection allows you to run
verifications remotely on the server.

These commands are equivalent to commands with the prefix Polyspace Install/
polyspace/bin/polyspace-

Manage Verification

A set of commands allow you to manage verification jobs in the server queue. These
commands begin with the prefix Polyspace Install/polyspace/bin/psqueue-:

* psqueue-download <id> <results dir>— download an identified verification
into a results folder. When downloading a unit-by-unit verification group, the unit
results are downloaded and a summary of the download status for each unit is

displayed.

[-F] force download (without interactivity)
+ —admin -p <password> allows administrator to download results.
[-server <name>[:port]] selects a specific Job Monitor.
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+ [-v]version] gives release number.

psqueue-kill <id>— kill an identified verification. For unit-by-unit verification
groups, you can stop the entire group, or individual jobs within the group. Stopping an
individual job does not kill the entire group.

psqueue-purge all]ended — remove completed verifications from the queue. For
unit-by-unit verification jobs, the jobs are not removed until the entire group has been
verified.

psqueue-dump — gives the list of verifications in the queue associated with the
default Job Monitor. Unit-by-unit verification groups are shown using a tree
structure.

psqueue-move-down <id>— move down an identified verification in the Queue.
Individual jobs can be moved within a unit-by-unit verification group, but not outside
of the group.

psqueue-remove <id>— remove an identified verification in the queue. You cannot
remove a single job that is part of a unit-by-unit verification group, you can only
remove the entire group.

psqueue-get-gm-server — give the name of the default Job Monitor.
psqueue-progress <id>: give progression of the currently identified and running
verification. This command does not apply to unit-by-unit verification groups, only the
individual jobs within a group.
* [-open-launcher] display the log in the Polyspace user interface.

[-Fful 1] give full log file.

*  psqueue-set-password <password> <new password> — change
administrator password.

psqueue-check-config — check the configuration of Job Monitor.

* [-check-licenses] check for licenses only.
psqueue-upgrade — Allow to upgrade a client side. See “Software Installation”.

* [-l1ist-versions] give the list of available release to upgrade.

* [-install-version <version number> [-install-dir <folder>]] [-
silent] allow to install an upgrade in a given folder and in silent.

Note: Polyspace Install/polyspace/bin/psqueue- <command> -h provides
information about available options for each command.
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Download Verification Results from Server

You can download verification results at the command line using the psqueue-
download command.

To download your results, enter the following command:

<PolyspaceCommonDir>/RemoteLauncher/bin/psqueue-download <id>
<results dir>

The verification <id> is downloaded into the results folder <results dir>.

Note: If you download results before the verification is complete, you get partial results
and the verification continues.

Once you download results, they remain on the client, and you can review them later in
the Polyspace user interface.

The psqueue-download command has the following options:

+ [-T] force download (without interactivity)
+ -—admin -p <password> allows administrator to download results.
* [-server <name>[:port]] selects a specific Queue Manager.

* [-v]version] gives the release number.

Note: When downloading a unit-by-unit verification group, all the unit results are
downloaded and a summary of the download status for each unit is displayed.
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Verification Failed Messages

If you see a message stating that Verification process failed, Polyspace software
did not perform the verification. The following sections present some possible reasons for
a failed verification.
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Hardware Does Not Meet Requirements

Hardware Does Not Meet Requirements

If your computer does not have the minimal hardware requirements, you see a warning
during verification, but the verification continues. For information about hardware
requirements for the Polyspace products, see:

www.mathworks.com/products/polyspaceclientada/requirements.html

To avoid this issue, upgrade your computer to meet the minimal requirements.
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Location of Included Files Not Specified

If you see the following message, either the included files are missing or you did not
specify the location of included files:

example.adb, line 12 (column 14): Error: "runtime_error (spec)" depends
on “types (spec)”

For information on how to specify the location of include files, see “Create Project”.
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Polyspace Software Cannot Find the Server
If the Polyspace software cannot find the server, you see the following message in the log:
Error: Unknown host :

To find the server information:

1 Select Tools > Preferences.

2 Select the Server configuration tab.

7-5



7 Troubleshooting Verification

7-6

% Polyspace Preferences 2
| Tools Menu Review Configuration | Review Statuses Miscellaneous | Character Encoding
Server Configuration | Fraject and Results Folder | Editors
MDCS duster configuration

Job scheduler host name:
Metrics configuration

@ Automatically detect the Polyspace Metrics server

() Use the following server and port: 12427

The server name “localhost™ can be used if the server is the local machine.

Polyspace Metrics allows you, through a Web browser, to drill down to specific coding rule violations and run-time checks. If you want to
view or dassify these items as defects within Polyspace, you dick the item. Polyspace opens with the spedific item displayed. However,
this feature requires the downloading of results from the Polyspace Metrics Web interface to a locally accessible folder. On this tab, you
specify how results are downloaded from the Polyspace Metrics Web interface and when justifications are saved in the Polyspace
Meftrics repository.

If you select this check box, results are downloaded to the folder from where the verification was run. If this folder does not exist,
results are downloaded to the location specified in the Folder field.
If you do not select this check box, a file browser allows you to select the download location.

Download results automatically
Folder: Wserverusername\Documents\Polyspace_Workspace\DownloadedResults

If you select this check box, the save action (Ctrl+5) will save your justifications in the local results folder and the Polyspace Metrics
repository. If you do not select this check box, the save action will save justifications in the local results folder only. If you want to save
justifications in the Polyspace Metrics repository, dick the 'Save in repository' button,

[7] save justifications in the Polyspace Metrics repository

Port used to communicate with the Polyspace Metrics Web interface.

Port number: 12428

The Polyspace Metrics Web interface URL is defined by: http:/f:.

Note that the remote server is configured above.

Web server port number: 8080

[] Use secure HTTPS protocol instead of HTTP protocol to access Metrics results
Web server port number for HTTPS: (5443

l oK ” Apply ” Cancel




Polyspace Software Cannot Find the Server

How you handle this error depends on the selected remote configuration option.

Remote Configuration Option Solution
Automatically detect the remote Specify the server by selecting Use
server the following server and port and

providing the server name and port.

Use the following server and port Check the server name and port number.

For information about setting up a server, see the Polyspace Installation Guide.
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Limit on Assignments and Function Calls
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If you start a client verification for a large file, the verification can stop with an error
message stating that the number of assignments and function calls is too large. For
example:

*** | icense error: number of assignments and function calls is too large

*** for the desktop mode (15462 v.s 2000).
*** Aborting.

--- Verifier has encountered an internal error. -—=
--- Please contact your technical support. -

Failure at: Dec 21, 2009 18:21:42
User time for polyspace-ada: 1773real, 1097.1u + 101s (6.1gc)
Exiting because of previous error

*hk

*** End of Polyspace Verifier analysis

*hk

The Polyspace Client for Ada software can verify only Ada code with up to 2,000
assignments and calls.

To verify code containing more than 2,000 assignments and calls, run a server
verification using Polyspace Server for Ada.



Examining the Compile Log

Examining the Compile Log

The compile log displays compile-phase messages and errors. You can search the log by
entering search terms in the Search box.

To examine errors in the Compile log:

1 In the log area of the Polyspace user interface, click Compile.

A list of compile-phase messages appear in the log part of the window.

Type Message File Line Col
|Ada 85 verification starts at Jul 3, 2013 14:37:28 -
"Rmes " never assigned a value utl.adb 7 7 3
*"is never assigned a value exemple.adb 150 7 3
INo CPU has been defined to run a ADA9S verification using the 6.6 (R2013b Prerelease) product.
/An error occured hie sending the verification to the queue. -

2 Click a message to see message details, as well as the full path of the file containing
the error.

File Line ol

Type Message
(i) |ads o5 verfication starts at 3 3, 2013 14:37:28 [ [ [ I-
7 [Rmesis never assigned a value util.adb 7 d IE
7 [Viisnever assigned a value example. adb 150 7 5
o CPU has been defined to run a ADA cation using the 6.6 (R2013
1 |an error ocured whie sendng the verification to the queue. -
etail
Error:

Mo CEU has been defined to run a ADESS verification using the 6.6 (R2013b Prerelease) product.
Please open the Remote Launcher Manager GUI on the server and check the
product you are using is properly installed and configured.

[E]ullLog | ] Verification Statistics | W Progress Monitor | [=] Output Summary

3 To open the source file referenced by a message, right-click the row for the message.
From the context menu, select Open Source File.

The file opens in your text editor.

4 Fix the error and run the verification again.
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Common Compile Errors

7-10

In this section...

“Missing specification for unit” on page 7-10
“Calendar not found” on page 7-11

“Not a predefined library unit” on page 7-11
“representation clause appears too late” on page 7-12
“Package system and standard include” on page 7-12
“Unsigned type” on page 7-13

“Function not declared in package” on page 7-13
“pre-elaborated unit” on page 7-13

“actual must be a definite subtype” on page 7-14
“ref attribute” on page 7-15

“Cannot load s-dec.ads (unit not found)” on page 7-15
“Green Hills standard include” on page 7-16
“Package Analysis Limitation” on page 7-16

“Ambiguous Bounds in Discrete Range” on page 7-17

Missing specification for unit
Problem

You must supply complete specifications associated with a package body verification to
the Polyspace software. If you do not, you might encounter the following error message:

Verifying _pst_main

Verifying my_package

-> Verifier found an error

in ./My_Package.adb, line 2 (column 14):
Missing specification for unit "My Package"

Solution/Workaround

Include the specifications of the package body in the list of supplied sources.
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Explanation

When you supply a package body as the source, and the package body specification as one
of the specifications in one of the —ada-include-dir folders, the Polyspace software
reports this error.

Calendar not found

Problem

The compiler did not find the package calendar.

Solution/Workaround

In the sources folder, create a file with:

With ada.calendar;
package calendar renames ada.calendar

Explanation

For some compilers, the package calendar is on the top level. For the GNAT compiler, the
calendar is a child of Ada.

Not a predefined library unit
Problem

You see the error message:

"machine_code" is not a predefined library unit
Solution/Workaround

In the sources folder, create a file with the following lines:

with System.Machine_Code;
package Machine_Code renames System.Machine_Code;

Explanation

Depending on the compiler that you are using, the subpackage of the package system can
have a different name.
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representation clause appears too late
Problem

The compilation phase stops and displays the warning:

representation clause appears too late
Solution/Workaround

Change:

type the_type is new Integer range O .. 10;
var : the_type;
for the_type“size use 16; -- Error : representation clause appears too late

to:

type the_type is new Integer range O .. 10;
for the_type“size use 16;

Explanation

If you use a type between its declaration clause and the representation clause, the
Polyspace software displays this warning.

Package system and standard include
Problem

The standard include files are dependent on the compiler. You may see the following
error message:

-> Verifier found an error in fl.ada, line 253 (column 29): "Offset" not
declared(l) in "System"

-> Verifier found an error in f2_ada, line 758 (column 43): expected type
"'System.OFFSET"

Solution/Workaround

Copy the system.ads file from <product_dir>\adainclude into your sources folder
and insert the line:

type OFFSET is range -2**31 .. 2**31-1;
Explanation

This type definition is specific to the AONIX/Alsys Ada compiler.
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Unsigned type

Problem

Some code uses unsigned types. The Polyspace compiler does not support unsigned types.
Solution/Workaround

Define unsigned types as follows:

type unsigned_integer is mod 4294967296;
type unsigned_short_integer is mod 65536;
type unsigned_tiny_integer is mod 256;

Function not declared in package
Problem

The package operations does not declare the function New_ATCB. The package
System.Tasking. Initialization declares that function.

Solution/Workaround

Copy the file s-taprop.ads from <product-dir>/adainclude/ into the sources
folder. Into the s-taprop.ads file, insert the following line:

function New_ATCB (Self_ID : integer) return Task_ ID;
Explanation

Add missing specifications to the package.

pre-elaborated unit

Problem

This package has a pragma preelaborate construct.
Solution/Workaround

Comment out the pragma preelaborate construct.
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actual must be a definite subtype
Problem

The compile error message is:

actual for ""SOURCE"™ must be a definite subtype

If the formal subtype is definite, the actual subtype must also be definite. This error is
a valid compilation error in Ada 95 but is not valid in Ada 83. For more information, see
the Ada 95 standard (12.5.1-6) and Ada 95 annotated (12.5.1-28.a).

The following example can be extended to other generic declarations. This example is
based on the unchecked_conversion generic function.

The example code is:

generic

type SOURCE is limited private;

type TARGET is limited private;
function UNCHECKED_CONVERSION (S : SOURCE) return TARGET;
with UNCHECKED_CONVERSION;
package Test is

type INDEX is new INTEGER;
type DATA_INDEX is new INTEGER;

type UNCONSTRAINED_DATA_TYPE is array
(INDEX range <>) of INTEGER;

subtype CONSTRAINED_DATA_TYPE is
UNCONSTRAINED_DATA_TYPE (INDEX range INDEX"First..Index"LAST);

function TO_DATA is new UNCHECKED_CONVERSION
(SOURCE => UNCONSTRAINED_DATA_TYPE,
TARGET => INTEGER);

procedure Main;

end Test;
Solution/Workaround

Change the lines:

type SOURCE is limited private;
type TARGET is limited private;
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to:

type SOURCE (<>) is limited private;
type TARGET (<>) is limited private;

to match the Polyspace definitions.
Explanation

The Polyspace provides its own version of Unchecked Conversion and its own
definition of the SOURCE and the TARGET.

'ref attribute
Problem

The use of the "reT attribute is not standard. The Polyspace software does not support
that attribute.

Two examples that cause a compile error are:
system.address"ref (16#FFFF_FFFF#)

a_varref

Solution/Workaround

In the preceding examples, use the following code instead:
system.address (16#FFFF_FFFF#)

var’address

Explanation

This attribute is dependent on the compiler.

Cannot load s-dec.ads (unit not found)
Problem

When compiling VMS Ada code, you may see the following error message:
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cannot load s-dec.ads (unit not found)

Solution/Workaround

Comment out every line that uses the AST_entry or Type_class attribute.
Explanation

The AST_entry and Type_class attributes are specific to VMS Ada.

Green Hills standard include
Problem

When analyzing a Green Hills® application, you may see compile errors due to:

* The compatibility between the Polyspace and Green Hills include files

* A limitation the Polyspace Verifier encounters when compiling a Green Hills include
file

Solution/Workaround

The Polyspace software now provides a specific option for the Green Hills Ada compiler.
For more information, see “T'arget operating system”.

Explanation

The $POLYSACE_ADA/adainclude/greenhi lIs folder contains the Green Hills
compiler include files.

Package Analysis Limitation

Problem

Suppose you have a types package that defines a task to a pointer type. Other packages
include this type package using the with clause. When you use that pointer type in the
package, you cannot analyze that package.

Solution/Workaround

1 Copy package specifications that have unsupported construction from the includes
folder to the include-modified folder.
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2 In these files, comment out every unsupported construction.

3 Use the —ada-include-dir option to incorporate the modified files in the analysis.

For example:

polyspace-ada -lang ada95 \
-ada-include-dir $HERE/includes \
-ada-include-dir $HERE/includes-modified \
-extensions-for-spec-files "*_.a??"

Note: If a package is defined in two different folders, the file compiled and analyzed
by Polyspace is the last one specified.

Explanation

By taking these steps, you do not have to modify the original files. You must maintain
copies of the original files in the includes-modified folder. These types of include files
do not change very often.

Use this workaround for an Ada compiler standard include file.

Ambiguous Bounds in Discrete Range
Problem

The type System.address must be declared private in the package System (file
system.ads). Otherwise, your verification might fail with the following error:
Verifying _pst _main

Verifying mypackage

mypackage.ada, line xx (column yy): Error: ambiguous bounds in discrete range
Warning: Failed compilation of mypackage

Solution/Workaround

Rerun the verification with the following options:

-0S-target gnat -D PST_GNAT_SYSTEM_ADDRESS_TYPE_IS_PRIVATE
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Multiple File Error in File by File Verification
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Issue

When you run a file by file verification, you get the following error message:
Verifying unit Filel (2/2)
Error: Unit Filel is defined multiple times

and has already been treated. Skipped
Warning: Failed compilation of unit: Filel

For more information on the analysis option for running file by file verification, see
“Verify files independently”.

Possible Cause

You added source files that have the same name.

The files are located in different folders in your file system. Therefore, the conflict does
not occur in your file system.

Solution

To perform the file by file verification, work around the file name conflict by:

*  Renaming the files.

* Creating a separate module in your Polyspace project. Move the files that cause the
file name conflict to that module.

For more information on creating modules, see “Modularize Project” on page 3-11.



Verification Time Considerations

Verification Time Considerations

In relation to the verification time, consider the following factors:

* Size of the code
*  Number of global variables

* Nesting depth of the variables (the more nested the variables are, the longer the
verification takes)

* Depth of the application call tree

+  “Intrinsic complexity” of the code, particularly the arithmetic manipulation

Polyspace software provides graphical and textual output to indicate how the verification
1s progressing.
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Displaying Verification Status Information
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For client verifications, monitor the progress of your verification using the Output
Summary and Dashboard tabs in the user interface.

For server verifications, use the Polyspace Job Monitor to follow the progress of your
verification.

The progress bar highlights each completed phase and displays the amount of time for
that phase. You can estimate the remaining verification time by extrapolating from this
data, and considering the number of files and passes remaining.

For more information, see:

* Client verification: “Monitor Progress” on page 6-2

+  Server verification: “Monitor Progress” on page 6-5



Ideal Application Size

Ideal Application Size

There is a compromise between the time and resources required to verify an application,
and the resulting selectivity. The larger the project size, the broader the approximations
made by Polyspace. These approximations enable Polyspace to extend the range of
project sizes that it can manage and to solve incomputable problems. You must balance
the benefits from verifying the whole of a large application against the resulting loss of
precision.

Begin with package by package verifications. The maximum recommended application
size 1s 100,000 lines of code.

Subdividing an application prior to verification typically has a beneficial impact on
selectivity—that is, more red, green, and gray checks, fewer orange warnings, and
therefore more efficient bug detection.

% of oranges

Oranges due to
complexity

Oranges due to
missing parts of
— the software

Size (lines of code)

Best usage: 100 KB - 120 KB
lines of code

A compromise between selectivity and size
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Optimum Size

7-22

Polyspace software verifies numerous applications with greater than 100,000 lines of
code. However, as project sizes become very large, the Polyspace Server:

*  Makes broader approximations, producing more orange checks.

+ Can take much more time to verify the application.

Before you use another form of testing, use the Polyspace software early on in the
development process.

When a small module (file, piece of code, package) is verified using Polyspace, focus on
the red and gray checks. Orange unproven checks at this stage are very useful, because
most of them deal with robustness of the application. The checks change to red, gray, or
green as the project progresses and more and more modules are integrated.

During the integration process, the code might become so large (100,000 lines of code
or more) that the verification of the whole project is not achievable within a reasonable
amount of time. You have several options:

+  Keep using Polyspace only upstream in the process.

* Verify subsets of the code.

+ Use the —unit-by-unit option, as described in “Subdivide According to Files” on
page 7-27.



Selecting a Subset of Code

Selecting a Subset of Code

If a project is subdivided into logical sections by considering data flow, the total
verification time is shorter than for the project considered in one pass. (See also “Volatile
Variables”and “Automatic Stubbing” on page 5-6.)

In such an application, consider the following:

+ Function entry points — Refer to the Polyspace execution model because the function
entry points are started concurrently, without assumptions regarding sequence or
priority. They represent the beginning of your call tree.

* Data entry points — Examine the lines in the code where data is acquired as “data
entry points”

Consider the following examples.

Example 1

Procedure complete_treatment_based_on_x(input : integer) is
begin

thousand of line of computation...
end

Example 2

procedure main is

begin
X:
y:

end

read_sensor();
complete_treatment_based_on_x(x);

Example 3

REGISTER_1: integer;
for REGISTER_1 use at 16#1234abcd#;
procedure main is

begin

Xx:= REGISTER_1;

y:= complete_treatment_based_on_x(X);
end

In each example, the x variable is a data entry point, and y is the consequence of a data
entry point. y may be formatted data, due to a very complex manipulation of X.
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Because X is volatile, y contains all possible formatted data. You can completely remove
the procedure complete_treatment _based_on_x and let automatic stubbing work. It
then assigns a full range of data to y directly.

-- removed body of complete_treatment_based on_x
procedure main is

begin

X:= ... -- what ever;

y:= complete_treatment_based_on_x(x); -- now stubbed!
end

Results

* (-) A slight loss of precision on y. Polyspace considers all possible values for y,
including the formatted values present at the first verification.

* (+) A huge investigation of the code is not required to isolate a meaningful subset.
* (+) Functional modules are not lost.

* (+) The results are still valid, because you do not have to remove a thread that uses
shared data.

* (+) The complexity of the code is considerably reduced.

* (+) A high precision level (for example, 02) can be maintained.

Examples of Removable Components

* Error management modules. Contain a large array of structures that are accessed
through an API, but return only a Boolean value. By removing the API code and
retaining the prototype, the automatically generated stub is assumed to return a
value in the range [-2731, 2731-1], which includes 1 and 0. The procedure is
considered to return the full range of possible results

*  Buffer management for mailboxes coming from missing code. Suppose an
application reads a huge buffer of 1024 char, and then uses it to populate three small
arrays of data, using a very complicated algorithm before passing it to the main
module. If the buffer is excluded from the verification and the arrays are initialized
with random values instead, the verification of the remaining code is unaffected.

Subdivide According to Data Flow

Consider the following example.



Selecting a Subset of Code

Module A reads variables vari1,var2,var3
and produces variables var4,var5,var6é

vari —s| Module A —» Var4 —ms| Module B
containing more containing more
var2 than one function vars than one function
Al B1
A2 B2
vars —» A3 —» Vare —s B3

In this application, varl, var2, and var3 can vary between the following ranges.

varl Between 0 and 10
var2 Between 1 and 100
var3 Between -10 and 10

Specification of Module A:

Module A consists of an algorithm that interpolates between varl and var2. That
algorithm uses var3 as an exponential factor. When varl is equal to 0, the result in

var4 is also equal to 0.

As a result, var4, var5, and var6 are produced with the following specifications.

Ranges vardvarb5var6 Between -60 and 110Between 0 and
12Between 0 and 100
Properties A set of properties For example:

between variables

<12

+ Ifvar2is equal to 0, then var4d > var5 > 5.
+ Ifvar3is greater than 4, then var4 <var5b

Subdivision in accordance with data flow allows modules A and B to be verified

separately:

* Ausesvarl, var2, and var3, initialized respectively to [0;10], [1;100] and

[-10;10].
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* B uses var4, var5b, and var6, initialized respectively to [-60;110], [0;12], and
[-10;10].

Results:

* (-) A slight loss of precision on the B module verification, because now the
combinations for var4, var5, and var6 are restricted by the A module verification.

*  For instance, if the B module included the test:
IT var2 is equal to 0, then var4d > var5 > 5

then the dead code on subsequent else clauses are undetected.

* (+) An in-depth investigation of the code is not required to isolate a meaningful
subset.

* (+) The results remain valid, because you do not have to remove a thread that changes
shared data.

* (+) The complexity of the code is reduced by a significant factor.

* (+) The maximum precision level can be retained.
Examples of removable components:

*  Error management modules. A function has_an_error_already_occurred
might return TRUE or FALSE. Such a module may contain a big array of structures
that are accessed through an API. The removal of the API code with the
retention of the prototype results in the Polyspace verification producing a stub
which returns [-27°31, 2731-1], including 1 and 0. Therefore, the procedure
has_an_error_already_occurred returns the full range of possible answers, as
the code does at execution time.

* Buffer management for mailboxes coming from missing code. Suppose a large
buffer of 1024 char is read, and the data is then collated into three small arrays of
data using a complicated algorithm. This data is then given to a main module for
processing. For the Polyspace Server verification, the buffer can be removed and the
three arrays initialized with random values.

* Display modules.

Subdivide According to Real-Time Characteristics

Another way to split an application is to isolate files that contain only a subset of tasks
and to verify each subset separately.
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If a verification is initiated using only a few tasks, Polyspace Server loses information
regarding the interaction between variables.

Suppose an application involves tasks T1 and T2, and a variable x.

If T1 modifies X, and T2 is scheduled to read X at a particular moment, subsequent
operations in T2 are impacted by the values of x.

As an example, consider that T1 can write either 10 or 12 into X and that T2 can
both write 15 into X and read the value of x. There are two ways to achieve a sound
standalone verification of T2:

+ X can be declared as volatile to take into account all possible executions. Otherwise,
X takes only its initial value or X remains constant, and T2 verification is a subset of
possible execution paths. You might have precise results, but for only one scenario
among possible states for the variable X.

* X can be initialized to the whole possible range [10;15], and then the T2 entry point
called.

Subdivide According to Files

Extract a subset of files and perform a verification, in one of three ways:

* Use entry points.

* Create a main that calls randomly those functions that are not called by other
functions within this subset of code.

* Relaunch your verification using the —unit-by-unit option. (For more information,
see “Verify files independently”.)

When you want to find red errors and bugs in gray code, this method can produce good
results.
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Benefits of Methods
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You might want to split the code:

* To reduce the verification time for a particular precision mode.

* To reduce the number of oranges (for details, see the following sections).

The problems that subdivision may create are:

*  Orange checks from a lack of information regarding the relationship between
modules, tasks, or variables.

* Orange checks from using too wide a range of values for stubbed functions.

When the Application is Incomplete

When the code consists of a small subset of a larger project, a lot of procedures are
automatically stubbed. Automatic stubbing is done according to the specification or
prototype of the missing functions. Therefore Polyspace assumes that all possible values
for the parameter type can be returned.

Consider two 32-bit integers a and b, which are initialized with their full range due to
missing functions. Here, a*b causes an overflow, because a and b can be equal to 231.
The number of incidences of these “data set issue” orange checks can be reduced by
precise stubbing.

Now consider a procedure F that modifies its input parameters a and b, both of which are
passed by reference. Suppose that a might be modified to a value between 0 and 10, and
b might be modified to a value between -10 and 10. In an automatically stubbed function,
the combination a = 10 and b = 10 is possible, even though it might not be possible with
the real function. This approach can introduce orange checks in a code snippet such as 1/
(a*b - 100), where the division would be orange.

+  Even where precise stubbing is used, verifying a small part of an application might
introduce extra orange checks. However, the net result from reducing the complexity
is to reduce the total number of orange checks.

*  When using the default stubbing, the increase in the number of orange checks is more
pronounced.



Benefits of Methods

Application Code Size

Polyspace can make approximations when computing the possible values of variables in
your code. Such an approximation uses a superset of the actual possible values.

For example, in a relatively small application, the Polyspace Server might retain detailed
information about the data at a particular point in the code. For example, the variable
VAR can take the values{ -2 ; 1 ; 2 ; 10 ; 15 ; 16 ; 17 ; 25 } IfVARis
used to as a divisor, the division is green (because 0 1s not a possible value).

If the program being verified is large, the Polyspace Server simplifies the internal
data representation using a less precise approximation, such as [-2 ; 2] U {10} U
[15 ; 17] U {25} . Here, the same division appears as an orange check.

If the complexity of the internal data becomes even greater later on in the verification,
the Polyspace Server might further simplify the VAR range to [-2 ; 25].

When the size of the program becomes large, this phenomenon leads to the increase of
the number of orange warnings.

Note: The amount of simplification applied to the data representations also depends
on the required precision level (00, 02). The Polyspace Server adjusts the level of
simplification, for example:

+  -00 — Shorter computation time

* -01 — Fewer orange warnings

*  -02 — Default and high-precision results

+ -03 — Fewer orange warnings and longer computation time
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Obtaining Configuration Information

Use the polyspace-ver command to quickly gather information about your system
configuration. You require this information when entering support requests.

Configuration information includes:
* Hardware configuration

+  Operating system

*  Polyspace licenses

* Specific version numbers for Polyspace products

+ Installed Bug Report patches

To obtain configuration information, use the following command:

Polyspace_Install/polyspace/bin/polyspace-ver

Note: You can obtain the same configuration information by selecting Help > About in
the Polyspace verification environment.
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Storage of Temporary Files

If you specify the option -tmp-dir-in-results-dir, Polyspace does not use the
standard /Ztmp or C:\Temp folder to store temporary files. Instead, Polyspace uses a
subfolder of the results folder. If the results folder is mounted on a network drive, this
action can increase verification time. Use this option only when the temporary folder
partition is not large enough and you need to troubleshoot.

You can specify -tmp-dir-in-results-dir through a line command or the
Configuration > Advanced Settings > Extra Settings field.
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Disk Defragmentation and Antivirus Software
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If a disk defragmentation tool or antivirus software runs on the machine on which your
client or server verification is running, the verification might fail, generating an error
message like the following:

Some stats on aliases use:

Number of alias writes: 22968
Number of must-alias writes: 3090
Number of alias reads: 0
Number of invisibles: 949

Stats about alias writes:

biggest sets of alias writes: fool:a (733), foo2:x (728), fool:b (728)

procedures that write the biggest sets of aliases: fool (2679), foo2 (2266), foo3 (1
**** C to intermediate language translation - 17 (P_PT) took 44real, 44u + Os (1.4gc)
exception SysErr(0S.SysErr(name="Directory not empty", syserror=notempty)) raised.
unhandled exception: SyskErr: No such file or directory [noent]

-—- Verifier has encountered an internal error. -—
--— Please contact your technical support. -——=

On your machine, you must do the following:

+ Stop the disk defragmentation tool.

* Deactivate the antivirus software, or configure exception rules for the antivirus
software that allow Polyspace to run without failure.



Out-of-Memory Errors During Report Generation

Out-of-Memory Errors During Report Generation

During generation of very large reports, the software might produce errors that indicate
insufficient memory. For example:

Exporting views. ..
Initializing. ..
Polyspace Report Generator
Generating Report
Converting report
Opening log file: C:\Users\auser\AppData\Local\Temp\java.log.7512
Document conversion failed
Java exception occurred:
java.lang.OutOfMemoryError: Java heap space

To increase the Java® heap size, modify the —Mx option in the
Polyspace_Install\polyspace\bin\architecture\java.opts file. By default,
the heap size is set to 512 MB. For 32-bit machines, you can increase the size to 1 GB.
For 64-bit machines, you can specify a higher value, for example, 2 GB.
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Error from Special Characters
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Issue

Your file or folder names contain extended ASCII characters, such as accented letters or
Kanji characters. You face file access errors during analysis. Error messages you might
see include:

* No source files to analyze
+ Control character not valid
+ Cannot create directory Folder_Name

Cause

Polyspace does not fully support these characters. If you use extended ASCII in your file
or folder names, your Polyspace analysis may fail due to file access errors.

Workaround

Change the unsupported ASCII characters to standard US-ASCII characters.
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Polyspace Checks

Polyspace software presents verification results as colored entries in the source code.
There are four main colors in the results:

Red — Indicates code proven to contain an error
Gray — Indicates unreachable code (dead code).
Orange — Indicates unproven code (code might have a run-time error).

Green — Indicates code proven not to have a run-time error

When reviewing verification results, remember these rules:

An instruction is verified only if no run-time error is proven to occur in the previous
instruction.

The verification assumes that each run-time error causes a “core dump”. The
corresponding instruction is considered to have stopped, even if the actual run-
time execution of the code might not stop. With orange checks, only the green parts
propagate through to subsequent checks.

Focus on the message produced by the verification, and do not jump to false
conclusions. You must understand the color of a check step by step, until you find the
root cause of the issue.

Determine the cause by examining the actual code. Do not focus on what the code is
supposed to do.
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Verification Following Red and Orange Checks

Verification Following Red and Orange Checks

Polyspace considers that all execution paths that contain a run-time error terminate at
the location of the error. Therefore:

* Following a red check, Polyspace does not analyze the remaining code in the same
scope as the check.

* Following an orange check, Polyspace analyzes the remaining code. But it considers
only the subset of execution paths that did not contain the run-time error.

Use these two rules to understand your checks. The following examples show how

the two rules can result in checks that can be misleading when viewed out of context.
Understand the examples below thoroughly to practice reviewing checks in context of the
remaining code.

In this section...

“Verification Following Red Check” on page 8-3
“Green Check Following Orange Check” on page 8-3
“Gray Check Following Orange Check” on page 8-4

Verification Following Red Check

Consider each line of the procedure red, which shows what happens after a red check.

procedure red is
X: integer;
begin

X:=1/7 X;

X:= X + 1;

end;

When Polyspace divides by X, X is not initialized. Therefore, the software generates a red
NIV check for the non-initialized variable X. Execution paths following this statement are
stopped. Checks are not generated for the statement X:= X + 1;

Green Check Following Orange Check

Now consider the procedure propagate, which shows how green checks propagate out
of orange checks.
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function read_an_input return integer;
procedure propagate is

X: Integer;

Y: array (0..99) of Integer;;

begin

X:= read_an_input;

Y(X):= 0;

Y(X):= 0;

end main;

For the propagate procedure:
+  Xis assigned the value of read_an_input. After this assignment, X = [-2731,
2731-1].

+ At the first array access, an “out of bounds” error is possible because X can be equal
to, for example, -3 as well as 3.

* The conditions leading to a run-time error are truncated. They are not considered
further in the verification. On the following line, the executions for which X =
[-2731, -1] and [100, 2731-1] are stopped.

+ At the next instruction, X = [0, 99].

* At the second array access, the check is green because X = [0, 99].

Therefore, green checks can propagate out of orange checks.

Note: Through manual stubbing and by using assert, you can use value propagation to
restrict input values for data.

See “Using Pragma Assert to Set Data Ranges” on page 4-18.

Gray Check Following Orange Check

Consider the following example, paying particular attention to the dead (gray) code
following the "if" statement:

function Read_An_Input return integer;
procedure Main is

X: Integer;

Y: array (0..99) of Integer;

begin
X = Read_An_input;
Y(X) := 0; -- [array index may be without its bounds] [x is
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initialized]
Y(X-1):= (1 /7 X) + X ; [array index is within its bounds]

if (X = 0) then

Y(X) = 1; -- this line is unreachable
end if;

end Main;

You can see that:

* The line containing the access to the Y array is unreachable.
* The line is unreachable only if the test for x = 0 is always false.

* You can conclude that the test is false because the input data is not equal to 0.
However, Read_An_ Input can represent a value in the full integer range, so this is
not the correct explanation.

Instead, consider the execution path leading to the gray code:
* The orange check on the array access (y[x]) truncates execution paths leading to a

run-time error, meaning that subsequent lines deal with only x = [0, 99].

* The orange check on the division also truncates execution paths that lead to a run-
time error, so instances where x = 0 are also stopped. Therefore, for the code execution
path after the orange division sign, X = [1; 99].

* x1is not equal to O at this line. The array access is green (y (x — 1).
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Results Folder Contents

Every time you run an analysis, Polyspace generates files and folders that contain
information about configuration options and analysis results. The contents of results
folders depend on the configuration options and how the analysis was started.

By default, your results are saved in your project folder in a folder called Result_#. To
use a different folder, see “Specify Results Folder” on page 3-4.

Files in the Results Folder

Some of the files and folders in the results folder are described below:
* Polyspace_release_project name_date-time.log — A log file associated with
each analysis.

+ ps_results.rte — An encrypted file containing your Polyspace results. Open this
file in the Polyspace environment to view your results.

* ps_sources.db — A non-encrypted database file listing source files and macros.

* ps_comments.db — An encrypted database file containing your comments and
justifications.

+ comments_bak — A subfolder used to import comments between results.

+ _.status and .settings — Two folders that store files required to relaunch the
analysis. You relaunch the analysis using a .bat file in Windows and a .sh file in
Linux.

+ Polyspace-Doc — When you generate a report, by default, your report is saved in
this folder with the name ProjectName_ReportType. For example, a developer
report in PDF format would be, myProject Developer.pdf.

Related Examples
. “Specify Results Folder” on page 3-4
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Result Views in Polyspace User Interface

In this section...

“Results Summary” on page 8-7
“Source” on page 8-10

“Result Details” on page 8-13
“Variable Access” on page 8-13
“Call Hierarchy” on page 8-17

Results Summary

The Results Summary pane lists all checks along with their attributes. To organize

your check review, from the "~ list on this pane, select one of the following options.

* None: Lists all checks without grouping them. The checks are sorted in the following

order:

1 Red: Indicates code that is proven to contain an error. The check indicates that
the code will fail every time it is executed.

2 Gray — Indicates unreachable code.

3 Orange — Indicates unproven code that might contain an error.

4 Green — Indicates code that is proven to not contain an error.

*  Family: Lists checks grouped by color. Within each color, the checks are organized by
group. For more information on the check groups, see “Run-Time Checks”.

+ File: Lists checks grouped by file. Within each file, the checks are grouped by

procedure.
+ Package: Lists checks grouped by package. Within each package, the checks are
grouped by procedure.
For each check, the Results Summary pane contains the check attributes, listed in
columns:
Attribute Description
Family Group to which the check belongs. For
instance, if you choose the grouping File,
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Attribute

Description

this column contains the name of the file
and function containing the check.

ID

Unique identification number of the
check. In the default view on the Results
Summary pane, the checks appear sorted
by this number.

Type

Check color

Group

Category of the check. For more
information on the checks covered by a
group, see the check reference pages.

Check

Description of the error

Information

For run-time errors, this attribute indicates
whether the check is related to path or
bounded input values. For coding rule
violations, this attribute indicates whether
the rule is Required.

File

File containing the instruction where the
check occurs

Package

Package containing the instruction where
the check occurs

Function

Function containing the instruction where
the check occurs.

Line

Line number of the instruction where the
check occurs.

Col

Column number of the instruction where
the check occurs. The column number is the
number of characters from the beginning of
the line.




Result Views in Polyspace User Interface

Attribute Description

% Percentage of checks that are not orange.
This column is most useful when you
choose the grouping Checks by File/
Function. The entry in this column
against a file or function indicates the
percentage of checks in the file or function
that are not orange.

Severity Level of severity you have assigned to the
check. The possible levels are:

* Unset
* High

* Medium
+ Low

* Not a defect

Status Review status you have assigned to the
check. The possible statuses are:

+ Fix

* Improve

+ Investigate

+ Justify with annotations

* No action planned

+ Other

+ Restart with different options

Justified Check boxes showing whether you have
justified the checks

Comments Comments you have entered about the
check

To show or hide a column, right-click anywhere on the column title. From the context
menu, select or clear the title of the column that you want to show or hide.

Using this pane, you can:
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+ Navigate through checks. For more information, see “Add Review Comments to
Results” on page 8-32.

*  Organize your check review using column filters. For more information, see “Filter
and Group Results” on page 8-40.

Source

The Source pane shows the source code with colored checks highlighted.

ﬂ_
Dashboard 3 | tasks.adbh x 4 b+ B
loop
accept ORDER (X : cut Integer) do

Increase Fowerlewvel;

SHR4.A := 22;
E Tmp := vel+SHEL.R;

£= i {h_.h Print Source Code: tasks.adb
‘4, Search For "PowerLevel” in Current Source File Ctrl+F

|, Search For "PowerLevel" in All Source Files

m

End_CS; Go To Definition
Get_Powerlewel: Go Ta Line Ctrl+L
Compute_Injectioni| o Show Error Call Graph

Lazert (Fow

Showe In Wariable Access View
Add Pre-Justification To Clipboard
Showe Dashboard

end loop;
end Tregulate;

task body Tserver is Create Duplicate Code Window

Tooltips

Placing your cursor over a check displays a tooltip that provides range information for
variables, operands, function parameters, and return values.

Examine Source Code

In the Source pane, if you right-click a text string, the context menu provides options to
examine your code. For example, right-click the variable PowerLevel:
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Y Source
Results Statistics | tasks.adb |

with types; use types;
with runtime_error;
with pkutil; use pkutil;

package body pktasking is

Current_Data : Integer;
task body Tregulate is
Tmp: INTEGER;
begin
accept INIT;

loop
accept ORDER (X :
Increase Powerlewel;
SHR4.Z

1= 22;

—- Copyright 2012 The MathWorks,

Inc.

out Integer) do

m

Get_Fowerlevel;

Compute_Injection:

end Tregulate;

task body Tserver is

EOoWErLewel+SHR4 . A7
e '{E Print Source Code: tasks.adb

(4 Search "PowerLevel” In Current Source
(4 Search "PowerLevel” In All Source Files
Go To Definition
Go To Line
°€ Show Error Call Graph
Show In Variable Access View
Add Pre-Justification To Clipbeard

Show Results Statistics

Create Duplicate Code Window

Ctrl+F

Ctrl+L

I : Integer := 1;

Tmp : Integer;

4

I ¥ Source] Data Range Configuration ‘

Use the following options to examine and navigate through your code:

+ Search "PowerLevel" in Current Source — List occurrences of the string within
the current source file in the Search pane.

* Search "PowerLevel" in All Source Files — List all occurrences of the string in
source files. The results appear on the Search pane.

Go To Definition — Go to the line of code that contains the definition of
PowerLevel. The software supports this feature for global and local variables,

functions and types.
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* Go To Line — Open the Go To Line dialog box. If you specify a line number and click

Enter, the software displays the specified line of code.

+ Expand All Macros or Collapse All Macros — Display or hide the content of

macros in current source file.
Manage Multiple Files in Source Pane
You can view multiple source files in the Source pane.

On the Source pane toolbar, right-click a tab title to manage source files.

ﬁ—

Dashboard X | kasks.adb X |arraw.ada X |example.adh

Close
rocedure Recuraive 2 (depth : in outg
B -2 (dep Close Others
kegin
Recursion | » —— call to Recy Close Al
end Recursive_2; Previous

Ll

Mew Horizontal Group
—— BRecurszion may lead to zero divisid DD Mews Vertical G
ews Wertica rou

procedure Recursion (depth : in ocut i c
advance : float; Flaating

begin

—-- potential zero division

A

Recursive 2 (d

advance := float(l)/float(de;

end Recursion;

From the Source pane context menu, you can:

+ Close — Close the currently selected source file.

+ Close Others — Close all source files except the currently selected file.
+ Close All — Close all source files.

*  Next — Display the next view.

*  Previous — Display the previous view.

+ New Horizontal Group — Split the Source window horizontally to display the

selected source file below another file.

8-12
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+ New Vertical Group — Split the Source window vertically to display the selected
source file side-by-side with another file.

+ Floating — Display the current source file in a new window, outside the Source pane.

Result Details

On the Results Summary pane, if you click a check, you see additional information on
the Result Details pane.

On this pane, you can also assign a Severity and Status to each check. You can also
enter comments to describe the results of your review. This action helps you track the
progress of your review and avoid reviewing the same check twice.

¥/ Result Details )
QS | | feo array.ada / ARRAY_OVERFLOW_INIT()
[=] Result Review

Classification | + | [Enter comment here...

Status -

! overflow
Error: operation [conversion from 21 P 1..10] on scalar overflows (result is always strictly greater than MAX integer)

This check may be a path-related issue, which is not dependent on input values

Event File Scope Line
1 cConversion from a big type to a small type (from [-2°L..221-1] to [1.. 10], error when expr is in range -2==31..0 or 11..2°=31-1) array.ada  PKDATA{ 65

Errar: operation [conversion from -2°1,.2%!-1 to 1..10] on scalar overflows (result is always strictly areater than MAX integer) array.ada  ARRAY_OVERFLOW_INIT() 65

4 m r

Variable Access

The Variable Access pane displays global variables. For each global variable, the pane
lists functions and tasks performing read/write operation on the variables, along with
their attributes, such as values, read/write operations and shared usage.
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B
o8 (x] X
Variables Values  #Re.. #Wri... Written by task Read by task Protection Usage Line col File DataType
T A N I
PKDATA.SCALE 4 0 read butn... 29 3 array.ada array(L..10) of float32 -3.41E+38..3. 4
PKTASKING. CURRENT_DATA 112 0 2 10 3 ‘tasks.adb
PKTASKING. TREGULATE.TMP [-21474836 1 2 13 L ‘tasks.adb
PKTASKING. TSERVER T [1.. 100, 2 2 33 B ‘tasks.adb
PKTASKING. TSERVER. TP [21474838 0 1 2 6 |tasks.ads
PKUTIL INJECTION fulvange [ 0 2 25 3 utlada
PKUTIL NEW_ALTITUDE 12 3 1 2 3 utlada
~PKUTIL POWERLEVEL full-range [- 7 5 REGULATE SERVER 1 SERVER2 REGULATE SERVER 1 SERVER2 Rendez-vous shared 2t 3 util.ada
PKUTIL.SHR. Dor23 1 2 SERVER1 SERVER2 REGULATE Critical section  shared 20 3 util.ada
Dor 22 1 3 SERVER1 SERVER2 REGULATE shared 20 8 util.ada
PKUTIL.SHR3 Dor 28o. 1 2 20 14 util.ada *31-1
PKUTIL.SHR4 2 2 ONE_INTERRUPT2 REGULATE SERVER 1 SERVER2  ONE_INTERRUPT2 REGULATE SERVER1 SERVER2 Access pattern  shared 22 3 util.ada 2%%31-1,b:-27*31.. 27311}
PKUTIL.SHRS Sor 28 2 2 (ONE_INTERRUPT1 (ONE_INTERRUPT1 ONE_INTERRUPT2 Temporal exdu... shared 23 3 util.ada
PKUTIL.SHR6 1 2 1 24 3 util.ada
RANDOM.RANDOM_BOOLEAN 1 0 read butn... 5 3 random.ad false..true
RANDOM.RANDOM_FLOAT 1 0 read butn... 11 3 random.ad float32 -3.41E+38..3.4E+38
RANDOM.RANDOM_INTEGER. 1 0 read butn... 8 3 random.ado 27731277511
RUNTIME_ERROR.BETA [0.6501 ... 2 2 160 3 example.adb E+308..1.79E+308
RUNTIVE_ERROR BIG 1 0 read but .. 105 3 exampleads 231271

I

For each variable and each read/write access, the Variable Access pane contains the
relevant attributes. For the variables, the various attributes are listed in this table.

Attribute

Description

Variables Name of Variable, Package Name.
Variable Name
Package Name: Name of package where
variable is declared

Values Value (or range of values) of variable

# Reads

Number of times the variable is read

# Writes

Number of times the variable is written

Written by task

Name of tasks writing on variable

Read by task

Name of tasks reading variable

Protection

8-14

Whether shared variable is protected from
concurrent access

(Filled only when Usage column has entry,
Shared)

The possible entries in this column are:

+ Critical Section: If variable is accessed
in critical section of code
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Attribute Description
+ Temporal Exclusion: If variable is
accessed in mutually exclusive tasks
For more details on these entries, see
“Verification Mode”.
Usage Shared, if variable is shared between tasks;
otherwise, blank
Line Line number of variable declaration
Col Column number (number of characters from
beginning of line) of variable declaration
File Source file containing variable declaration
Data Type + If the variable has a scalar data type, this

column states the values allowed for the type.

+ If the variable is an array or a record, this
column states the values allowed for the data
types of its components.

Detailed Type

Data type of variable, if the variable has a scalar
data type.

Double-click a variable name to view read/write access operations on the variable.

The arrowhead symbols * and * in the Variable Access pane indicate functions
performing read and write access respectively on the global variable. Likewise, tasks

performing read and write access are indicated by the symbols [I» and 41 respectively.

For access operations on the variables, the various attributes described in the pane are

listed in this table.

Attribute

Description

Variables

Names of procedure (or task) performing read/
write access on the variable, Package_Name.
Procedure_Name

Package Name: Name of package containing
procedure (or task) definition
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Attribute

Description

Values

Value or range of values of variable in the
procedure or task performing read/write access

Written by task

Only for tasks: Name of task performing write
access on variable

Read by task Only for tasks: Name of task performing read
access on variable

Line Line number where procedure or task accesses
variable

Col Column number where procedure or task
accesses variable

File Source file containing access operation on

variable

You can also perform the following actions from the Variable Access pane.

* View Access Graph

View the access operations on a global variable in graphical format using the

Variable Access pane. Select the global variable and click %9 .

Here is an example of an access graph:

o

&

Demo_Ada - Co...da PKUTIL.5HR2 | Demo_Ada - Ac...NG.TSERVER. TMP

B83% - —J)

B

tasks.adb tasks.ads

PETASKING, MAIM PKTASKING, SERVERZ

tasks.ads

PETASKING SERVER1

tasks.adb tasks.adb

PKTASKING, TSERVER PETASKING, TSERVER, TMP WRITE
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+  Show/Hide Non-Shared Variables

Customize the Variable Access pane to show only the shared variables. On the

Variable Access pane toolbar, click the Non-Shared Variables button E& to show or

hide non-shared variables.

+ Hide Access in Unreachable Code

Hide read/write access occurring in dead code by clicking the filter button X[,

Call Hierarchy

The Call Hierarchy pane displays the call tree of procedures in the source code.

For each procedure, foo, the Call Hierarchy pane lists the procedures and tasks

that call oo (callers) and those called by oo (callees). The callers are indicated by 4

(procedures), or 1| (tasks). The callees are indicated by P (procedures) or [ (tasks).

In the following example, the Call Hierarchy pane displays the procedure,
SORT_CALIBRATION, in the package, SENSITIVITY. It also displays the callers and the

callees of SORT_CALIBRATION.

b b RANDOM,.RAMDOM

----- b FEDATA.COMYTOINTESER

= 4 RUMTIME_ERR.OR.MAIMRTE
b 4 PKTASKING, MAIN

1 | 1] [ b

Depending on the name, the corresponding line number in the Call Hierarchy pane

refers to a different line in the source code:
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*  For a procedure name, the line number refers to the beginning of
the procedure definition. In the preceding example, the definition of
SENSITIVITY.SORT_CALIBRATION begins on line 97.

* For a callee name, the number refers to the line where the callee is called.
In the preceding example, callee, SENSITIVITY_POLYNOMIA, is called by
SENSITIVITY ._SORT_CALIBRATION on line 108.

+ For a caller name, the number refers to the line where the caller calls the
procedure. In the preceding example, caller, RUNTIME_ERROR.MAINRTE, calls
SENSITIVITY.SORT_CALIBRATION on line 222.

Tip Select a caller or callee name to navigate to the procedure call in the source code.

You can perform the following actions from the Call Hierarchy pane:
+  Show/Hide Callers and Callees

Customize the view to display callers only or callees only. Show or hide callers and
callees by clicking this button

= | <
+  Go to Caller/Callee Definition

Go directly to the definition of a caller or callee in the source code. Right-click the
name of the caller or callee and select Go To Definition. .

8-18
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Why Review Dead Code Checks

In this section...

“Functional Bugs in Gray Code” on page 8-19

“Structural Coverage” on page 8-20

Functional Bugs in Gray Code

Polyspace verification finds different types of dead code. Common examples include:

Defensive code
Dead code due to a particular configuration.
Libraries which are not used to their full extent in a particular context.

Dead code resulting from bugs in the source code.

The causes of dead code listed in the following examples are taken from critical
applications of embedded software by Polyspace verification.

A lack of parenthesis and operand priorities in the testing clause can change the
meaning significantly.

Consider a line of code such as

IF NOT a AND b OR ¢ AND d

Now consider how misplaced parentheses might influence how that line behaves
IF NOT (a AND b OR c AND d)

IF ((NOT (a) AND b) OR (c AND d))

IF NOT (a AND (b OR c) AND d)

The test of variable inside an unreachable branch of a conditional statement.

An unreachable “else” clause where the wrong variable is tested in the “if” statement.
A variable that is supposed to be local to the file but instead is local to the function.

Wrong variable prototyping leading to a comparison which is always false.

The consequences of dead code and the effort to deal with it is unpredictable. From a
one-week effort of functional testing on target, trying to build a scenario going into that
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8-20

branch, and wondering why the functional behavior is altered to a three-minute code
review discovering the bug.

Polyspace does not measure the impact of dead code.

The tool provides a list of dead code. A short code review enables you to place each entry
from that list into one of the five categories. Doing so identifies known dead code and
uncovers real bugs.

The Polyspace experience is that at least 30% of gray code reveals real bugs.

Structural Coverage

Polyspace software performs upper approximations of possible executions. Therefore,
even if a line of code is shown in green, there remains a possibility that it is a dead
portion of code. Because Polyspace verification made an upper approximation, it could
not conclude that the code was dead. Instead it concludes that a run-time error could not
be found.

Polyspace verification finds around 80% of dead code that the developer would find by
doing structural coverage.

Polyspace verification is intended to be a productivity aid in dead code detection. It
detects dead code which might take days of effort to find by other means.
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Review Red Checks

During verification, Polyspace checks each operation in your code for certain run-time
errors. After verification, the software displays the checks on the Results Summary
pane.

A red check indicates that the operation fails the check on all execution paths. For
instance, a red Division by Zero check on a division operation indicates that a division
by zero occurs every time the operation takes place. Therefore, you must fix the code
containing a red check.

In this section...

“Step 1: Interpret Check Information” on page 8-21
“Step 2: Determine Root Cause of Check” on page 8-22

Step 1: Interpret Check Information

Select a check on the Results Summary pane.

*  On the Result Details pane, view further information about the check.

*  On the Source pane, the operation containing the check is highlighted.

If you place your cursor on the operation, the tooltip provides further information
about the check.

Sometimes, this information is enough to understand the root cause of the check. If

you can determine a fix for your code from this information, you do not have to proceed
further with this procedure.
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@S| & x example.adb / SQUARE_ROGT()
[l Result Review

Classification v: \Eter comment here. ..
Status -
! Arithmetic exceptions

Error: float argument of SQRT is not positive

Step 2: Determine Root Cause of Check

If you cannot determine the root cause based on the check information, using navigation
shortcuts in the user interface, navigate to the root cause.

1  Using the tooltips on variables or operations, identify the variable var that causes
the check. For instance, for a Division by Zero error, var can be the denominator
variable.

2 Trace the data flow for var.

a Browse through the previous instances of var. On the Source pane, place your
cursor on each instance of var to see its values.

Variable How to trace data flow

Local Variable Right-click the variable. Select Search For varname
in Current Source File or Search For varname in
All Source Files.

Global Variable i  Select the right-click menu option Show In

Variable Access View.
Right-click the variable.

If the option Show In The current instance of the variable is shown on
Variable Access View the Variable Access pane.
appears, the variable is

. il Select the previous instances of the variable on
a global variable.

this pane.
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Variable

How to trace data flow

Write operations on the variable are indicated

with { and read operations with » .

Tip On the Variable Access pane, drag the Line
column to the left. You can then easily see the line
numbers during navigation.

Procedure argument

procedure func(..,arg

end func;

On the Result Details pane, select the Fx
button.

On the Call Hierarchy pane, you see the calling
functions indicated with 4 .

Select a calling function name. You go to the call
to func in your source.

Identify the variable in the call to func that maps
to arg. This variable is your new variable to trace
back.

Tip On the Call Hierarchy pane, drag the Line
column to the left. You can then easily see the line
numbers during navigation.

Function return value

ret := func(Q;

Find the function definition.

Right-click func on the Source pane. Select Go
To Definition, if the option exists.

In the definition of func, identify each return
statement. The variable that the function returns
is your new variable to trace back.

b Find the instance where var acquires the value that can cause the run-time

error.

3 If var obtains values from another variable, trace the data flow for the second

variable.
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Continue this process until you identify the root cause of the check.
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Review Gray Checks

Gray checks indicate code that cannot be reached during run-time.

If the gray check indicates defensive code, ignore the check. For instance, you can have
error handling tests in your code. If the errors do not occur, the test blocks appear gray.
However, you might want to retain the error handling test.

In some cases, unreachable code results from coding errors. Therefore, you must review
the gray checks. Also, if you do not want to retain unnecessary code, review and fix gray
checks.

Note: Following a red check, Polyspace does not verify the remaining code in the same
scope as the check. However, this code does not appear gray on the Source pane.

Review and fix the red checks so that Polyspace can verify the remaining code. For more
information, see “Review Red Checks” on page 8-21.

1 After verification, see the code coverage metrics on the Dashboard pane.

The coverage metrics are displayed through the Code covered by verification
graph. The graph displays:
+  Percentage of code covered by verification.

Percentage of procedures covered by verification.

2 If the percentage of procedures covered is less than 100, investigate why there are
unreachable procedures. Select the column graph to see the full list of unreachable
procedures.

3 Investigate the Unreachable code checks further.

4 If you determine that the check represents defensive code, ignore the check. Add a
comment and justification in your result or code explaining the rationale.
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Review Orange Checks

During verification, Polyspace checks each operation in your code for certain run-time
errors. After verification, the software displays the checks on the Results Summary
pane.

An orange check indicates that the operation fails the check only on certain execution
paths. Investigate whether the execution paths can occur during run time. If you
determine that the execution paths can occur, you must fix the code containing the check.

In this section...

“Step 1: Interpret Check Information” on page 8-26
“Step 2: Determine Root Cause of Check” on page 8-27

“Step 3: Trace Check to Polyspace Assumption” on page 8-29

Step 1: Interpret Check Information

Select a check on the Results Summary pane.

*  On the Result Details pane, view further information about the check.

*  On the Source pane, the operation containing the check is highlighted.

If you place your cursor on the operation, the tooltip provides further information
about the check.

Sometimes, this information is enough to understand the root cause of the check. If

you can determine a fix for your code from this information, you do not have to proceed
further with this procedure.
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v m B 5L LIeTalls
&) o9 Iﬁ| fx > Demo_Single-File.adb / PARTIAL_INIT(

=] Result Review -

Classification v: \Enter comment here...

Status [ -

Non-initialized local variable
Warning: local variable may be non-initialized
This check may be a path-related issue, which is not dependent on input values
Variable 'y' (type: boolean [false..true]): 1

m

Event File Scope Line
1 Demo_Single-File.adh DEMO_DESKTOR() 73

2 7 Warning: local variable may be non-nitizlized Demo_Single-File.adb PARTIAL_INIT() 73

1

Step 2: Determine Root Cause of Check

If you cannot determine the root cause based on the check information, using navigation
shortcuts in the user interface, navigate to the root cause.

1  Using the tooltips on variables or operations, identify the variable var that causes
the check. For instance, for a Division by Zero error, var can be the denominator
variable.

2 Trace the data flow for var.

a Browse through the previous instances of var. On the Source pane, place your
cursor on each instance of var to see its values.

Variable How to trace data flow

Local Variable Right-click the variable. Select Search For varname
in Current Source File or Search For varname in
All Source Files.

Global Variable i  Select the right-click menu option Show In
Variable Access View.

Right-click the variable.
If the option Show In The current instance of the variable is shown on

Variable Access View the Variable Access pane.
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Variable

How to trace data flow

appears, the variable is
a global variable.

Select the previous instances of the variable on
this pane.

Write operations on the variable are indicated

with 4 and read operations with » .

Tip On the Variable Access pane, drag the Line
column to the left. You can then easily see the line
numbers during navigation.

Procedure argument

procedure func(..,arg

end func;

On the Result Details pane, select the F
button.

On the Call Hierarchy pane, you see the calling
functions indicated with 1 .

Select a calling function name. You go to the call
to Func in your source.

Identify the variable in the call to func that maps
to arg. This variable is your new variable to trace
back.

Tip On the Call Hierarchy pane, drag the Line
column to the left. You can then easily see the line
numbers during navigation.

Function return value

ret := func(Q;

Find the function definition.

Right-click func on the Source pane. Select Go
To Definition, if the option exists.

In the definition of func, identify each return
statement. The variable that the function returns
is your new variable to trace back.

b Find the instance where var acquires the value that can cause the run-time

error.
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If var obtains values from another variable, trace the data flow for the second
variable.

Continue this process until you identify the root cause of the check.

For orange checks, you have an additional option that helps with root cause
investigation. If a function is called several times and an error occurs only on certain
calls, you can identify which function call caused the check. For more information,
see “Sensitivity context”.

Step 3: Trace Check to Polyspace Assumption

If you cannot determine a coding error, try to trace the check to a Polyspace assumption
earlier in the code. If the assumption is broader than what you expect, do one of the
following:

If you can use an analysis option to relax the assumption, rerun verification using
that option.

In particular, determine if you must specify constraints outside your code or provide
other contextual information. See “Inputs & Stubbing”.

See if you can improve your coding design to avoid the assumption.

For instance, goto statements interrupt the flow and can cause orange checks during
verification. Avoid goto statements in your code.

To improve your coding design:

Enforce limits on code complexity metrics.
*  Observe coding rules.

Ignore the orange check. Add a comment and justification in your result or code
describing why you ignored the check.
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Review Global Variable Usage

After verification, Polyspace displays a list of global variables in your source code. Using
this list:

* You can remove variables that you define but do not use.

Such variables appear gray on the Results Summary and Source pane.
*  For code intended for multitasking, you can see which variables are not protected
from concurrent access by multiple tasks.
+ If Polyspace proves that a variable is protected, it appears green on the Results
Summary and Source pane.

* Otherwise, it appears orange.
For more information, see “Global Variables”.

To review global variable usage:

1 —
On the Results Summary pane, from the ~— © list, select Family.
The global variables appear together under one node.

2 Expand the Global Variable node. Review each result under the nodes:

+ Shared > Potentially unprotected variable.
* Not shared > Unused non-shared variable.

3 For each potentially unprotected variable, select the variable name.

a On the Result Details pane, view which tasks can access the variable.

b Read and write operations on the variable appear in this pane. Select each
operation to navigate to it in your source code.

This action also displays more details of the operation on the Variable Access
pane.

¢ To review your multitasking options, select Window > Show/Hide View >
Configuration.
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Identify whether you can leverage some of the existing protection mechanisms
to protect your variable. For more information on multitasking verification, see
“Critical section details” or “Temporally exclusive tasks”.
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Add Review Comments to Results

8-32

This example shows how to comment on results in the Polyspace user interface. When

reviewing results, you can assign a status to them, and enter comments to describe the
results of your review. These actions help you to track the progress of your review and

avoid reviewing the same result twice.

In this section...

“Assign and Save Comments” on page 8-32

“Import Review Comments from Previous Verifications” on page 8-33

Assign and Save Comments

1
2

On the Results Summary pane, select the result that you want to review.

Investigate the result further.

For more information, see:

“Review Red Checks” on page 8-21

“Review Gray Checks” on page 8-25

“Review Orange Checks” on page 8-26
“Review Global Variable Usage” on page 8-30

On the Results Summary or Result Details pane, provide the following review
information for the result:

Severity to describe how critical you consider the issue.

Status to describe how you intend to address the issue.

To justify the check, select one of the Status options, Justify with
annotations or No action planned. You can view the percentage of results

justified per file and function. On the Results Summary pane, from the "=
list, select File. View the entries on the Justified column.

You can also create your own status or associate justification with an existing
status. Select Tools > Preferences and create or modify statuses on the Review
Statuses tab.
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+  Comment to describe any other information about the result.

4 To provide review information for a group of results, select the results in the group
together. Then provide review information for a single result.

To select the results:
+ If the results are contiguous, left-click the first result. Then Shift click the last
result.

+ If the results are not contiguous, Ctrl click each result.

+ If the results belong to the same group and have the same color, right-click one
result. From the context menu, select Select All Color Type Results.
For instance, select Select All Orange "Overflow" Results.

5 To save your review comments, select File > Save. Your comments are saved with
the verification results.

Import Review Comments from Previous Verifications

* “Import Comments” on page 8-33

+ “Specify Automatic Comment Import from Last Verification” on page 8-34

+ “View Imported Comments That Do Not Apply” on page 8-34

After you have reviewed verification results, you can reuse your review comments for

subsequent verifications.

After you import checks and comments, clicking the & icon skips justified checks.
Therefore, you do not have to review checks twice.

Import Comments

Open your verification results.
Select Tools > Import Comments.

Navigate to the folder containing your previous results.

B WN —

Select the results file with extension . rte and then click Open.

The review comments from the previous results are imported into the current
results, and the Import checks and comments report opens. For information on this
report, see “View Imported Comments That Do Not Apply” on page 8-34.
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Specify Automatic Comment Import from Last Verification

1 Select Tools > Preferences, which opens the Polyspace Preferences dialog box.
2 Select the Project and Results Folder tab.

3 Under Import Comments, select Automatically import comments from last
verification.

4 Click OK.

After you set this preference, for every run, the software imports review comments
from the last run.

View Imported Comments That Do Not Apply

You can directly import review comments from another set of results into the current
results. However, it is possible that your review comments do not apply to a subsequent
verification because:

* You have changed your source code so that the check is no longer present.

* You have changed your source code so that the check color has changed.

* You have already entered different review comments for the same check.

The Import Checks and Comments Report highlights differences between two verification
results. When you import comments from a previous verification, you can see this report.
If you have closed the report after an import, to review the report again:

1 Select Window > Show/Hide View > Import Comments Report.

The Import Checks and Comments Report opens, highlighting differences in the two
results.

2 Review the differences between the two results.

+ If the check color changes, Polyspace populates the Comment field but not the
fields Severity, Status or Justified.

+ If a check no longer appears in the code, Polyspace highlights only the change in
the Import Checks and Comments Report. It does not import review comments
from the previous result.



Add Review Comments to Results

+ Ifyou have already entered different review comments for the same check,
Polyspace highlights only the change in the Import Checks and Comments
Report. It does not import review comments from the previous result.
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Add Review Comments to Code

This example shows how to place review comments in your code for a particular result.
If your code comments follow a particular syntax, in a later verification on the same
code, Polyspace can read the comments. Using the comments, Polyspace automatically
populates the Severity, Status and Comment fields on the Results Summary pane.
After you have placed your comments in your code, you or another reviewer can avoid
reviewing the same result twice.

In this section...

“Enter Code Comments in Specific Syntax” on page 8-36

“Copy Comment Syntax from Polyspace User Interface” on page 8-39

Enter Code Comments in Specific Syntax

You can manually enter comments in a specific syntax just before the line containing the
result.

To comment:

* An individual line of code, use the following syntax:

-— polyspace<Type: RunTimeErrori[,RunTimeError2[,..]] - [Severity] : [Status] >
[Additional text]

+ A section of code, use the following syntax:

-- polyspace:begin<Defect:Kind1[,Kind2] : [Severity] : [Status] >
[Additional text]

. Code section ...
-— polyspace:end<Type:Kind1[,Kind2] : [Severity] : [Status] >

The square brackets [ ] indicate optional information.

Replace Replace with

Type Runtime errors:
RTE
Global variables:
VARIABLE
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Replace

Replace with

Kind1,Kind2, . ..

Runtime errors:

Acronyms for checks such as ZDV, OVFL,
etc..

If you want the comment to apply to all
checks on the following line, specify ALL.

Global variables:

ALL. For global variables, the same
comment syntax applies irrespective of
whether they are shared or used.

Severity

Text that indicates the severity of the
defect. Enter one of the following:

* Unset
* High

* Medium
+ Low

* Not a defect

This text populates the Severity column
on the Results Summary pane.
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Replace Replace with

Status Text that indicates how you intend to
correct the error in your code. Enter one of
the following or any other text:

+ Fix

* Improve

+ Investigate

+ Justify with annotations

* No action planned

+ Restart with different options
+ Other

* Undecided

This text populates the Status column on
the Results Summary pane.

Additional text Any text. This text populates the
Comment column on the Results
Summary pane.

* “Syntax Example: Run-time Checks” on page 8-38
+ “Syntax Example: Global Variables” on page 8-38

Syntax Example: Run-time Checks
* Non-terminating call:

/* polyspace<RTE: NTC : Low : No Action Planned > Known issue */

* Division by zero:
/* polyspace<RTE: ZDV : High : Fix > Denominator cannot be zero */

Syntax Example: Global Variables

/* polyspace<VARIABLE: ALL : Low : Justify with annotations> Known issue */




Add Review Comments to Code

Copy Comment Syntax from Polyspace User Interface

Instead of manually entering the comment in a specific syntax, you can copy the
comment syntax from the Polyspace user interface and paste in your code.

1

On the Results Summary or Result Details pane, assign a Severity, Status and
Comment to a result.

a Select the result.

b Select options from the Severity and Status dropdown lists.

In the Comment field, enter a comment that helps you recognize the result
easily.

Copy the Severity, Status and Comment.

a On the Results Summary pane, right-click the result.

b Select Add Pre-Justification to Clipboard. The software copies the
justification string to the clipboard.

Paste the Severity, Status and Comment in your source code.
a On the Results Summary pane, right-click the result and select Open Editor.

Your source file opens on the Code Editor pane or an external text editor
depending on your Preferences. The current line is the line containing the
result.

b Using the paste option in the text editor, paste the justification template string
on the line immediately before the line containing the result.
You can see your Severity, Status and Comment as a code comment in a
format that Polyspace can read later.

¢ Save your source file.

Run the verification again. Open your results.

On the Results Summary pane, the software populates the Severity, Status and

Comment fields for the result. You can either ignore these findings, or filter them
from the Results Summary pane.
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This example shows how to filter and group results on the Results Summary pane. To
organize your result review, use filters and groups when you want to:

Review certain types of checks in preference to others. For instance, you first want to
address only the Non-terminating loop checks.

Review only new results found since the last verification.

Not review checks you have already justified.

Typically, in your second or later rounds of review, you would have some checks
already justified.

Review only those checks that you have already assigned a certain status. For
instance, you want to review only those checks to which you have assigned the status,
Investigate.

Review all checks in the body of a particular file or function. Because of continuity of
code, reviewing these checks together can help you organize your review process.

You can also review the checks in one file alone if you have written the code for that
file only and not the entire set of source files used for verification.

In this section...

“Filter Results” on page 8-40
“Group Results” on page 8-41

Filter Results

1

To review only new results found since the last verification, on the Results

— :
Summary pane, select .

For the other filters, select the “  icon on the desired column.

Item to Filter Column

Results in a certain file or function File or Function

Results with a certain severity or status |Severity or Status




Filter and Group Results

Item to Filter Column

Results that you have justified. If you Justified
assign the status No action planned
or Justify with annotations, a
result is justified.

Checks only Family
Checks of a certain color Family
Global variables of a certain type Family
Code metrics Family

3 Clear All. Select the boxes for the results that you want displayed.

Alternatively, clear the boxes for the results that you do not want displayed.

Note: You can also apply multiple filters. Once you apply a set of filters to your
verification results, they are preserved for subsequent verifications on the same project
module. The Results Summary pane shows the number of results filtered from display.
If you place your cursor on the number, you can see which filters have been applied.

Group Results

On the Results Summary pane, from the "= list, select an appropriate option.

To view ungrouped results , select None.
To view results grouped by result type, select Family.

The results are organized by type: checks, global variables, coding rule violations,
code metrics. Within each type, they are grouped further.

* The checks are grouped by color. Within each color, the checks are organized by
check group. For more information on the groups, see “Run-Time Checks”.

+ The global variables are grouped by their usage. For more information, see “Global
Variables”.

To show results grouped by file, select File.

Within each file, the results are grouped by procedures in the file.
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* To show results grouped by package, select Package.

Within each class, the results are grouped by method. The global variables are
grouped under _init_globals().
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Prioritize Check Review

This example shows how to organize your review of orange checks.
1  Before beginning your check review, do the following:

See the Code covered by verification graph on the Dashboard pane. See if
the Procedure and Code operation columns display a value closer to 100%.
Otherwise, identify why Polyspace could not cover the code.

For more information, see “Review Gray Checks” on page 8-25. If a substantial
number of functions or code operations were not covered, after identifying and
fixing the cause, run verification again.

+  See if you have used the right configuration. With the results open, select
Window > Show/Hide View > Configuration.

Sometimes, especially if you are switching between multiple configurations, you
can accidentally use the wrong configuration for the verification.

2 From the drop-down list in the middle of the Results Summary pane toolbar, select
Critical checks.

This action retains only red, gray and critical orange checks.

Click the forward arrow & to go to the first unreviewed check. Review this check.
For more information, see “Results Review Process”.

Continue to click the forward arrow until you have reviewed through all of the
checks.

4 Before reviewing orange checks, review red and gray checks.

5 To check that you have addressed the red and critical orange checks, rerun the
verification and view your results.

6 Ifyou do not have red or unjustified critical orange checks, from the drop-down list
in the middle of the Results Summary pane toolbar, select All results.

Depending on the quality level you want, you can choose whether to review the
noncritical orange checks or not. For more information, see “Do I Have Too Many
Orange Checks?” on page 9-9.

7 To see what percentage of checks you have justified:
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a If you want the percentage broken down by color and type, on the Results

Summary pane, from the = list, select Family. If you want the percentage
broken down by file and function, select File.

b  View the entries in the Justified column.
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Generate Report

This example shows how to generate a report from your verification results. Using

a customizable template, the report presents your results in a concise manner for
managerial review or other purposes. To generate a verification report, do one of the
following:

+ Specify certain options before verification so that the software automatically
generates a report.

* Generate a report from your verification results.

Specify Report Generation Before Verification

User Interface Command Line
1  Select your project configuration. Use the appropriate option with the
On the Configuration pane, select polyspace-ada command.
Reporting. Specify report generation
options. For more information, see For more information on the options, see
“Reporting”. the section Command-Line Information

2 Run verification and open your results. i e B

w

Select Reporting > Open Report Additionally, you can also specify a report
4 Navigate to the Polyspace-Doc name using the option “-report-output-

subfolder in your results folder. name’”,
You can see the generated report in
this subfolder. Click OK to open the
report.
Generate Report After Verification
User Interface Command Line
1 Open your verification results. Use the appropriate option with the
2 Select Reporting > Run Report. polyspace-report-generator
command.
The Run Report dialog box opens. . .
The available options are:
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User Interface

Command Line

3 In the Select Reports section, select
the report templates you want to
use. For example, you can select
Developer and Quality.

For more information, see “Report
template”.

4 Select an Output folder in which to
save the reports.

5 Select the Output format for the
reports.

6 Click Run Report.

The software creates the specified
reports and opens them.

-template path: Path to report
template file. For more information, see
“Report template”.

The predefined report templates

are in matlabroot\polyspace
\toolbox\psrptgen\templates
\Developer.rpt. Here, matlabroot
is the MATLAB" installation folder
such as C:\Program Files\MATLAB
\R2015a.

-format type: Output format of
report. The allowed types areHTML, PDF
and WORD.

-output-name filename: Name of
report.

-results-dir folder_paths: Path
to folder containing your verification
results.

To generate a single report for multiple
verifications, specify folder paths as
follows:

"folderl, folder2, ..., folderN"
where folderi, folder2,

are paths to the folders that contain
verification results. For example,

"C:\Recent\results,C:\0Id"

If you do not specify a folder path, the
software uses verification results from
the current folder.

Related Examples

. “Customize Report Templates” on page 8-47
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Customize Report Templates

This example shows how to customize the templates that you use for report generation.
To customize the templates, you must have MATLAB Report Generator™ software
installed on your system.

In this section...

“Create Custom Template” on page 8-47

“Apply Global Filters in Template” on page 8-47
“Override Global Filters” on page 8-49

“Use Custom Template” on page 8-50

Create Custom Template

If you have Simulink® Report Generator software on your system:

1

Open the Report Explorer from the MATLAB command prompt:

report
Select File > Open to open the template that you want to customize.

Navigate to Matlab_Install/polyspace/toolbox/psrptgen/templates
where Matlab _Install is the MATLAB installation folder. Use the matlabroot
command to find the folder location.

Modify the template using the options on the Report Options pane.

Save the modified template as a - rpt file.

Apply Global Filters in Template

1

In the Report Explorer, open the template that you want to customize. For instance,
Developer.rpt.

On the Name pane, under the Polyspace node, select Report Customization
(Filtering).

Drag this component above the Title Page component that is located under the
Report-Developer.rpt node.
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4 3 Report Generator
4 32 Report - Developer.rpt*
G Report Customization (Filtering)
H Title Page - Polyspace Code Verification
4 8 Chapter - Polyspace Code Verifi...
## Code Verification summary
i Report Customization (Filtering)
B Text - Developer Mam...
4 o if (PolyspaceData.RTEEnabled)
4 Chapter - Polyspace Proven
## Run-time Checks summary Ordered by

4 On the Report Customization (Filtering) pane in the right side of the Report
Explorer, specify your filters. For example:

To include Division by zero checks, under Advanced filters, in the Check
types to include field, enter ZDV.

To exclude Division by zero checks, under Advanced filters, in the Check
types to include field, enter the regular expression *(?1ZDV) . *.

To include the file main.c, under Advanced filters, in the Files to include
field, enter main.c.

To exclude the file main.c, under Advanced filters, in the Files to include
field, enter the regular expression ~(?!main.c).>.

In each text box, specify one filter per line.
For more information, see:

Check acronyms in “Run-Time Checks”

1n
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* “Regular Expressions”

Override Global Filters

You can override some of the global filters using the Run-time Check Details Ordered
by Color/File component. For example, you can have a report chapter that contains NIV
checks even though NIV checks are excluded by the global filters.

1 Select the Run-time Check Details Ordered by Color/File component.

?J Report Explorer - Report - Developer.rpt*

File

Edit View Tools Help
s ¥ &

X ¥ 44,

4 o Chapter - Custom Coding Rules R...
@ Coding Rules Summary
‘@ Coding Rules Details
4 i (PolyspaceData.JSFEnabled)
PR Chapter - JSF AV Coding Rules R...
@ Coding Rules Summary
‘@ Coding Rules Details
4 i (PolyspaceData.MISRAEnabled)
PR Chapter - MISRA-C Coding Rules ...
@ Coding Rules Summary
‘@ Coding Rules Details
4 i (PolyspaceData.MISRAAGCEnabled)
4 o Chapter - MISRA AC AGC Rules Re...
@ Coding Rules Summary
‘@ Coding Rules Details
4 i (PolyspaceData.MISRACPPEnabled)
4 4§ Chapter - MISRA-CPP Cading Rule...
@ Coding Rules Summary
‘@ Coding Rules Details
4 i (PolyspaceData.RTEEnabled)
4 o Chapter - Polyspace Run-Time Ch...

#@ Run-time Checks Details Ordered by Color/File

> @ Section 1- Appendix 1 - Configur...
4 4 Chapter - Appendix 2 - Definitions
@ Acronym Definitions

B OE e E e e [

HEEEE s s

~EE B E(

Name

- Formatting ----------—--

Array-Based Table
Chapter/Subsection
Image

Link

List

Paragraph

Text

Title Page

- Formatting Tables -----

Table

Table Body

Table Column Spec
Table Entry

Table Footer

Table Header
Table Row

- Handle Graphics ------

Axes Loop

Axes Snapshot
Figure Loop

Figure Snapshot
Graphics Object Loop

Handle Granhics linkine ~
»

-

1

[E=8 Bol =5

Run-time Checks Details Ordered by Color/File
| Override Global Report filter -
Organise Checks by

Display by: ‘F\Ie

1

Categories To Include
| Red Checks (Certain Errors)
| Grey Checks (Unreachable Code) | Unreachable Functions
| Orange Checks (Unproven)
Green Checks (Safe)

Inspection Point Checks (Informational Checks)

Advanced Filters

Justification status: ‘ All

For each filter give a list of regular expressions matching the content to include ir
report. Example to inlcude only ASRT and OBAI checks in the report in the check
enter:

ASRT

OBAI -

< [ 3

Help

2 On the right of the dialog box, select the Override Global Report filter check box.

Specify your filters for this component. For example, in the Check types to include

field, enter NIV.
4 Save the template.

For more information on the components available for customizing a report template, see

“Generate Report”.
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Use Custom Template

Open your results in the Polyspace interface.

Select Reporting > Run Report.

Click Browse.

Navigate to the location where you saved your template . rpt file.

Select the file and click OK. Under Select Reports, you see your template.

o 0 bW —

Select the template and click Run Report.
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Set Character Encoding Preferences

If the source files that you want to verify are created on an operating system that uses
different character encoding than your current system (for example, when viewing files
containing Japanese characters), you receive an error message when you view the source
file or run certain macros.

The Character encoding option allows you to view source files created on an operating
system that uses different character encoding than your current system.

To set the character encoding for a source file:

1 Select Tools > Preferences.

2 In the Polyspace Preferences dialog box, select the Character encoding tab.
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Y Polyspace Preferences |_ 2
Server Configuration | Project and Results Folder Editors |
Tools Menu Review Configuration | Review Statuses Miscellaneous | Character Encoding
Specifies the character encoding used by the operating system on which the source file was created.
This allows you to view source files created on an operating system that uses different character encoding than the current system.
Select the character encoding that you want to use.
Latin/Western European (I150) (I50-8859-1)
18-bits UCS Transformation Format, byte order identified by an optional byte-order mark (UTF-18) =
16-bits Unicode {or UCS) Transformation Format, little-endian byte order with byte-order mark (%-JTF-16LE-BOM) [
16-bits Unicode Transformation Format, big-endian byte order (UTF-16BE)
16-bits Unicode Transformation Format, litHe-endian byte order (UTF-16LE) | =
32-bits UCS Transformation Format, byte order identified by an optional byte-order mark (UTF-32) I
32-bits Unicode {or UCS) Transformation Format, big-endian byte order with byte-order mark (¥-UTF-32BE-BOM)
32-bits Unicode (or UCS) Transformation Format, little-endian byte order with byte-order mark (X-UTF-32LE-BOM) L
32-bits Unicode Transformation Format, big-endian byte order (UTF-32BE)
32-bits Unicode Transformation Format, litHe-endian byte order (UTF-32LE)
3-bits UCS Transformation Format (UTF-8)
American Standard Code for Information Interchange (US-ASCIT)
Arabic (IEM420)
Arabic (IBEM&64)
Arabic (Macintosh) (x-MacArabic)
Arabic (Windows) (windows-1258)
Arabic - Windows (-IBM1048)
Austria, Germany (IBEM273)
Baltic (IBM775)
Baltic {Windows) (windows-1257)
Canadian French (M5-DOS) (IBM&63)
Catalan,Spain, Spanish Latin America (IBM284)
Chinese (AIX) (x-IBM1333)
Chinese {AIX) (x-IBM334)
Chinese (AIX) (x-IBM3E4)
Chinese {(Hong Kong, Taiwan) (x-IEM350)
Chinese (05/2) (x-IBM1331)
Chinese (Simplified) (GBK)
Chinese (Simplified) Host mixed with 1880 UDC, superset of 5031 (x-IBM335)
Chinese (Simplified) PRC standard (GB18030)
Chinese (Simplified), GB2312 in IS0 2022 CH form (%-150-2022-CN-GB)
Chinese (Traditional) (Big5) -

[ Select current operating system character encoding: Western European (Windows) (windows-1252) ]

MNote: You must restart Polyspace to use the new character encoding settings.

l

QK

” Apply ” Cancel




Set Character Encoding Preferences

Select the character encoding used by the operating system on which the source file
was created.

Click OK.

Close and restart the Polyspace verification environment to use the new character
encoding settings.
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“What Is an Orange Check?” on page 9-2

“Sources of Orange Checks” on page 9-6

“Do I Have Too Many Orange Checks?” on page 9-9
“Limit Display of Orange Checks” on page 9-10
“Reduce Orange Checks” on page 9-13
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What Is an Orange Check?

Orange checks indicate unproven code, which means the software cannot prove that the
code:

* Produces a run-time error

* Does not produce a run-time error

Polyspace verification attempts to prove the absence or existence of run-time errors.
Therefore, the software considers all code unproven before a verification. During a
verification, the software attempts to prove that the code is:

*  Without run-time errors (green)
+ Certain to fail (red)
*  Unreachable (gray)

Code that is not assigned one of these categories (colors) stays unproven (orange).

Code often remains unproven in situations where some paths fail while others succeed.
For example, consider the following instruction:

X=1/7 X-Y);
Does a division-by-zero error occur?
The answer depends on the values of X and Y. However, there are an almost infinite

number of possible values. Creating test cases for all possible values is not practical.

X =Y (Division by zero error)

x-+—— Actual states of operation
X X/ (X-Y)
X X (nearly infinite)




What Is an Orange Check?

Because it is not possible to test every value for each variable, the target computer and
programming language provide limits on the possible values of the variables. Polyspace
verification uses these limits to compute a cloud of points (upper-bounded convex
polyhedron) that contains all possible states for the variables.

Y% Convex polyhedron
containing all possible
states of

X/ (X-Y)

X

Polyspace verification then compares the data set represented by this polyhedron to the
error zone. If the two data sets intersect, the check is orange.
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Intersection means

X =Y (Division by zero error)

Operation: X/ (X-Y)

X

Graphical Representation of an Orange Check

A true orange check represents a situation where some paths fail while others succeed.
However, because the data set in the verification is an approximation of actual values, an
orange check may actually represent a check of another color.

Yy
/

Red approximated by orange Gray approximated by orange



What Is an Orange Check?

o

-
o

Green approximated by orange Any other situation (true orange)

Polyspace reports an orange check when the two data sets intersect, regardless of the
actual values. Therefore, you may find orange checks that represent bugs, while other
orange checks represent code that does not have run-time errors.

You can resolve some of these orange checks by increasing the precision of your
verification, or by adding execution context, but often you must review the results to
determine the source of an orange check.
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Sources of Orange Checks

Orange checks can be separated into two categories:

In this section...

“Orange Checks from Code” on page 9-6

“Orange Checks from Verification Limitations” on page 9-7

Orange Checks from Code
Potential Bug

An orange check can reveal code which will fail under some circumstances. These types of
orange checks often represent real bugs.

For example, consider a function Recursion():

* Recursion() takes a parameter, increments it, then divides by it.
* This sequence of actions loops through an indirect recursive call to
Recursion_recurse().

If the initial value passed to Recursion() is negative, then the recursive loop will at
some point attempt a division by zero. Therefore, the division operation causes an orange
Division by Zero.

Data Set Issue
An orange check can result from a theoretical set of data that cannot actually occur.

Polyspace verification uses an upper approximation of the data set, meaning that it
considers many combinations of input data rather than a particular combination.
Therefore, an orange check may result from a combination of input values that is not
possible at execution time.

For example, consider three variables X, Y, and Z:

* Each of these variables is defined as being between 1 and 1,000.
* The code computes X*Y*Z on a 16-bit data type.

* The result can potentially overflow, so it causes an orange OVFL.



Sources of Orange Checks

When developing the code, you might know that the three variables cannot take the
value 1,000 at the same time, but this information is not available to the verification.
Therefore, the multiplication is orange.

When an orange check is caused by a data set issue, you can usually identify the cause
quickly. After identifying a data set issue, you might want to comment the code to flag
the warning, or modify the code to take the constraints into account.

Orange Checks from Verification Limitations
Inconclusive Verification

An orange check can be caused by situations in which the verification is unable to
conclude whether a problem exists.

In some code, it is impossible to conclude whether an error exists without additional
information.

For example, consider a variable X, and two concurrent tasks T1 and T2.

+  Xis initialized to O.

* T1 assigns the value 12 to X.

* T2 divides a local variable by X.

+ A division by zero error is possible because T1 can be started before or after T2, so the

division causes an orange ZDV.

Unless you define the call sequence, the verification cannot determine if an error will
occur.

Most inconclusive orange checks take some time to investigate. An inconclusive orange
check often results from complex code structure. Sometimes, such situations take an
hour or more to understand. Depending on the criticality of the function and the required
speed of execution, you may might want to rewrite the code to remove risk of failure.

Basic Imprecision

An orange check can be caused by imprecise approximation of the data set used for
verification.

For example, consider a variable X:
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+ Before the function call, X is defined as having the following values: -5, -3, 8, or a
value in the range [10...20]. O has been excluded from the set of possible values for

X.

+ However, due to optimization at low precision levels (-00), the verification
approximates X in the range [-5. . .20], instead of the previous set of values.

+ Therefore, calling the function X = 1/X causes an orange ZDV.
Polyspace verification is unable to prove the absence of a run-time error in this case.

In cases of basic imprecision, you might be able to resolve orange checks by increasing
the precision level. If increasing the precision level does not resolve the orange check,
verification cannot help directly. You must review the code to determine the problem.

For more information, see “Polyspace Software Assumptions”.



Do | Have Too Many Orange Checks?

Do | Have Too Many Orange Checks?

If the goal of code verification is to prove the absence of run-time errors, you might be
concerned by the number of orange checks in your results.

However, the presence of multiple orange checks need not be a cause for concern. The
minimum number that you want depends on several factors:

+ Development Stage — When verifying the first version of a software component,
focus exclusively on resolving red checks. As development progresses, start
considering the orange checks more and more.

+ Application Requirements — Sometimes, to write provable code, you can
compromise with properties such as code size, speed, and portability. Depending
on the requirements of your application, you might optimize one or more of these
properties at the expense of more orange checks.

Quality Goals — Using Polyspace software, you can meet your quality goals.
Therefore, before you verify code, you must define quality goals for your application.
These goals should be based on the criticality of the application, as well as time and
cost constraints. Based on your quality goals, you can choose to retain a specific
minimum number of orange checks in your application.

It is these factors that ultimately determine how many orange checks are acceptable in
your results, and what you must do with the orange checks that remain.
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This example shows how to control the number and type of orange checks displayed on
the Results Summary pane using the Show menu. To reduce your review effort, you
can do one of the following:

Display only the critical orange checks.

Use the option Show > Critical checks on the Results Summary pane.

Limit the number or suppress orange checks for certain check types, using additional
options on the Show menu.

You can create your own options. You can share the option files to help developers in
your organization review at least a certain number or percentage of orange checks.

Select Tools > Preferences.
On the Review Scope tab, select New. Save your option file.

On the left pane, select Run-time Check. On the right pane, to suppress a check
completely from display, clear the box next to the check. To suppress a check partly,
specify a percentage less than 100 to display.

To select all checks belonging to a category such as Numerical, select the box
next to the category name. For more information on the categories, see “Run-Time
Checks”. If only a fraction of checks in a category are selected, the check box next to

the category name displays a [ symbol.

Instead of a percentage, you can specify a number or the string ALL. To specify a
number, clear the box Specify percentage of checks.



Limit Display of Orange Checks

.
"Y' Polyspace Preferences [ = ]
Server Configuration | Project and Results Folder I Editors | I
Tools Manu Review Statuses | Miscellaneous Character Encoding | Review Scope
Manage Show menu on Results Summary
Scope Name iMy_Smpe - [ MNew ] [ Remove ] [ Open ] [ Save as ]
E-Ru Run-time Check
" Your scope controls the orange checks displayed in Results Summary
specify percentage of checks =
-Global Variable {Unset)
[} Code Metric (Unset) Status Cap Name
=N Murnerical -
100%: Positive power value
100%; Division by Zera
60% Scalar overflow
100% Float overflow
Data flow
100% Nen-nitialized variable
100% Nen-nitialized local variable L&
=
100% User assertion
100% Correctness condition
100% Arithmetic exceptions
[ ) [ ] [t

L

Select Apply or OK.

On the Results Summary pane, the Show menu displays the additional options.

Select the option corresponding to the limits that you want. Only the number or
percentage of orange checks that you specify remain on the Results Summary

pane.

+ If you specify an absolute number, Polyspace displays that number of orange

checks.

+ If you specify a percentage, Polyspace displays green and justified orange checks
until they make up the percentage. If they do not make up the percentage, the
software then displays unjustified orange checks.
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You can use a review scope with percentage specifications to ensure that you
justify at least a certain percentage of checks.
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Reduce Orange Checks

An orange check indicates that Polyspace detects a possible run-time error but cannot
prove it. To help Polyspace produce more proven results, you can:

*  Follow good coding practices.

+  Specify the necessary verification options.

You can also limit the number and family of orange checks displayed on Results
Summary. For more information, see “Limit Display of Orange Checks” on page 9-10.

In this section...

“Improve Verification Precision” on page 9-13
“Apply Coding Guidelines” on page 9-14
“Stub Parts of the Code Manually” on page 9-14

“Specify Multitasking Behavior” on page 9-19

Improve Verification Precision

Improving the precision of a verification can reduce the number of orange checks in your
results.

There are a number of Polyspace options that can improve the precision of the
verification. The compromise for this improved precision is increased verification time.

The following sections describe how to improve the precision of your verification:

+  “Set the Analysis Precision Level” on page 9-13
+ “Set Software Safety Analysis Level” on page 9-14

Set the Analysis Precision Level

The precision level specifies the mathematical algorithm used to compute the cloud of
points (polyhedron) containing many possible states for the variables. Changing the
precision level does not improve the quality of your code. However, orange checks caused
by low precision can become green when verified with higher precision. The default
precision level is 2. To set the precision level:
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1 In the Polyspace user interface, on the Configuration pane, select Precision.

2 From the Precision Level drop-down list, select O, 1, 2, or 3.

For more information, see “Precision level”.
Set Software Safety Analysis Level

The verification level specifies how many times the abstract interpretation algorithm
passes through your code. Each pass results in a deeper level of propagation of calling
and called context. The deeper the verification goes, the more precise it is. By default,
verification proceeds to Software Safety Analysis Level 4. To set the verification
level:

1 In the Polyspace user interface, on the Configuration pane, select Precision.

2 From the Verification level drop-down list, select the level that you want.

For more information, see “Verification level”.

Apply Coding Guidelines
The number of orange checks per file depends on the coding style used in the project.

The following coding guidelines improve Polyspace precision and selectivity in Ada code
verification:

* Use constrained types. Use subtype and not standard type.

* Do not use "use at" clause.

+  Minimize the use of big and complex types (record of record, array of record, etc.).

*  Minimize the use of volatile variables.

*  Minimize the use of assembler code.

* Do not mix assembly code and Ada. Gather assembly code in a procedure or function
which can be automatically stubbed.

Stub Parts of the Code Manually

Manually stubbing parts of your code can reduce the number of orange checks in your
results. Manual stubbing does not improve the quality of your code, but only changes the
results.



Reduce Orange Checks

Stubs do not need to model the details of the functions or procedures involved. They only
need to represent how the code interacts with the remainder of the system.

If a function is supposed to return an integer, the default automatic stubbing will stub it
on the assumption that it can take a value from the full range of an integer.

The following sections describe how to reduce orange checks using manual stubbing:

+ “Manual vs. Automatic Stubbing” on page 9-15

+  “Emulating Function Behavior with Manual Stubs” on page 9-16
* “Reducing Orange Checks with Empty Stubs” on page 9-17

* “Applying Constraints to Variables Using Stubs” on page 9-18

Manual vs. Automatic Stubbing
There are two types of stubs in Polyspace verification:

+ Automatic stubs — The software automatically creates stubs for unknown functions
based on the function prototype (the function declaration). Automatic stubs do not
provide insight into the behavior of the function, but are very conservative, ensuring
that the function does not cause a run-time error.

* Manual stubs — You create these stub functions to emulate the behavior of the
missing functions, and manually include them in the verification with the rest of
the source code. Manual stubs can better emulate missing functions, or they can be
empty.

By default, Polyspace software automatically stubs functions. However, because
automatic stubs are conservative, they can lead to more orange checks in your results.

Stubbing Example

procedure a_missing_function
(dest: in out integer,

src : in integer);

procedure test is

a: integer;

b: integer;

begin

a: = 1;
b: = 0;
a_missing_function(a,b);
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b:= 1/a;
end;

Due to automatic stubbing, the verification assumes that a can be have take a value from
the full range of integers, including 0. This assumption produces an orange check on the
division.

If you provide an empty manual stub for the function, the division is green. This action
reduces the number of orange checks in the result, but does not improve the quality of
the code itself. The function could still potentially cause an error.

You can also provide a detailed manual stub that emulates the behavior of the function.
Emulating Function Behavior with Manual Stubs

You can improve both the speed and selectivity of your verification by providing manual
stubs that emulate the behavior of missing functions. The trade-off is time spent writing
the stubs.

Manual stubs do not need to model the details of the functions or procedures involved.
They only need to represent how the code interacts with the remainder of the system.

Example

This example shows a header for a missing function (which may occur when the verified
code is an incomplete subset of a project).

procedure a_missing_function
(dest: in out integer,
src : in integer);

Applying fine-level modeling of constraints in primitives and outside functions at the
application periphery propagates more precision throughout the application, which
results in a higher selectivity rate (more proven colors, i.e. more red+ green + gray). For
this function, you could add a simple body:

procedure a_missing_function
(dest: in out integer,
src : in integer)

begin
dest := src;

end;
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In this case, instead of considering the full range for the dest parameter, Polyspace
considers the relation between input parameter src and the output parameter,
propagating more precision throughout the application.

Reducing Orange Checks with Empty Stubs

Providing empty manual stubs can reduce the number of orange checks in your results.

For example, consider the following code:

package automatic_vs_manual_stub is
procedure write_or_notl(x : in out Integer);
procedure write_or_not2(x : in out Integer);
procedure green;
procedure orange;

end;

package body automatic_vs_manual_stub is
procedure write_or_not2(x : in out Integer) is
begin

null;
end;

procedure orange is
X I Integer;
y I Integer;

begin

X = 12;

y = 1;

write_or_notl(x);

y = y/X; -- Orange ZDV due to automatic stub
end;

procedure green is
X I Integer;
y I Integer;
begin

N

rite_or_not2(x);
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y = y/X; -- Green due to empty stub
end;

end;

The code for the two functions is identical, but the automatic stub produces an orange
check, while the empty stub produces a green.

While the empty stub reduces the number of orange checks in your results, you must
take additional steps to ensure that the actual function does not result in a run-time
error.

Applying Constraints to Variables Using Stubs

Another way to increase the selectivity is to indicate to the Polyspace software that
some variables may lie within smaller functional ranges instead of the full range of the
considered type.

This smaller function range primarily concerns two items from the language:

*  Parameters passed to functions.

+ Variables' content, mostly globals, which might change from one execution to another.
Typically, these might include things like calibration data or mission specific data.
These variables might be read directly within the code, or read through an API of
functions.

Reduce the cloud of points

If a function is supposed to return an integer, the default automatic stubbing stubs it on
the assumption that it can potentially take a value from the full range of an integer.

Polyspace models data ranges throughout the code it verifies. It produces more precise,
informative results provided that the data it considers from the “outside world” is
representative of the data that can be expected when the code is implemented. There is
a certain number of mechanisms available to model such a data range within the code
itself, and there are three possible approaches.

with volatile and assert with assert and without without assert, without

volatile volatile, without "if"
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function stub return INTEGER is
tmp: INTEGER;

random: INTEGER;

pragma volatile (random);

begin

tmp:= random;

pragma assert (tmp>=1);

pragma assert (tmp<=10);

return tmp;

end;

function random return INTEGER;
pragma Interface (C, random);
function stub return INTEGER is
tmp: INTEGER;

begin

tmp:= random;

pragma assert (tmp>=1);

pragma assert (tmp<=10);

return tmp;

end;

function random return INTEGER;
pragma Interface (C, random);
function stub return INTEGER is
tmp: INTEGER;

begin

tmp:= random;

while (tmp<1l or tmp>10)

loop

tmp:=random;

end loop;

return tmp;

end;

The three approaches are equivalent (except, perhaps, that the assertions in the first two
usually generate orange checks).

Specify Multitasking Behavior

The asynchronous characteristics of your application can have a direct impact on the
number of orange checks. Properly describing characteristics such as implicit task
declarations, mutual exclusion, and critical sections can reduce the number of orange

checks in your results.

For example, consider a variable X, and two concurrent tasks T1 and T2.

* Xis initialized to O.

* T1 assigns the value T2 to X.

* T2 divides a local variable by X.

+ A division by zero error is possible because T1 can be started before or after T2, so the

division causes an orange Division by Zero error.

The verification cannot determine if an error will occur without knowing the call
sequence. Modeling the task differently could turn this orange check green or red.

For more information, see “Modelling Synchronous Tasks” on page 5-9.
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Polyspace Metrics is a Web-based tool for software development managers, quality
assurance engineers, and software developers, to do the following in software projects:

+ Evaluate software quality metrics

*  Monitor the variation of code metrics and run-time checks through the lifecycle of a
project

+  View defect numbers, run-time reliability of the software, review progress, and the
status of the code with respect to software quality objectives.

If you are a development manager or a quality assurance engineer, through a Web
browser, you can:

+  View software quality information about your project. See “View Polyspace Metrics
Project Index” on page 10-9.

* Observe trends over time, by project or module. See “Review Overall Progress” on
page 10-17.

*  Compare metrics of one project version with those of another. See “Compare Project
Versions” on page 10-24.

If you have the Polyspace product installed on your computer, you can drill down to run-
time checks in the Polyspace verification environment. This feature allows you to review
run-time checks and, if required, classify these checks as defects. In addition, if you think
that run-time checks can be justified, you can mark them as justified and enter relevant
comments. See “Review Run-Time Checks” on page 10-26.

If you are a software developer, Polyspace Metrics allows you to focus on the latest
version of the project that you are working on. You can use the view filters and drill-
down functionality to go to code defects, which you can then fix. See “Fix Defects” on page
10-29.

Polyspace calculates metrics that are used to determine whether your code fulfills
predefined software quality objectives. You can redefine these software quality objectives.
See “Customizing Software Quality Objectives” on page 10-31.
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Setting Up Verification to Generate Metrics

You can run, either manually or automatically, verifications that generate metrics. In
each case, the Polyspace product uses a metrics computation engine to evaluate metrics
for your code, and stores these metrics in a results repository.

Before you run a verification manually, in the Polyspace user interface:

1 On the Configuration pane, select Machine Configuration.
2 Select the Send to Polyspace Server check box.
3 Select the Add to results repository check box.

To set up scheduled, automatic verification runs, see “Specifying Automatic Verification”
on page 10-3.

The software saves generated metrics in the following XML file:

Results_Folder/Polyspace-Doc/Code_Metrics.xml

Specifying Automatic Verification

You can configure verifications to start automatically and periodically, for example, at
a specific time every night. At the end of each verification, the software stores results in
the repository and updates the project metrics. You can also configure the software to
send you an email at the end of the verification. This email will contain:

* Links to results
* An attached log file if the verification produces compilation errors

* A summary of new findings, for example, new potential and actual run-time errors

To configure automatic verification, you must create an XML file Projects.psproj
that has the following elements:

<?xml version="1.0" encoding="UTF-8" ?>
<I-- Polyspace Metrics Automatic Verification Project File -->
<Configuration>
<Project>
<Options>
</Options>
<LaunchingPeriod>
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</LaunchingPeriod>
<Commands>
</Commands>
<Users>
<User>
</User>
</Users>
</Project>
<SmtpConfiguration>
</SmtpConfiguration>
</Configuration>

Configure the verification by providing data for the elements (and their attributes)
within Configuration. See “Element and Attribute Data for Projects.psproj” on page
10-4.

After creating Projects.psproj, place the file in the following folder on the Polyspace
Queue Manager server:

/var/Polyspace/results-repository

Note: If the flag process_automation in your configuration file polyspace .conf
is set to yes, then, when you start your Polyspace Queue Manager server, Polyspace
generates two template files in the results repository folder:

* ProcessAutomationWindowsTemplate.psproj for Windows

* ProcessAutomationLinuxTemplate.psproj for Linux
Use the relevant template to create your Projects.psproj file.

For more information about the configuration file polyspace.conT, see “Manual
Configuration of the Polyspace Server”.

Element and Atiribute Data for Projects.psproj

Project
Specify three attributes:

* name — Your project name.
+ language — ADA or ADA95.

10-4



Setting Up Verification to Generate Metrics

+ verificationKind — Mode, which is either INTEGRATION or UNIT-BY-UNIT.

For example,

<Project name="Demo_Ada" language="Ada" verificationKind=""INTEGRATION">
The Project element also contains the following elements:

+ “Options” on page 10-5
+  “LaunchingPeriod” on page 10-5
* “Commands” on page 10-6

+ “Users” on page 10-7
Options

Specify a list of Polyspace options required for your verification, with the exception of —
unit-by-unit, —results-dir, —prog and —verif-version. If these four options are
present, they are ignored.

The following is an example.

<Options>
-02
-to pass2
-target sparc
-temporal-exclusions-file sources/temporal_exclusions.txt
-entry-points tregulate,procl,proc2,serverl,server2
-critical-section-begin Begin_CS:CS1
-critical-section-end End_CS:CS1

</Options>

LaunchingPeriod
For the starting time of the verification, specify five attributes:

* hour. Integer in the range 0—23.

* minute. Integer in the range 0-59.

* month. Integer in the range 1-12.

+ day. Integer in the range 1-31.

+ weekDay. Integer in the range 1-7, where 1 specifies Monday.

Use * to specify all values in range, for example, month=""*"" specifies a verification every
month.
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Use - to specify a range, for example, weekDay=""1-5"" specifies Monday to Friday.

You can also specify a list for each attribute. For example, day=""1,15" specifies the first
and the fifteenth day of the month.

Default: If you do not specify attribute data for LaunchingPeriod, then a verification is
started each week day at midnight.

The following is an example.
<LaunchingPeriod hour="12" minute="20" month="*" weekDay="1-5">

Commands

You can provide a list of optional commands. There must be only one command per line,
and these commands must be executable on the computer that starts the verification.

+ GetSource. A command to retrieve source files from the configuration management
system, or the file system of the user. Executed in a temporary folder on the client
computer, which is also used to store results from the compilation phase of the
verification. This temporary folder is removed after the verification is spooled to the
Polyspace server.

For example:

<GetSource>
cvs co —-r 1.4.6.4 myProject
mkdir sources
cp —fvr myProject/*.adb sources
</GetSource>

You can also use:

<GetSource>
find /.../myProject —name “*_adb” | tee sources list.txt
</GetSource>

and add -sources-list-file sources_list.txt tothe options list.

+ GetVersion. A command to retrieve the version identifier of your project. Polyspace
uses the version identifier as a parameter for -verif-version.

For example:

<GetVersion>
cd /..../myProject ; cvs status Makefile 2>/dev/null | grep "Sticky Tag:*
| sed "s/Sticky Tag://" | awk “{print $1"-"$3}"| sed "s/).*$//"
</GetVersion>
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Users

A list of users, where each user is defined using the element “User” on page 10-7.

User
Define a user using three elements:

*  FirstName. First name of user.
+ LastName. Last name of user.

+ Mail. Use the attributes resultsMail and compilationFailureMail to specify

conditions for sending an email at the end of verification. Specify the email address in
the element.

+ resultsMail. You can use one of the following values:
+  ALWAYS. Default. Email sent at the end of each automatic verification (even if

the verification does not produce new run-time checks).

+ NEW-CERTAIN-FINDINGS. Email sent only if verification produces new red,
gray, NTC, or NTL checks.

* NEW-POTENTIAL-FINDINGS. Email sent only if verification produces new
orange check.

*  ALL-NEW-FINDINGS. Email sent if verification produces a new run-time check.
compi lationFailureMail. Either Yes (default) or No. If Yes, email sent when
automatic verification fails because of a compilation failure.

The following is an example of Mai l.

<Mail resultsMail="NEW-POTENTIAL-FINDINGS"

compi lationFailureMail="yes">

user_id@yourcompany .com
</Mail>

SmtpConfiguration

This element is mandatory for sending email, and you must specify the following
attributes:

+ server. Your Simple Mail Transport Protocol (SMTP) server.
+ port. SMTP server port. Optional, default is 25.

For example:
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<SmtpConfiguration server="smtp.yourcompany.com'" port="25">
Example of Projects.psproj

The following is an example of Projects.psproj:

<?xml version="1.0" encoding="UTF-8" ?>
<I-- Polyspace Metrics Automatic Verification Project File -->
<Configuration>
<Project name="Demo_Ada" language="ADA" verificationKind=""INTEGRATION">
<Options>
-02
-to pass2
-target sparc
-temporal-exclusions-file sources/temporal_exclusions.txt
-entry-points tregulate,procl,proc2,serverl,server2
-critical-section-begin Begin_CS:CS1
-critical-section-end End_CS:CS1
</Options>
<LaunchingPeriod hour="12" minute="20" month="*" weekDay="'1-5">
</LaunchingPeriod>
<Commands>
<GetSource>

/bin/cp -vr /yourcompany/home/auser/tempfolder/Demo_Ada_Studio/sources/ .

</GetSource>
<GetVersion>
</GetVersion>
</Commands>
<Users>
<User>
<FirstName>Polyspace</FirstName>
<LastName>User</LastName>
<Mail resultsMail="ALWAYS"
compi lationFai lureMai l="yes">userid@yourcompany .com
</Mail>
</User>
</Users>
</Project>
<SmtpConfiguration server="smtp.yourcompany.com'" port="25">
</SmtpConfiguration>
</Configuration>
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View Polyspace Metrics Project Index

1 In the address bar of your Web browser, enter the following URL:
protocol:// ServerName: PortNumber
+ protocol is either http (default) or https.

+ ServerName is the name or IP address of the server that is your Polyspace Queue
Manager.

* PortNumber is the Web server port number (default 8080)

To use HTTPS, you must set up the configuration file and the Metrics

configuration preferences. For more information, see “Configure Web Server for
HTTPS”.

2 Select the Projects tab.

You can save the project index page as a bookmark for future use. You can also save as
bookmarks Polyspace Metrics pages that you subsequently navigate to.

Refresh

To refresh the page, click

At the top of each column, use the filters to shorten the list of displayed projects. For
example:

* In the Project filter, if you enter demo_, the browser displays a list of projects with
names that begin with demo_.

*  From the drop-down list for the Language filter, if you select Ada, the browser
displays only Ada projects.

If a new verification has been carried out for a project since your last visit to the project

index page, then the icon B appears before the name of the project.

If you place your cursor anywhere on a project row, in a box on the left of the window, you
see the following project information:

+ Language — For example, Ada, C, C++.
* Mode — Either Integrationor Unit by Unit.

+ Last Run Name — Identifier for last verification performed.
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* Number of Runs — Number of verifications performed in project.

In a project row, click anywhere to go to the Summary view for that project.
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Organize Polyspace Metrics Projects

The Polyspace Metrics project index allows you to display projects as categories, a useful
feature when you have a large number of projects to manage. You can:

Create multiple-level project categories.
Move projects between categories by dragging and dropping projects.

Rename and remove categories. When you remove a category, the software does not
delete the projects within the category but moves the projects back to the parent or
root level.

To create a root-level project category:

On the Polyspace Metrics project index, right-click a project.

From the context menu, select Create Project Category. The Add To Category
dialog box opens.

In Enter the name of the project category field, enter the required name, for
example, MyNewCategory. Then click OK.

To add projects to this new category, drag and drop the required projects into this
category.

To create a subroot-level category:

Right-click a project category.

From the context menu, select Create Project Category. The Add To Category
dialog box opens.

In Enter the name of the project category field, enter the required name, for
example, SubCategoryl. If you decide that you do not want a subroot category, but
want a new root category instead, select the Create a root project category check
box. Then click OK.

To add projects to this new category, drag and drop the required projects into this
category.

To rename a project category:

1

Right-click the project category.

2 From the context menu, select Rename Project Category. The category name

becomes editable.
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3 Enter the new name for your category. Press Return.
4 A message dialog box opens requesting confirmation. Click OK. The software
updates the category name.

To remove a project category:

1 Right-click the project category.
2 From the context menu, select Delete Project Category. If the project category is
a:
*  Root-level project category, the software moves all projects in the category to the
root level and removes the project category and associated subroot categories.

Subroot-level category, the software moves all projects within the subroot
category to the parent level and removes the subroot category.

Note: The software does not delete projects when removing project categories.

You can move projects back to the root level from project categories without removing the
project categories:

1 From within project categories, select the projects that you want to move to the root
level.

2 Right-click the selected projects. From the context menu, select Move to Root. The
software moves the projects back to the root level.
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Protect Access to Project Metrics

You can restrict access to the metrics for a project by specifying a password:

When you run a verification with Polyspace Metrics enabled or upload results to
Polyspace Metrics:

1 The Authentication Required dialog box opens.

Authentication Required @I

If you want protect access to the project results, specify a password.

Otherwise leave the fields blank.

Project password: |

Confirm password:

OK Cancel

2 In the Project password and Confirm password fields, enter your password.
3 Click OK.

+ After the creation of a project:

1 From the Polyspace Metrics project index, right-click the project.

2 From the context menu, select Change/Set Password. The Change Project
Password dialog box opens.

Change Project Password X

Enter the password for the project:

Mew password:

Confirm new password:

OK Cancel

3 Inthe New password and Confirm new password fields, enter your
password.

Click OK. The software displays the password-restricted icon = next to the
project.

From the command line, you can use the -password option. For example:

polyspace-results-repository.exe -prog psdemo_model_link sl -password my_passwd
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Note: The password for a Polyspace Metrics project is encrypted. The Web data transfer
is not encrypted. The password feature minimizes unintentional data corruption, but it
does not provide data security. However, data transfers between the Polyspace Client
and Polyspace Server are encrypted. To use a secure Web data transfer with HTTPS, see
“Configure Web Server for HTTPS”.

After you enter your password, the project pages are accessible for a session that lasts 30
minutes. Access is available for this period of time, even if you close your Web browser.
If you return to the Polyspace Metrics project index, the session ends. If you click =
during a session, the project pages are accessible for another 30 minutes.
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Monitor Verification Progress

In the Summary > Verification Status column, Polyspace Metrics provides status
information for each verification in the project. The status can be queued, running, or
completed.

If the verification mode is Unit By Unit, the software provides status information in
each unit row. If the verification mode is Integration, the software provides status
information in the parent row only.

If the verification status is running (and you have installed the Polyspace product on
your computer), you can monitor progress of the verification with the Polyspace Job
Monitor.

To open the Progress Monitor of the Polyspace Job Monitor:

1

In the Summary > Verification Status column, right-click the parent or unit cell

with the status running.

Code Metrics Run-Time Errors
Verificat Verification
=L Status Files Lines of |Confirmed Run-Time Green Red
Code Defects | Selectivity
1.0(8) queued (ID=39)
4 1.0 (7) queued (ID=38)
5 10(6) running (ID=131
&7 1.0 () completed (P4 [ FelowProgress... 83.8% 176 3
completed (P4 Rename Run 83.8% 176 3
completed (P4 Delete Run from Repository B3.8% 176 3

From the context menu, select Follow Progress.

Orange

40
40
40

Gi

19
19
19

ay

Review
Progress

0.0%
0.0%
0.0%

The Output Summary tab opens in the Polyspace verification environment.
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Polyspace Metrics supports the following Web browsers:

Internet Explorer® 7.0, or later
Firefox® version 3.6, or later

Google® Chrome version 12.0, or later
To use Polyspace Metrics, you must install on your computer Java, version 1.4 or later.

For the Firefox Web browser, you must manually install the required Java plug-in. For
example, if your computer uses the Linux operating system:
1 Create a Firefox folder for plug-ins:
mkdir ~/.mozilla/plugins
2  Go to this folder:
cd ~/.mozilla/plugins

3 Create a symbolic link to the Java plug-in, which is available in the Java Runtime
Environment folder of your Polyspace installation:

In -s Polyspace _Install/jre/lib/amd64/1ibnpjp2.so
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Review Overall Progress

For a development manager or quality assurance engineer, the Polyspace Metrics
Summary view provides useful high-level information, including quality trends, over the
course of a project.

To obtain the Summary view for a project:

1 Open the Polyspace Metrics project index. See “View Polyspace Metrics Project
Index” on page 10-9.

2 Click anywhere in the row that contains your project. You see the Summary view.

<= Back to Project Selection PS_AV-GNAT (Unit By Unit)

Polyspace® Metrics

From | CC-R2011bMain-S9 (1) v | 7o [CC-R20116Main-510 (2) | [] Compare [] New Findings Only c

Refresh

Quality Objectives |OFF v | Display Mode |Rewew.uuslmcalmn Progress (%) v ‘

Summary Code Metrics Run-Time Checks

Files Lines of Code Run-Time Defects Run-Time Selectivity (%)

250 150480 3 91
Legend
150480 2 W High
280 | e——— n mgmum 90 1: CC-R2011bMain-53 (1)
150440 1 i 2: CC-R2011bMain-S9 (2)
3: CC-R2011bMain-S10 (1)
4: CC-R2011bMain-S10 (2)
288 150420 0 88
1 2 2 4 12 3 4 1 2 3 4 1 2 2 4
L Codz Mefrics Run-Time Errors
N Review
Verification Werification Status. -
. . Confirmed | Run-Time - S Cre Progress
Files Lines of Code| "ot | ooty | 576" Red Orange Gray
[+ CC-R2011bMain-S8 (1) failed (—) 289 150433 4 50.7% 75665 287 7810 317 05%
[#-<] CC-R2011bMain-58 (2) failed (—) 280 150456 4 90.7% 76TV 287 7810 317 05%
[#]-“] CC-R2011bMain-510 (1} failed (—) 280 150456 T 90.7% 76TV 287 7810 317 1.0%
[¥ “) CC-R2011bMain-510 (2} failed (—) 289 150473 T 89.2% 73537 217 9126 1272 07%

At the top of the Summary view, use the From and To filters to specify the project
versions that you want to examine. By default, the From and To fields specify the
earliest and latest project versions respectively.

In addition, by default, the Quality Objectives filter is OFF, and the Display Mode is
Review/Justification Progress (%).

Below the filters, you see:

+ Plots that reveal how the number of verified files, lines of code, defects, and run-time
selectivity vary over the different versions of your project
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+ A table containing summary information about your project versions

If you have projects with two or more file modules in the Polyspace verification
environment, by default, Polyspace Metrics displays verification results using the
same module structure. However, Polyspace Metrics also allows you to create or
delete file modules. See “Creating File Module and Specifying Quality Level” on page
10-22.

With the default filter settings, you can monitor progress in terms of run-time checks
that quality assurance engineers or developers have reviewed.

You can also monitor progress in terms of software quality objectives. You may, for
example, want to find out whether the latest version fulfills quality objectives.

To display software quality information, from the Quality Objectives drop-down list,
select ON .

Under Software Quality Objectives, look at Review Progress for the latest version
(CC-R2011bMain-S10 (2)), which, in this example, indicates that the review of
verification results is incomplete (3.4 % reviewed). You also see that the Overall Status is
FAIL. This status indicates that, although the review is incomplete, the project code fails
to meet software quality objectives for the quality level MW-Q0-3. With this information,
you may conclude that you cannot release version CC-R2011bMain-S10 (2) to your
customers.

A Code Metrics Run-Time Errors Software Qualty Objectives.

Verification
Status. - - Confirmed | Run-Time Overall Review | Justified Run-
Files. |Lines of Code Defects Reliability Status e Progress. Time Errors

Verification

% CC-R2011bMain-510 (2) | failed (—) = 289 150473 7 875% FAILL () MW-QO-3 34% A 3.1% A&
When Polyspace Metrics adds the results for a new project version to the repository,
Polyspace Metrics also imports comments from the previous version. For this reason, you
rarely see the review progress metric at 0% after verification of the first project version.

Note: You may want to find out whether your code fulfills software quality objectives at
another quality level, for example, MW-Q0-1. Under Software Quality Objectives, in
the Level cell, select MW-Q0-1 from the drop-down list.

There are seven quality levels, which are based on predefined software quality objectives.
You can customize these software quality objectives and modify the way quality is
evaluated. See “Customizing Software Quality Objectives” on page 10-31.




Review Overall Progress

To investigate further, under Run-Time Errors, in the Run-Time Reliability cell, you
click the link 87 .6%. This action takes you to the Run-Time Checks view, where you
see an expanded view of check information for each file in the project.

Systematic Run-Time

S C;gff;r;:d F;:r‘\‘;';r‘r';; Green Code| Errors (Red Checks) Non-terminating Constructs, Software Quality Objectives
Checks | Justified | Checks Justified | Checks g:’:&g Level P'?s;’::‘s
[=) -} CC-R2011bMain-510 (2) 7 B87.6% 73537 94.4% 4 72 0.0% L 1272 00% L 9126 00% 4. 205 FAL £ WW-Q0-3 34% 4
B M xref_tab 46.0% 523 100.0% 1 0.0% 5 100.0% 11 FAIL MW-Q0-3 16.7%
+ 1 xref 60.3% 450 100.0% 1 100.0% 287 PASS MW-Q0-3 100.0%
+]- 1] widechar 854% 216 100.0% a7 PASS MW-Q0-3 100.0%
+- 1 usage 75.0% 3 100.0% 1 PASS MW-00-3 100.0%
+- 1 urealp 76.6% 669 0.0% 1 0.0% 203 FAIL MW-00-3 0.0%
(- 1 uname: 81.5% 285 100.0% K3 0.0% 65 FAIL MW-00-3 40.0%
- 1] vintp 83.3% 1520 100.0% K3 0.0% 18 0.0% 287 FAIL MW-00-3 T.7%
- Htypes 98.2% 55 100.0% 1 PASS MW-Q0-3 100.0%
+- 1] treepr 89.9% S87 100.0% 3 0.0% g 0.0% 58 FAIL MW-Q0-3 25.0%
+| Htree_io 84.8% 189 100.0% 34 PASS MW-00-3 100.0%
+- [ tree_gen 100.0% 2 PASS MW-00-3 100.0%
- 1 thuild 81.5% 154 0.0% 35 FAIL MW-00-3 0.0%

To view a check in the Polyspace verification environment, in the relevant cell, click
the numeric value for the check. The Polyspace verification environment opens in the
Polyspace user interface displaying verification information for this check.

Note: If you update a check information through the Polyspace verification environment
(see “Review Run-Time Checks” on page 10-26), when you return to Polyspace
Metrics, click Refresh to incorporate this updated information.

If you want to view check information with reference to check type, from the Group by
drop-down list, select Run-Time Categories.
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=
Verification o] ot
Defects Reliability
£ 5 CC-R2011bMain-510 (2) 7 87.6%
ZDV (Scalar) - Division by Zero 86.7%
[} ZDV (Float} - Division by Zero
[+ UOVFL (Scalar)
[#- UOVFL (Float)
[#]-UNR - Unreachable Code 0.0%
UNFL (Scalar)
UNFL {Float)
[#-STD_LIB - Argument of standard
[#]- SHF - Shift amount is outside its
[+ POW - Power must be positive
[+ OVFL (Scalar) - Overflow 1 61.2%
[#]- OVFL (Fioat) - Overfiow 50.0%

Systematic Run-Time

Unreachable Branches

Other Run-Time Errors

Green Code Errors (Red Checks} (Gray Checks) {Orange Checks) Non-terminating Constructs. Software Quality Objectives
Checks | Justiied | Checks | Justified | Checks | Justfied | Checks | Justfied | Checks | QU3 | eug Review
Status Progress
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Displaying Metrics for Single Project Version

Displaying Metrics for Single Project Version

To display metrics for a single project version:

1
2
3

In the From field, from the drop-down list, select the required project version.
In the To field, from the drop-down list, select the same project version.
In # items field, enter the maximum number of files for which you want information
displayed.
The software displays:
Bar charts with file defect information, ordering the files according to the number
of defects in each file

A table with information about the selected project version
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Creating File Module and Specifying Quality Level

You can group files into a module and specify a quality level for the module. The quality
level applies to all files within the module. By grouping your files in different modules,
you can specify different quality levels for your files.

To create a module of files:

Select a tab, for example, Summary.

2 Inthe Verification column, expand the node corresponding to the verification that
you are interested. You see the verified files.

3  Select the files that you want to place in a module.

4 Right-click the selected files, and, from the context menu, select Add To Module.
The Add to Module dialog box opens.

5 In the text field, enter the name for your new module, for example,
Example_module. Click OK. You see a new node.

=7 CC-R2011bMain-510 (2)
+|- M| Example_module
+| [ atree

+- M| back_end

To specify a quality level for the module:

1  Select the row containing the module.
2 Under Software Quality Objectives, click the Level cell.

3 From the drop-down list, select the quality level for your module.

To remove files from a module:

Expand the node corresponding to the module.
2 Select the files that you want to remove from the module.

3 Right-click your selection, and from the context menu, select Remove From
Module. The software removes the files from the module. If you remove all files from
the module, the software also removes the module from the tree.
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Note: You can drag and drop files into and out of folders. For example, you can select
back_end and drag it to Example_module.
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Compare Project Versions

10-24

You can compare metrics of two versions of a project.

1 In the From drop-down list, select one version of your project.
2 In the To drop-down list, select a newer version of your project.
3 Select the Compare check box.

In each view, for example, Summary and Run-Time Checks, you see metric differences
and tooltip messages that indicate whether the newer version is an improvement over
the older version.



Review New Findings

Review New Findings

You can specify a project version and focus on the differences between the verification
results of your specified version and the previous verification. For example, consider a
project with versions 1.0,1.1,1.2,2.0, and 2.1.

In the To field, specify a version of your project, for example, 2.0.

2 Select the New Findings Only check box. In the From field, you see 1.2 in
dimmed lettering, which is the previous verification. The charts and tables now show
the changes in results with respect to the previous verification.

To manage the content of the bar charts, in the # items field, enter the maximum
number of files for which you want information displayed. The software displays file
defect information, ordering the files according to the number of defects in each file.
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Review Run-Time Checks

If you have installed Polyspace on your computer, you can use Polyspace Metrics to
review and add information about run-time checks produced by a verification.

You may use the Review Progress metric in the Summary view to decide when your
team of developers should start work on the next version of the software. For example,
you may wait until the review is complete (Review Progress cell displays 100%), before
informing your development team.

Consider an example, where you see the following in the Summary view.

Code Metrics Run-Time Errors Software Quality Objectives
Verificati Verification
eriieaton SIS | o || ines of Coge CONMIMed | Run-Time | Overal — Review | Justified Run-
Defects Reliability Status Progress. Time Errors
1 CC-R2011bMain-510 (2) | faled (—) 289 150473 7 87.6% FAL i MW-00-3 34% A 31% A&

Under Run-Time Errors, click a cell value. This action takes you to the Run-Time
Checks view.

Systematic Run-Time

BN e et

Confirmed |  Run-Time:

Non-terminating Constructs Software Qualtty Objectives.

Verification -
efects. | Retanity Checks | Justified | Checks Justified | Checks g;‘;lf;’ Level P'?:g':‘::‘s
) J‘ CC-R2011bMain-S10 (2) 7 876% 73537 944% 8 72 00% 1272 00% L. 9126 00% & 205 FALL £ MW-Q0-3 34% o

B 1] xref_tab 46.0% 523 100.0% 1 0.0% 5 100.0% 811 FAIL MWw-00-3 16.7%
+- 1| xref 60.3% 450 100.0% 1 100.0% 297 PASS MWw-00-3 100.0%
+- 1| widechar 85.4% 216 100.0% a7 PASS MW-00-3 100.0%
+ [ usage 75.0% 3 100.0% 1 PASS | MW-00-3 | 100.0%
+1- 11 urealp 76.6% 869 0.0% 1 0.0% 203 FAL WW-00-3 0.0%
& [ uname 815% 285 100.0% 2 0.0% 65 FAL WW-00-3 40.0%
+l- 1] vintp 83.3% 1520 100.0% 2 0.0% 18 0.0% 287 FAIL MW-00-3 7%
+- 1 types 98.2% 55 100.0% 1 PASS MWw-00-3 100.0%
+- M treepr 89.9% 587 100.0% 3 0.0% 8 0.0% 58 FAIL MWw-00-3 250%
#- [Htree_io 84.8% 129 100.0% 34 PASS | MW-00-3 | 100.0%
+1- [ tree_gen 100.0% 2 PASS | MW-00-3 | 100.0%
- 1] touid 815% 154 0.0% 35 FAL WW-00-3 0.0%

The Review Progress column reveals the progress level for each file. Expandsem chl12.
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& Systematic Run-Time | Unreac

S c;g?er;:j RR:I;;EI‘.:: Green Code| Errors (Red Checks) Non-terminating Constructs Stjﬂwﬂre Quality Objectives
Checks | Justified | Checks lustified | Checks g;’ai:g Level Pfj;::'g
=I- [ sem_ch12 1 94.0% 2843 80.0% 5 0.0% 107 0.0% 73 47 FAIL MW-Q0-3 4.4%
+| 4| g-htable. adb 88.2% 15 2
= 14/ sem_ch12.adb 1 943% 2699 5 104 58 47
ASRT - User Assertion 80.0% 4 1
K_NTC - Known Non-Termination of C 47
NIV - Non-Inttialized Variable 94.4% 611 38
NIVL - Non-Initialized Local Variable 1 99.7% 2065 1 6
QVFL (Scalar) - Overflow 59.5% 22 15
UNR - Unreachable Code 0.0% 104
ZDV (Scalar) - Division by Zero 100.0% 1

In the row containing the NIVL (Non-Initialized Local Variable) check, click the value
in the red Checks cell. This action downloads the results and opens the Polyspace user
interface. You see the NIVL check on the Results Summary tab.

Note: If you download results using Internet Explorer 11, it may take a minute or two to
open the Java plug-in and load the Polyspace interface.

To view details in the Result Details pane, double-click the NIVL check.

On the Result Details pane, using the drop-down list for the Severity field, you can
classify the check as a defect (High, Medium, or Low) or specify that the check is Not a
defect.

Using the drop-down list for the Status field, you can assign a status for the check, for
example, Fix or Investigate. When you assign a status, the software considers the

check to be reviewed.

If you think that the presence of the check in your code can be justified, select the check
box Justified. In the Comment field, enter remarks that justify this check.

Save the review. See “Saving Review Comments and Justifications” on page 10-28.

Note: Classifying a run-time check as a defect or assigning a status for an unreviewed
check in the Polyspace verification environment increases the corresponding metric
values (Confirmed Defects and Review Progress) in the Summary and Run-Time
Checks views of Polyspace Metrics.
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Specifying Download Folder for Polyspace Metrics

When you click a coding rule violation or run-time check, Polyspace downloads result
files from the Polyspace Metrics web interface to a local folder. You can specify this folder
as follows:

1 Select Options > Preferences > Server configuration.

2 If you want to download result files to the folder from which the verification is
launched, select the check box Download results automatically.

3  If this launch folder does not exist, specify another path in the Folder field.
If you do not specify a folder using step 2 or 3, when you click a violation or check, the

software opens a file browser. Use this browser to specify the download location.

Saving Review Comments and Justifications

By default, when you save your project (Ctrl+S), the software saves your comments and
justifications to a local folder. See “Specifying Download Folder for Polyspace Metrics” on
page 10-28.

If you want to save your comments and justifications to a local folder and the Polyspace
Metrics repository, select Metrics > Upload to Metrics.

This default behavior allows you to upload your review comments and justifications only
when you are satisfied that your review is, for example, correct and complete.

If you want the software to save your comments and justifications to the local folder and
the Polyspace Metrics repository whenever you save your project (Ctrl+S):

1 Select Tools > Preferences > Server configuration.

2 Select the check box Save justifications in the Polyspace Metrics repository.

C

Refresh

Note: In Polyspace Metrics, click to view updated information.




Fix Defects

Fix Defects

If you are a software developer, you can begin to fix defects in code when, for example:

* In the Summary view, Review Progress shows 100%

* Your quality assurance engineer informs you
You can use Polyspace Metrics to access defects that you must fix.

Within the Summary view, under Run-Time Errors, click a cell value. This action
takes you to the Run-Time Checks view.

You want to fix defects that are classified as defects. In the Confirmed Defects column,
click a non-zero cell value. Polyspace Code Prover opens with the checks visible in
Results Summary tab.

Double-click the row containing a check. In the Result Details pane, you see
information about this check. You can now go to the source code and fix the defect.
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Review Code Metrics

Polyspace Metrics generates metrics about your Ada code. These metrics provide the
number of:

+ Files

+ Lines of code

+ Packages

+ Packages that appear in with statements

*  Subprograms that appear in with statements

* Protected shared variables

*  Unprotected shared variables

To review code metrics for your project, in the Summary view, click a value in a Code
Metrics cell. The Code Metrics view opens.

Project Metrics

Verification Packages in | Subprograms | Protected |Mon-Protected
Files Lines of Code| Packages With in With Shared Shared
Statements | Statements Variables Variables
+-1 ") CC-R2011bMain-S10 (2) 289 150473
+- ) CC-R2011bMain-510 (1) 289 150456
+|-1 ] CC-R2011bMain-38 (2} 289 150456
+/-- 7 CC-R2011bMain-S9 (1) 280 150433
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Customizing Software Quality Objectives

In this section...

“About Customizing Software Quality Objectives” on page 10-31
“SQO Level 2” on page 10-32

“SQO Level 3” on page 10-32

“SQO Level 4” on page 10-32

“SQO Level 5” on page 10-33

“SQO Level 6” on page 10-33

“SQO Exhaustive” on page 10-33
“Run-Time Checks Set 1” on page 10-34
“Run-Time Checks Set 2” on page 10-34
“Run-Time Checks Set 3” on page 10-35
“Status Acronyms” on page 10-36

About Customizing Software Quality Objectives

When you run your first verification to produce metrics, Polyspace software uses
predefined software quality objectives (SQO) to evaluate quality. In addition, when you
use Polyspace Metrics for the first time, Polyspace creates the following XML file that
contains definitions of these software quality objectives:

RemoteDataFolder/Custom-SQO-Definitions.xml

RemoteDataFolder is the folder where Polyspace stores data generated by remote

verifications. See “Modify Polyspace Server Configuration” in the Polyspace Installation
Guide.

If you want to customize SQOs and modify the way quality is evaluated, you must change
Custom-SQO0-Definitions.xml. This XML file has the following form:

<?xml version="1.0" encoding=""utf-8"7?>
<MetricsDefinitions>

SQO Level 2

SQ0 Level 3

SQO Level 4

SQO0 Level 5

SQ0 Level 6

SQ0 Exhaustive
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Run-Time Checks Set 1
Run-Time Checks Set 2
Run-Time Checks Set 3
Status Acronym 1
Status Acronym 2
</MetricsDefinitions>

The following topics provide information about MetricsDefinitions elements and how
SQO levels are calculated. Use this information when you modify or create elements.

SQO Level 2

The default SQO Level 2 element is:

<SQO 1D="SQ0-2" ParentlD="SQ0-1">
<Num_Unjustified_Red>0</Num_Unjustified_Red>
<Num_Unjustified_NT_Constructs>0</Num_Unjustified_NT_Constructs>
</SQ0>

To fulfill requirements of SQO Level 2, the code must meet the requirements of SQO
Level 1 and the following:

*  Number of unjustified red checks Num_Unjustified Red must not be greater than
the threshold (default is zero)

*  Number of unjustified NTC and NTL checks Num_Unjustified_NT_Constructs
must not be greater than the threshold (default is zero)

SQO Level 3

The default SQO Level 3 element is:

<SQO 1D="SQ0-3" ParentlID="SQ0-2">
<Num_Unjustified_Gray>0</Num_Unjustified_Gray>
</SQ0>

To fulfill requirements of SQO Level 3, the code must meet the requirements of SQO
Level 2 and the number of unjustified UNR checks must not exceed the threshold
(default is zero).

SQO Level 4

The default SQO Level 4 element is:

<SQO ID="SQ0-4" ParentlID="SQ0-3">
<Percentage_Proven_Or_Justified>
Runtime_Checks_Set_1
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</Percentage_Proven_Or_Justified>
</SQ0>

To fulfill requirements of SQO Level 4, the code must meet the requirements of SQO
Level 3 and the following ratio as a percentage

(green checks + justified orange checks) / (green checks + all orange checks)

must not be less than the thresholds specified by “Run-Time Checks Set 1” on page
10-34.

SQO Level 5

The default SQO Level 5 element is:

<SQO ID=""SQ0-5" ParentlD="SQ0-4">
<Percentage_Proven_Or_Justified>
Runtime_Checks_Set_2
</Percentage_Proven_Or_Justified>
</SQ0>

To fulfill requirements of SQO Level 5, the code must meet the requirements of SQO
Level 4 and the percentage of green and justified checks must not be less than the
thresholds specified by “Run-Time Checks Set 2” on page 10-34.

SQO Level 6

The default SQO Level 6 element is:

<SQO ID="SQ0-6" ParentlD="SQ0-5">
<Percentage_Proven_Or_Justified>
Runtime_Checks_Set_3
</Percentage_Proven_Or_Justified>
</SQ0>

To fulfill requirements of SQO Level 6, the code must meet the requirements of SQO
Level 5 and the percentage of green and justified checks must not be less than the
thresholds specified by “Run-Time Checks Set 3” on page 10-35.

SQO Exhaustive

The default Exhaustive element is:

<SQO ID="'Exhaustive" ParentlID="SQ0-1">
<Num_Unjustified_Red>0</Num_Unjustified_Red>
<Num_Unjustified_NT_Constructs>0</Num_Unjustified_NT_Constructs>
<Num_Unjustified_Gray>0</Num_Unjustified_Gray>
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<Percentage_Proven_Or_Justified>100</Percentage_Proven_Or_Justified>
</SQ0>

Run-Time Checks Set 1

The Run-Time Checks Set 1 is composed of Check elements with data that specify
thresholds. The Name and Type attribute in each Check element defines a run-time
check, while the element data specifies a threshold in percentage. The default structure
of Run-Time Checks Set 1 is:

<RuntimeChecksSet ID="Runtime_Checks_Set_ 1'">

<Check Name="O0BAI"'">80</Check>

<Check Name='"ZDV" Type="'Scalar'>80</Check>
<Check Name="ZDV" Type="Float'>80</Check>
<Check Name="NIVL">80</Check>

<Check Name="NIV''>60</Check>

<Check Name="IRV''>80</Check>

<Check Name="FRIV''>80</Check>

<Check Name="FRV''>80</Check>

<Check Name="OVFL" Type="Scalar'>60</Check>
<Check Name="OVFL" Type="Float'>60</Check>
<Check Name="IDP'"'>60</Check>

<Check Name="NIP"'>60</Check>

<Check Name="POW''>80</Check>

<Check Name='"'SHF''>80</Check>

<Check Name="COR''>60</Check>

<Check Name="NNR''>50</Check>

<Check Name="EXCP''>50</Check>

<Check Name="EXC''>50</Check>

<Check Name="NNT''>50</Check>

<Check Name="CPP''>50</Check>

<Check Name="00P''>50</Check>

<Check Name="ASRT"'>60</Check>

</RuntimeChecksSet>

When you use Run-Time Checks Set 1 in evaluating code quality, the software calculates
the following ratio as a percentage for each run-time check in the set:

(green checks + justified orange checks)/(green checks + all orange checks)

If the percentage values do not exceed the thresholds in the set, the code meets the
quality level.

To modify the default set, you can change the check threshold values.

Run-Time Checks Set 2

This set is similar to “Run-Time Checks Set 1” on page 10-34, but has more stringent
threshold values.
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<RuntimeChecksSet ID=""Runtime_Checks_Set_2">

<Check Name="O0BAI'">90</Check>

<Check Name='"ZDV" Type="Scalar'>90</Check>
<Check Name="ZzZDV" Type="Float'>90</Check>
<Check Name="NIVL">90</Check>

<Check Name="NIV''>70</Check>

<Check Name="IRV''>90</Check>

<Check Name="FRIV''>90</Check>

<Check Name="FRV''>90</Check>

<Check Name="OVFL" Type="Scalar'>80</Check>
<Check Name="OVFL" Type="Float'>80</Check>
<Check Name="IDP'"'>70</Check>

<Check Name="NIP'"'>70</Check>

<Check Name="POW''>90</Check>

<Check Name='"'SHF''>90</Check>

<Check Name="COR''>80</Check>

<Check Name="NNR''>70</Check>

<Check Name="EXCP''>70</Check>

<Check Name="EXC''>70</Check>

<Check Name="NNT''>70</Check>

<Check Name="CPP''>70</Check>

<Check Name="00P''>70</Check>

<Check Name="ASRT"'>80</Check>

</RuntimeChecksSet>

Run-Time Checks Set 3

This set is similar to “Run-Time Checks Set 1” on page 10-34, but has more stringent
threshold values.

<RuntimeChecksSet ID="Runtime_Checks_Set_3">
<Check Name="O0BAI''>100</Check>
<Check Name="ZDV" Type="Scalar'>100</Check>
<Check Name="ZDV" Type="Float'>100</Check>
<Check Name="NIVL">100</Check>
<Check Name="NIV''>80</Check>
<Check Name="IRV''>100</Check>
<Check Name="FRIV''>100</Check>
<Check Name="FRV''>100</Check>
<Check Name="OVFL" Type="Scalar'>100</Check>
<Check Name="OVFL" Type="Float'>100</Check>
<Check Name="IDP''>80</Check>
<Check Name="NIP''>80</Check>
<Check Name="POW''>100</Check>
<Check Name='"'SHF''>100</Check>
<Check Name='""COR''>100</Check>
<Check Name="NNR''>90</Check>
<Check Name="EXCP''>90</Check>
<Check Name="EXC''>90</Check>
<Check Name="NNT''>90</Check>
<Check Name="CPP''>90</Check>
<Check Name="00P''>90</Check>
<Check Name="ASRT''>100</Check>
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</RuntimeChecksSet>

Status Acronyms

When you click a link, StatusAcronym elements are passed to the Polyspace verification
environment. This feature allows you to define, through your Polyspace server, additional
items for the drop-down list of the Status field in Result Details. See “Review Run-
Time Checks” on page 10-26.

Polyspace Metrics provides the following default elements:

<StatusAcronym Justified="yes" Name="Justify with code/model annotations"/>
<StatusAcronym Justified="yes" Name="No action planned"/>

The Name attribute specifies the name that appears on the Status field drop-down list.
If you specify the Justify attribute to yes, then when you select the item, for example,
No action planned, the software automatically selects the Justified check box. If
you do not specify the Justify attribute, then the Justified check box is not selected
automatically.

You can remove the default elements and create new StatusAcronym elements, which
are available to all users of your Polyspace server.
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Tips for Administering Results Repository

In this section...

“Through the Polyspace Metrics Web Interface” on page 10-37
“Through the Command Line” on page 10-38

“Backup of Results Repository” on page 10-39

Through the Polyspace Metrics Web Interface
You can rename or delete projects and verifications.
Project Renaming

To rename a project:

1 In your Polyspace Metrics project index, right-click the row with the project that you
want to rename.

2 From the context menu, select Rename Project.

3 Inthe Project field, enter the new name.
Project Deletion
To delete a project:

1 In your Polyspace Metrics project index, right-click the row with the project that you
want to delete.

2 From the context menu, select Delete Project from Repository.
Verification Renaming
To rename a verification:

Select the Summary view for your project.
In the Verification column, right-click the verification that you want to rename.

From the context menu, select Rename Run.

A W DN —

In the Project field, edit the text to rename the verification.
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Verification Deletion

To delete a verification:

1  Select the Summary view for your project.
2 In the Verification column, right-click the verification that you want to delete.

3 From the context menu, select Delete Run from Repository.

Through the Command Line

You can run the following batch command with various options.
Polyspace_Install/polyspace/bin/polyspace-results-repository[.exe]
* To rename a project or version, use the following options:

[-f] [-server hostname] -rename [-prog old prog -new-prog new_prog]
[-verif-version old_version -new-verif-version new_version]

hostname — Polyspace server. localhost if you run the command directly on the
server. Can be omitted if, in the Polyspace Preferences dialog box, on the Server

configuration tab, you have specified a server name. See “Modify Polyspace
Client Configuration”.

+ 0ld prog — Current project name
new_prog — New project name
+ 0ld version — Old version name
* new_version — New version name
+ —f — Specifies that a confirmation is not requested
+ To delete a project or version, use the following options:

[-f1 [-server hostname] -delete -prog prog [-verif-version version]
[-unit-by-unit]-integration]

hostname — Polyspace server. localhost if you run the command directly on the
server. Can be omitted if, in the Polyspace Preferences dialog box, on the Server

configuration tab, you have specified a server name. See “Modify Polyspace
Client Configuration”.

* prog — Project name

version — Version name. If omitted, all versions are deleted
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* unit-by-unit]-integration — Delete only unit-by-unit or integration
verifications

+ —f — Specifies that a confirmation is not requested

+ To get information about other commands, for example, retrieve a list of projects or
versions, and download and upload results, use the —h option.

Renaming and Deletion Examples

To change the name of the project psdemo_model link sl to Track Quality:

polyspace-results-repository.exe -prog psdemo_model_link_sl
-new-prog Track_Quality -rename

To delete the fifth verification run with version 1.0 of the project Track_Quality:

polyspace-results-repository.exe -prog Track Quality -verif-version 1.0
-run-number 5 -delete

To rename verification 1.2 as 1.0:

polyspace-results-repository.exe -prog Track Quality -verif-version 1.2
-new-verif-version 1.0 -rename

To rename the fourth verification run with version 1.0 as version 0.4:

polyspace-results-repository.exe -prog Track Quality -verif-version 1.0
-run-number 4 -new-verif-version 0.4 -rename

Backup of Results Repository

To preserve your Polyspace Metrics data, create a backup copy of the results repository
Polyspace RLDatas/results-repository — Polyspace RLDatas is the path to
the folder where Polyspace stores data generated by remote verifications. See “Configure
the Polyspace Server”.

For example, on a Linux system, do the following:

1 $cd Polyspace RlLDatas

2 $zip -r Path _to backup_ folder/results-repository.zip results-
repository

If you want to restore data from the backup copy:

1 $cd Polyspace RlLDatas
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2 S$unzip Path_to backup folder/results-repository.zip
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* “Install Polyspace Plug-In for Eclipse IDE” on page 11-2
+ “Verify Code in Eclipse IDE” on page 11-5
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Install Polyspace Plug-In for Eclipse IDE

11-2

You can install the Polyspace plug-in only if you have already set up the Eclipse
Integrated Development Environment (IDE). For information about downloading and
installing the Eclipse IDE, go to www.eclipse.org.

In addition to the Eclipse IDE, you must have:

* The GNATbench 2.5.1 plug-in. For more information, go to www.adacore.com.

* A GNAT compiler, a free compiler for Ada95 that is integrated into the GCC compiler
system. For more information, go to www.gnu.org/software/gnat/.

Note: On a Windows system, the GNATbench plug-in supports only the 32-bit version
of the Eclipse IDE. Therefore, on a 64-bit Windows machine, you must install the 32-
bit version of the Polyspace product. From a DOS command window, run the following
command:

DVD\Instal ler32bits\Windows\Diskl\InstData\VM\Polyspace.exe

To install the Polyspace plug-in:

1 From the Eclipse editor, select Help > Install New Software. The Install wizard
opens, displaying the Available Software page.

2 Click Add, which opens the Add Repository dialog box.

In the Name field, specify a name for your Polyspace site, for example,
Polyspace_13a.

4 Click Local, which opens the Browse for Folder dialog box.

5 Navigate to the Polyspace Install\polyspace\plugin\eclipse folder. Then
click OK.

6 Click OK, which closes the Add Repository dialog box.
7 On the Available Software page, select Polyspace Plugin for Eclipse.


http://www.eclipse.org
http://www.adacore.com
http://www.gnu.org/software/gnat/

Install Polyspace Plug-In for Eclipse IDE

2 Install = [E ]

Available Software
—
Check the items that you wish to install. i
Work with:  Polyspace_13a - filei/C:/Program Files/Polyspace/PolyspaceForADA_R2013a/polyspace/plugin/eclipse/ - Add...

Find more software by working with the "Available Software Sites” preferences.
type filter text

Name

Version
> wﬂ Polyspace Plugin for Eclipse
Select All ] l Deselect All 1item selected
Details
Show only the latest versions of available software [T] Hide items that are already installed
Group items by category What is already installed?

[~] Show only software applicable to target environment

Contact all update sites during install to find required software

8 Click Next.
9 On the Install Details page, click Next.

10 On the Review Licenses page, review and accept the license agreement. Then click
Finish.

Once you install the Polyspace plug-in, in the Eclipse editor, you have access to:

+ A Polyspace menu

+ A Polyspace Run view
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File Edit Scurce Refactor Mavigate Search Project Run [Pol}rspacT\] Window Help

m S e i &I > | Run Ctrl+R

B & Stop
= PrD_]ECtEKp|DrEF H % Configure Project

....................................... Reload Results

Close Results

Open Results in PVE

[<

Show View »

Help

Related Examples
. “Verify Code in Eclipse IDE” on page 11-5
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Verify Code in Eclipse IDE

In this section...

“Workflow for Code Verification in Eclipse IDE” on page 11-5
“Create Eclipse Project” on page 11-5
“Configure Polyspace Verification” on page 11-7

“Start Verification” on page 11-8

“Review Results” on page 11-8

Workflow for Code Verification in Eclipse IDE

You can use Polyspace software to verify Ada code that you develop within the Eclipse
Integrated Development Environment (IDE).

The workflow is:

* Use the editor to create an Eclipse project and develop code within your project.
* Set up the Polyspace verification by configuring analysis options and settings.
+ Start the verification and monitor the process.

*  Review the verification results.

Before you verify code, install the Polyspace plug-in for Eclipse IDE. See “Polyspace Plug-
In Requirements” and “Install Polyspace Plug-In for Eclipse IDE” on page 11-2.

Create Eclipse Project

+ “Creating New Project” on page 11-5
+ “Add Source Files” on page 11-7

Creating New Project

If your source files do not belong to an Eclipse project, then create a project using the
Polyspace editor:

1 Select File > New > Project to open the New Project dialog box.
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Under Wizards, select Ada > Ada Managed Project.

Note: The software supports only Ada Managed Project and Ada Standard
Project. If you use the Eclipse template General Project for Ada source files,
you may encounter problems.

Click Next to start the New Ada Project wizard.
On the Create an Ada Project page, specify the name and location of the Ada project.

Either:

a Select the Use default location check box.

b Inthe Project name field, enter a name, for example, Demo_Ada.
Or:
a Clear the Use default location check box.

b Click Browse, and select a folder, for example, C:\Test\Source_ada.

¢ Inthe Project name field, enter a name, for example, Demo_Ada.

Click Next.

On the Select Ada Toolchain and Build Type page, specify the default build
configuration for your project:

a Inthe Configuration Name field, specify the library name, for example, Hib.

b Inthe Toolchain Type field, from the drop-down list, select GNAT for
Windows (or GNAT Linux x86).

¢ Inthe Build Type field, from the drop-down list, select either Executable or
Static Library.

d Under Toolchain Path, select Use Installed Toolchain.

Click Manage to open the Preferences dialog box.

Click Add to start the Install a new Ada toolchain wizard.

On the New Ada toolchain page, specify:

a Inthe Type field, from the drop-down list, select GNAT for Windows (or GNAT
Linux x86).

b In the Name field, your toolchain, for example, GNAT GPL.
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¢ In the Path field, the path to your Ada installation folder, for example, C:\GNAT
\2009.

Click Next.

On the Select source directories page, select the folder that contains the Ada include
files, and click Finish.

Click OK to close the Preferences dialog box.

On the Select Ada Toolchain and Build Type page, under Initial Setting Values,
select Use Default Settings.

If you want to specify options for the Ada build on the Select Build Options page,
click Next. Otherwise, click Finish.

You have created an Polyspace project.

Add Source Files

To add Ada source files to a project:

B WN —

In the Ada Navigator view, right-click the project, for example, Demo_Ada.
Select Import to start the Import wizard.

On the Select page, select General > File System, and click Next.

On the File system page:

a Inthe From directory field, specify your source folder.

b In the folder or file view, select the check boxes for the folder or files that you
want to import.

¢ Inthe Into folder field, specify the project, for example, Demo_Ada.
Under Options, select Create selected folders only.
Click Finish.

For information on developing code within Eclipse IDE, go to www.eclipse.org.

Configure Polyspace Verification

To configure your verification:

1

In Project Explorer, select the project or files that you want to verify.

11-7


http://www.eclipse.org

11 Verifying Code in the Eclipse IDE

11-8

2 Select Polyspace > Configure Project to open the Configuration pane in the
Polyspace user interface.

3  Select your verification options. For more information, see “Analysis Options”.

4 Save your options and close the pane.

Start Verification

You can start a Polyspace verification from the Eclipse editor.

1

Switch to the Polyspace perspective.

a Select Window > Open Perspective > Other.

b Inthe Open Perspective dialog box, select Polyspace.

This allows you to view only the information related to a Polyspace verification.
To start a verification, do one of the following:
In the Project Explorer, right-click the project containing the files that you
want to verify and select Run Polyspace.

In the Project Explorer, select the project containing the files that you want to
verify. From the global menu, select Polyspace > Run.

Follow the progress of the verification in the Polyspace Run view.
If you see an error or warning during the compilation phase, double-click it to go

to the corresponding location in the source code. Once the verification is over, the
results are displayed in the Results Summary view.

To stop a verification, select Polyspace > Stop. Alternatively you can use the @
button in the Polyspace Run view.

Review Results

After you run a verification in Eclipse, your results open automatically on the Results
Summary view.

Review Results

1

Select a check to see detailed information on the Result Details view.
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2 In the Result Details view, to see a brief description and examples of the result,

click the '/ button next to the result name.

3 Ifyou close Eclipse or run Polyspace on another Eclipse project, your results are
closed. To reopen the results for an Eclipse project, select the project in the Project
Explorer and from the global menu, select Polyspace > Reload Results.

Save Multiple Results

The results in Eclipse are overwritten every time a new verification is performed.
However, Polyspace automatically imports Status, Severity, and Comment
information to the new verification results. If you want to save your earlier results:

1 Select Polyspace > Open Results in PVE to open your results in the Polyspace
user interface.
2 Save your results from the Polyspace user interface.

If you have setup Polyspace Metrics, upload your results to the web dashboard. For
more information, see “Generate Code Quality Metrics”.

In addition to the Results Summary and Result Details views available in Eclipse, in
the Polyspace user interface, you can use other views to:
*  View tooltips with information about variable ranges.

* Navigate the call hierarchy easily in your source code.
Results Location

Polyspace stores your results from Eclipse in the following folder:

Polyspace_Workspace\EclipseProjects\Project_Name

Where Project_Name is the name of your Eclipse project and Polyspace Workspace
is the default Polyspace project location. You can change the Polyspace Workspace in
the Polyspace interface preferences.

1 In the Polyspace interface, select Tools > Preferences.

2 On the Project and Results Folder tab, change the value of the Default project
location.

If you prefer to store your results within your Eclipse project, inside your Eclipse project
folder, create a folder named polyspace. Polyspace will save your verification results
inside this folder.
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Atomic

Batch mode

Category

Certain error

Check

Code Verification

Dead Code

Development Process

Green check
Gray check
Imprecision

Orange check

Polyspace Approach

Glossary

In computer programming, the adjective atomic describes
a unitary action or object that is essentially indivisible,
unchangeable, whole, and irreducible.

Execution of Polyspace from the command line rather
than through the Polyspace user interface.

One of four types of orange check: potential bug,
inconclusive check, data set issue and basic imprecision.

See "red check.”

A test performed by Polyspace during a verification and
subsequently colored red, orange, green or gray in the
Run-Time Checks perspective.

The Polyspace process through which code is tested to
reveal definite and potential runtime errors and a set of

results is generated for review.

Code which is inaccessible at execution time due to the
logic of the software executed prior to it.

The process used within a company to progress through
the software development lifecycle.

Code has been proven to be free of runtime errors.
Unreachable code; dead code.

Approximations are made during a Polyspace verification,
so data values possible at execution time are represented

by supersets including those values.

A warning that represents a possible error which may be
revealed upon further investigation.

The manner of use of Polyspace to achieve a particular

goal, with reference to a collection of techniques and
guiding principles.

Glossary-1



Glossary

Precision

Progress text

Red check
Review

Scaling option

Selectivity

Unreachable code

Verification

Glossary-2

A verification which includes few inconclusive orange
checks is said to be precise

Output from Polyspace during verification that indicates
what proportion of the verification has been completed.
Could be considered to be a “textual progress bar”.

Code has been proven to contain definite runtime errors
(every execution will result in an error).

Inspection of the results produced by a Polyspace
verification.

Option applied when an application submitted to
Polyspace Server proves to be bigger or more complex
than is practical.

The ratio (green checks + gray checks + red checks) / (total
amount of checks)

Dead code.

The Polyspace process through which code is tested to
reveal definite and potential runtime errors and a set of
results is generated for review.



